summaryrefslogtreecommitdiff
path: root/dev-go/goversion/goversion-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/goversion/goversion-1.2.0.ebuild')
-rw-r--r--dev-go/goversion/goversion-1.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-go/goversion/goversion-1.2.0.ebuild b/dev-go/goversion/goversion-1.2.0.ebuild
new file mode 100644
index 000000000000..d4c4b0f2d3b3
--- /dev/null
+++ b/dev-go/goversion/goversion-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="rsc.io/goversion"
+
+inherit golang-build golang-vcs-snapshot bash-completion-r1
+ARCHIVE_URI="https://github.com/rsc/goversion/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Print version used to build Go executables"
+HOMEPAGE="https://github.com/rsc/goversion https://rsc.io/goversion"
+SRC_URI="${ARCHIVE_URI}"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -o ${PN} . || die
+ popd || die
+}
+
+src_install() {
+ dobin src/${EGO_PN}/${PN}
+ dodoc src/${EGO_PN}/README.md
+}