summaryrefslogtreecommitdiff
path: root/dev-go/gogo-protobuf/gogo-protobuf-1.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/gogo-protobuf/gogo-protobuf-1.3.2.ebuild')
-rw-r--r--dev-go/gogo-protobuf/gogo-protobuf-1.3.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-go/gogo-protobuf/gogo-protobuf-1.3.2.ebuild b/dev-go/gogo-protobuf/gogo-protobuf-1.3.2.ebuild
new file mode 100644
index 000000000000..0362f8ea12fa
--- /dev/null
+++ b/dev-go/gogo-protobuf/gogo-protobuf-1.3.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Protocol Buffers for Go with Gadgets"
+HOMEPAGE="https://github.com/gogo/protobuf"
+SRC_URI="https://github.com/gogo/protobuf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+S="${WORKDIR}/protobuf-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT+=" test"
+
+src_compile() {
+ GOBIN="${S}/bin" emake install
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README
+}