summaryrefslogtreecommitdiff
path: root/dev-go/go-tour/go-tour-0_p20180810.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-tour/go-tour-0_p20180810.ebuild')
-rw-r--r--dev-go/go-tour/go-tour-0_p20180810.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-go/go-tour/go-tour-0_p20180810.ebuild b/dev-go/go-tour/go-tour-0_p20180810.ebuild
index 0266d4dd62b2..c5967f041fa4 100644
--- a/dev-go/go-tour/go-tour-0_p20180810.ebuild
+++ b/dev-go/go-tour/go-tour-0_p20180810.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,11 +20,16 @@ DEPEND="dev-go/go-net:=
src_compile() {
local x
+ # Create a temporary GOROOT, since otherwise the executable is not
+ # built if it happens to be installed already.
+ cp -rs "$(go env GOROOT)" "${T}/goroot" || die
+ rm -rf "${T}/goroot/"{pkg/tool/$(go env GOOS)_$(go env GOARCH)/tour,src/${EGO_PN%/...}} || die
mkdir -p "${T}/golibdir/src/golang.org/x" || die
for x in net tools; do
ln -s "$(get_golibdir_gopath)/src/golang.org/x/${x}" "${T}/golibdir/src/golang.org/x/${x}" || die
done
- GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" \
+ export -n GOCACHE XDG_CACHE_HOME #567192
+ GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" GOROOT=${T}/goroot \
go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
[[ -x bin/gotour ]] || die "gotour not found"
}