summaryrefslogtreecommitdiff
path: root/dev-go/go-text
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-text')
-rw-r--r--dev-go/go-text/Manifest6
-rw-r--r--dev-go/go-text/go-text-0_pre20150806.ebuild49
-rw-r--r--dev-go/go-text/go-text-0_pre20160211.ebuild50
-rw-r--r--dev-go/go-text/go-text-9999.ebuild48
-rw-r--r--dev-go/go-text/metadata.xml10
5 files changed, 163 insertions, 0 deletions
diff --git a/dev-go/go-text/Manifest b/dev-go/go-text/Manifest
new file mode 100644
index 000000000000..7c8ed026b362
--- /dev/null
+++ b/dev-go/go-text/Manifest
@@ -0,0 +1,6 @@
+DIST go-text-0_pre20150806.tar.gz 3736536 BLAKE2B afc6a95116426f9b981432c772c374cb3c84d300e81af1599383be74d00830556d36ff614d88e8952b89974ecb238b77725a3d1a83dc65a0f85dafa3d29a2dff SHA512 dd0fc8b5abdfa6f005316bb7828c03a081485e0bd33cbf86c0b83f8bf9240973a7b0a2e6f52ef75f48ec00fc922be21a6c65ff9eb4080f28cb3f280bd4c4f5c6
+DIST go-text-0_pre20160211.tar.gz 4015547 BLAKE2B ad85f27761e2fd91a6acff497fe9b720484d51c6d75032c02fe21784dff78b4b900ac95aab394a6db1f7b2c9fb5a3d1cbde8db2aaa4c099b19357d82f747eb89 SHA512 066e53f6e094a6cf3effe1a9376f7bde41c3059099381bb5adf8c84589de4dab9115ce3c8cb7f89f90e2601422f79e3906f8f498d66e364da9f830ede1f7f05f
+EBUILD go-text-0_pre20150806.ebuild 1234 BLAKE2B d61eeacd7b8f6af3bc9b3957d350d52d103169cb49e9dc1ead669dbd1669a683d7792e67a52a19af57b5a15b79cc30a4b85bef7bd47501ea6495565d07503c8c SHA512 d058c7b320013440f938b91a1ac9cd2224d2bf329d8aab45dfd57db319cffdbb3a8e709d1b3fe240b7ee64e9788fb2ac0bc0b0698750fc6bee8885e72c334180
+EBUILD go-text-0_pre20160211.ebuild 1372 BLAKE2B 79842e705e299769a14b12735ae09eec6788cfdbdb0a29050356575ce0706f9e4bc34c0d1b0e957161f2ea9cff7d62fd653780d507621b426b0df8894afd7d18 SHA512 09a680a57e682d51a5929b7c08680c14aea25bbb816e61865942166c8ff30230d36143bd11174f8d0c84170e3020a06c5a9a8a9973d50d90c7e53bda763f3fb9
+EBUILD go-text-9999.ebuild 1218 BLAKE2B 2a2e2e29d6779d523b3baa05a3ec36532b29d79ba1459117580185ab1d9633d636288f1385fd8e615ab933ef2820d9006acaa36e0db5585dc1b1579e6f96d4df SHA512 8042d1fe75b9064c2e24ec36d13b1204d6b4f2710cfc2be231bc0ca435568b1c83afc2623cc9f5d37d36c8f7ab364d8242500c444a9a327ed85c05bc6274dc29
+MISC metadata.xml 302 BLAKE2B a05f70c06783ee19acede14cc45403fc3c66b6ba9d9d60a46ff406187bc3d0b4d60a37896b8d5099c3a883442ee11700c2692397dd9f86606807c4f3ea69ec1c SHA512 d6011dea76488098287ce6c436fd8c8b2b3607153611121b2ebd0b67be11629e8eb1318d460474c355fe8828c0bb0836db4fbae351f49bbbd7448c37f5a572ca
diff --git a/dev-go/go-text/go-text-0_pre20150806.ebuild b/dev-go/go-text/go-text-0_pre20150806.ebuild
new file mode 100644
index 000000000000..3fb9794a126a
--- /dev/null
+++ b/dev-go/go-text/go-text-0_pre20150806.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+EGO_PN=golang.org/x/text/...
+EGO_SRC=golang.org/x/text
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="1309a1875a4368c12688b9383c6bcac738c17c29"
+ SRC_URI="https://github.com/golang/text/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go text processing support"
+HOMEPAGE="https://godoc.org/golang.org/x/text"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ cp -sR "$(go env GOROOT)" "${T}/goroot" || die
+ rm -rf "${T}/goroot/src/${EGO_SRC}" || die
+ rm -rf "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" || die
+ export GOROOT="${T}/goroot"
+ golang-build_src_compile
+}
+
+src_test() {
+ # Create go symlink for TestLinking in display/dict_test.go
+ mkdir -p "${GOROOT}/bin"
+ ln -s /usr/bin/go "${GOROOT}/bin/go" || die
+ golang-build_src_test
+}
+
+src_install() {
+ golang-build_src_install
+ export -n GOROOT
+ exeopts -m0755 -p # preserve timestamps for bug 551486
+ exeinto "$(go env GOROOT)/bin"
+ doexe bin/*
+}
diff --git a/dev-go/go-text/go-text-0_pre20160211.ebuild b/dev-go/go-text/go-text-0_pre20160211.ebuild
new file mode 100644
index 000000000000..979b835ba8c6
--- /dev/null
+++ b/dev-go/go-text/go-text-0_pre20160211.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+EGO_PN=golang.org/x/text/...
+EGO_SRC=golang.org/x/text
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ EGIT_COMMIT="07b9a78963006a15c538ec5175243979025fa7a8"
+ SRC_URI="https://github.com/golang/text/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go text processing support"
+HOMEPAGE="https://godoc.org/golang.org/x/text"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ cp -sR "$(go env GOROOT)" "${T}/goroot" || die
+ rm -rf "${T}/goroot/src/${EGO_SRC}" || die
+ rm -rf "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" || die
+ export GOROOT="${T}/goroot"
+ golang-build_src_compile
+}
+
+src_install() {
+ golang-build_src_install
+ export -n GOROOT
+ exeopts -m0755 -p # preserve timestamps for bug 551486
+ exeinto "$(go env GOROOT)/bin"
+ doexe bin/*
+}
+
+src_test() {
+ # omit $(get_golibdir_gopath) from GOPATH:
+ #package golang.org/x/text/display (test)
+ # imports golang.org/x/text/internal/testtext: use of internal package not allowed
+ #FAIL golang.org/x/text/display [setup failed]
+ GOPATH="${WORKDIR}/${P}" go test -v -work -x "${EGO_PN}" || die
+}
diff --git a/dev-go/go-text/go-text-9999.ebuild b/dev-go/go-text/go-text-9999.ebuild
new file mode 100644
index 000000000000..5768c80ac6f4
--- /dev/null
+++ b/dev-go/go-text/go-text-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+EGO_PN=golang.org/x/text/...
+EGO_SRC=golang.org/x/text
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="df923bbb63f8ea3a26bb743e2a497abd0ab585f7"
+ SRC_URI="https://github.com/golang/text/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go text processing support"
+HOMEPAGE="https://godoc.org/golang.org/x/text"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_test() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ cp -sR "$(go env GOROOT)" "${T}/goroot" || die
+ if [ -d "${T}/goroot/src/${EGO_SRC}" ]; then
+ rm -rf "${T}/goroot/src/${EGO_SRC}" || die
+ fi
+ if [ -d "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" ]; then
+ rm -rf "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" ||
+ die
+ fi
+
+ # Create go symlink for TestLinking in display/dict_test.go
+ mkdir -p "${T}/goroot/bin"
+ ln -s /usr/bin/go "${T}/goroot/bin/go" || die
+
+ GOROOT="${T}/goroot" golang-build_src_test
+}
+
+src_install() {
+ golang-build_src_install
+ dobin bin/*
+}
diff --git a/dev-go/go-text/metadata.xml b/dev-go/go-text/metadata.xml
new file mode 100644
index 000000000000..52a350b9d8f5
--- /dev/null
+++ b/dev-go/go-text/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">golang/text</remote-id>
+ </upstream>
+</pkgmetadata>