summaryrefslogtreecommitdiff
path: root/dev-go/go-sys/go-sys-0_pre20160204.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-sys/go-sys-0_pre20160204.ebuild')
-rw-r--r--dev-go/go-sys/go-sys-0_pre20160204.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-go/go-sys/go-sys-0_pre20160204.ebuild b/dev-go/go-sys/go-sys-0_pre20160204.ebuild
new file mode 100644
index 000000000000..8d00e6d5ff8f
--- /dev/null
+++ b/dev-go/go-sys/go-sys-0_pre20160204.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+EGO_PN=golang.org/x/sys/...
+EGO_SRC=golang.org/x/sys
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="50c6bc5e4292a1d4e65c6e9be5f53be28bcbe28e"
+ SRC_URI="https://github.com/golang/sys/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go packages for low-level interaction with the operating system"
+HOMEPAGE="https://godoc.org/golang.org/x/sys"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ cp -sR "$(go env GOROOT)" "${T}/goroot" || die
+ rm -rf "${T}/goroot/src/${EGO_SRC}" || die
+ rm -rf "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" || die
+ export GOROOT="${T}/goroot"
+ golang-build_src_compile
+}