summaryrefslogtreecommitdiff
path: root/dev-go/go-resiliency/go-resiliency-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-resiliency/go-resiliency-1.0.0.ebuild')
-rw-r--r--dev-go/go-resiliency/go-resiliency-1.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-go/go-resiliency/go-resiliency-1.0.0.ebuild b/dev-go/go-resiliency/go-resiliency-1.0.0.ebuild
new file mode 100644
index 000000000000..06788f608c0c
--- /dev/null
+++ b/dev-go/go-resiliency/go-resiliency-1.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+EGO_SRC=github.com/eapache/go-resiliency
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Resiliency patterns for golang"
+HOMEPAGE="https://github.com/eapache/go-resiliency"
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""