summaryrefslogtreecommitdiff
path: root/dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild')
-rw-r--r--dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild b/dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild
new file mode 100644
index 000000000000..0b686e9c4867
--- /dev/null
+++ b/dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+EGO_SRC=github.com/golang/protobuf
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="127091107ff5f822298f1faa7487ffcf578adcf6"
+ SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go support for Google's protocol buffers"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+ dobin bin/*
+}