summaryrefslogtreecommitdiff
path: root/dev-go/go-crypto/go-crypto-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-crypto/go-crypto-9999.ebuild')
-rw-r--r--dev-go/go-crypto/go-crypto-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-go/go-crypto/go-crypto-9999.ebuild b/dev-go/go-crypto/go-crypto-9999.ebuild
new file mode 100644
index 000000000000..6cee16b68553
--- /dev/null
+++ b/dev-go/go-crypto/go-crypto-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+EGO_PN=golang.org/x/crypto/...
+EGO_SRC=golang.org/x/crypto
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="1e856cbfdf9bc25eefca75f83f25d55e35ae72e0"
+ SRC_URI="https://github.com/golang/crypto/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go supplementary cryptography libraries"
+HOMEPAGE="https://godoc.org/golang.org/x/crypto"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ # disable broken tests
+ sed -e 's:TestAgentForward(:_\0:' \
+ -i src/${EGO_SRC}/ssh/test/agent_unix_test.go || die
+ sed -e 's:TestRunCommandSuccess(:_\0:' \
+ -e 's:TestRunCommandStdin(:_\0:' \
+ -e 's:TestRunCommandStdinError(:_\0:' \
+ -e 's:TestRunCommandWeClosed(:_\0:' \
+ -e 's:TestFuncLargeRead(:_\0:' \
+ -e 's:TestKeyChange(:_\0:' \
+ -e 's:TestValidTerminalMode(:_\0:' \
+ -i src/${EGO_SRC}/ssh/test/session_test.go || die
+}