summaryrefslogtreecommitdiff
path: root/dev-gap/hap
diff options
context:
space:
mode:
Diffstat (limited to 'dev-gap/hap')
-rw-r--r--dev-gap/hap/Manifest3
-rw-r--r--dev-gap/hap/hap-1.60.ebuild54
-rw-r--r--dev-gap/hap/metadata.xml34
3 files changed, 91 insertions, 0 deletions
diff --git a/dev-gap/hap/Manifest b/dev-gap/hap/Manifest
new file mode 100644
index 000000000000..1f02194c1c15
--- /dev/null
+++ b/dev-gap/hap/Manifest
@@ -0,0 +1,3 @@
+DIST hap-1.60.tar.gz 21322579 BLAKE2B 2ac276e33109fa6bb975ebe6f0cf1f503e9e6b3b29a2f4381723e84ba8659f54ddb66cec0470894d01edd64894691febb098a34a1e6366162037ea229a7c0e74 SHA512 fe121efe7d65d1ea7f156ff4cca04eeb95591ea44343b562ff34cbf5a702301630a8a92f7aca1ac12a46b9058b54b88fbd42621c1cdedaebf5e5702c72a34416
+EBUILD hap-1.60.ebuild 1407 BLAKE2B e22218fe72e32145ad0984baeeb62724b6c2684af1f3232819b3d09b58ea672948c842a65962ab2474ec7174d9213b5c1a91af442ae9d01acd005b0e4a99ae58 SHA512 5100c12597122c82e45d41f98e2fc4bd254229aa8ff445f1d2e6f366847354ce83be8da727cd41cdf64689474047b1a942644312819ef99052547726e77409c2
+MISC metadata.xml 1377 BLAKE2B a210ac56246e1de6b3b1241045ede74c3997e7f8d2333bb5e307f24eb8e988b283a3971d538261a01d7f87a95fecff1266219ae7eb46d4b6164f8514a03f2fbd SHA512 8f38dcd881412d137e40361816a718de94bbcfe8d87cafe36d9bc8ea6a4fd07a617e2d5f4f37b2d2f46df9ab7f1a0d0ec8dfa7300bc4b074a4009d341349eb39
diff --git a/dev-gap/hap/hap-1.60.ebuild b/dev-gap/hap/hap-1.60.ebuild
new file mode 100644
index 000000000000..ef7a1b6988d4
--- /dev/null
+++ b/dev-gap/hap/hap-1.60.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="Homological Algebra Programming (HAP) in GAP"
+SRC_URI="https://github.com/gap-packages/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-gap/aclib
+ dev-gap/crystcat
+ dev-gap/fga
+ dev-gap/nq
+ dev-gap/polycyclic"
+
+# Singular: https://docs.gap-system.org/pkg/hap/doc/chap14.html
+# EDIM: https://docs.gap-system.org/pkg/hap/doc/chap11.html
+# congruence is needed for ResolutionSL2Z()
+# tst/testextra/3.6.1.tst calls LieAlgebra() from laguna
+# EquivariantEuclideanSpace() in tst/testallV11/1.8.1.tst needs hapcryst
+#
+# The imagemagick "convert" utility is used in a few places, and it does
+# actually need to be imagemagick (and not graphicsmagick) because e.g.
+# ReadImageAsPureCubicalComplex parses the comment that only imagemagick
+# puts at the top of a text file:
+#
+# https://github.com/gap-packages/hap/issues/115
+#
+BDEPEND="test? (
+ dev-gap/congruence
+ dev-gap/edim
+ dev-gap/hapcryst
+ dev-gap/laguna
+ dev-gap/polymaking
+ dev-gap/singular
+ media-gfx/imagemagick[png]
+)"
+
+HTML_DOCS="www/* tutorial"
+
+GAP_PKG_EXTRA_INSTALL=( boolean )
+gap-pkg_enable_tests
+
+pkg_postinst() {
+ elog "Some optional functions require media-gfx/graphviz"
+ elog "to be installed at runtime."
+}
diff --git a/dev-gap/hap/metadata.xml b/dev-gap/hap/metadata.xml
new file mode 100644
index 000000000000..147ed3e9c377
--- /dev/null
+++ b/dev-gap/hap/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ HAP is a package for some calculations in elementary algebraic
+ topology and the cohomology of groups. The initial focus of the
+ library was on computations related to the cohomology of finite and
+ infinite groups, with particular emphasis on integral
+ coefficients. The focus has since broadened to include Steenrod
+ algebras of finite groups, Bredon homology, cohomology of simplicial
+ groups, and general computations in algebraic topology relating to
+ finite CW-complexes, covering spaces, knots, knotted surfaces, and
+ topics such as persitent homology arising in topological data
+ analysis.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/hap</remote-id>
+ </upstream>
+</pkgmetadata>