summaryrefslogtreecommitdiff
path: root/dev-games/tiled
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/tiled')
-rw-r--r--dev-games/tiled/Manifest5
-rw-r--r--dev-games/tiled/files/tiled-1.11.0-python.patch55
-rw-r--r--dev-games/tiled/metadata.xml15
-rw-r--r--dev-games/tiled/tiled-1.11.0.ebuild88
4 files changed, 160 insertions, 3 deletions
diff --git a/dev-games/tiled/Manifest b/dev-games/tiled/Manifest
index 5b0821445f69..77db3dbf9b9d 100644
--- a/dev-games/tiled/Manifest
+++ b/dev-games/tiled/Manifest
@@ -1,3 +1,6 @@
+AUX tiled-1.11.0-python.patch 2156 BLAKE2B 0a6686c1694ccfce7c114618e783f214f2d3c6c22e444793e6fbf3de9d74f7a278fe5779796a2d7e255e6af525f7973206b730a879eec33c3da7d5881da58be7 SHA512 2b7fcaeddcd0d8495942be03fb8e75d5cf8dbeeb54cdc2079597de8ce1e282254436b31697cf1159d5b2f4dfd32b2a7166aa41456189d6545d2c44de63697112
+DIST tiled-1.11.0.tar.gz 17458724 BLAKE2B 3e7ea2ce4a61aa31d60487bf4cd68efb9307be0a753ee1571b9d2a90dff5299fdbbfd432c38eddafbea98cd6a1c59aa338c9ab5337e923e3178456a720e24ed4 SHA512 59e7ff38bedb0b897b40b2d3f6231004970de843e3700ef8adfaf78ab9b15c57e291ec27d409ba61094871b84f27238defb33bef5b23e838736f515ec1addf5d
DIST tiled-1.8.6.tar.gz 17053221 BLAKE2B a226ff9861ebfa3980176fac2b23c7fff8ac6db585444c5d5c21afff2301298e1eaa74179970bfaeb07c62074c706378040c520d5f0155b030f9e2025c51abb0 SHA512 f77ff46fbb707d8c02499f168e5748f39081fa780fb9a5b1ea04603b09cd71280d76034cab28b23fc30280bd856121e473c992c9c39d7c46fc97d5fbfbe4191d
+EBUILD tiled-1.11.0.ebuild 2203 BLAKE2B 51676137495dc207d23e8213a3ca91048a40b900ad3ff087a41b9a98d692f816e124df223111b297437684f949a855064ea046aeb259cfd84168b2ad6582a5af SHA512 c1200cb4e38b129cbc44c2b9affdddfd757c3127a12b84f92414ec2d5cbc4fa4134902433fea83e20cd8a35de9410df5eddeaa0517e74276eca7e8c5989bc06a
EBUILD tiled-1.8.6.ebuild 1428 BLAKE2B 1f6e4358ed7c07c34e599c55e8b3f243b58116ddd993d4e17d24d24bacbea7c416de3d4f4bff867bf1a1b7c16129216b3b862f6ba90b25debd25f629a9e834a9 SHA512 14e48dc91b99b6aaf4883de5f36d172e41eeed4c59882ed0bd649c24eb6ce48695560edf83cf1d3c1d6ab59e2265eca8d2530f2affded2be7c38fb14642645b2
-MISC metadata.xml 244 BLAKE2B e2a5c9db87398a2d71e19839436da90e8c76d01ebcdd50ee2ec7155cd822a9243a4587ac7c076616163d198d421ab33a62594003d9e99227eba84c48e43e7b46 SHA512 2e780fa40e1032d4cbe0f59fd7df73ffdda34d3fbb378529065a37590e99d3a8d4579481b9c4e0279a77d13e82dd99424990db370d710dc9b689a44b2b27d955
+MISC metadata.xml 575 BLAKE2B 67eae166f5a7e6f93eb2f550a259d642ff5372de2bc19c82eaaceacf6255378f81541c92b5200df3c2d3206baf008b06de1cebdb7380f9fd48a77a96f2248b3d SHA512 25c2670f6f3b08cf951641ea50b7f62c528b192e850ea5923c5092349d750166c73979a7d54ad5a3ba40c62778cdcfde9d555e0af4c7def99075aa8921339b10
diff --git a/dev-games/tiled/files/tiled-1.11.0-python.patch b/dev-games/tiled/files/tiled-1.11.0-python.patch
new file mode 100644
index 000000000000..f5407045e019
--- /dev/null
+++ b/dev-games/tiled/files/tiled-1.11.0-python.patch
@@ -0,0 +1,55 @@
+diff --git a/qbs/imports/PythonProbe.qbs b/qbs/imports/PythonProbe.qbs
+index 52eae7fc..93b4270c 100644
+--- a/qbs/imports/PythonProbe.qbs
++++ b/qbs/imports/PythonProbe.qbs
+@@ -7,7 +7,6 @@ import qbs.Utilities
+ Probe {
+ id: pythonDllProbe
+
+- property string pythonDir: pythonInstallDir // Input
+ property string buildVariant: qbs.buildVariant // Input
+ property string minVersion: "3.5" // Input
+ property string fileNamePrefix // Output
+@@ -17,18 +16,9 @@ Probe {
+ console.warn(msg + " The Python plugin will not be available.");
+ }
+
+- if (!pythonDir) {
+- printWarning("PYTHONHOME not set.");
+- return;
+- }
+- if (!File.exists(pythonDir)) {
+- printWarning("The provided Python installation directory '" + pythonDir
+- + "' does not exist.");
+- return;
+- }
+ var p = new Process();
+ try {
+- var pythonFilePath = FileInfo.joinPaths(pythonDir, "python.exe");
++ var pythonFilePath = "python";
+ p.exec(pythonFilePath, ["--version"], true);
+ var output = p.readStdOut().trim();
+ var magicPrefix = "Python ";
+@@ -45,9 +35,7 @@ Probe {
+ return;
+ }
+ if (Utilities.versionCompare(versionNumberString, minVersion) < 0) {
+- printWarning("The Python installation at '" + pythonDir
+- + "' has version " + versionNumberString + ", but " + minVersion + " or higher "
+- + "is required.");
++ printWarning("The Python installation has version " + versionNumberString + ", but " + minVersion + " or higher " + "is required.");
+ return;
+ }
+ found = true;
+diff --git a/src/plugins/python/python.qbs b/src/plugins/python/python.qbs
+index f1c959d3..8c43af9c 100644
+--- a/src/plugins/python/python.qbs
++++ b/src/plugins/python/python.qbs
+@@ -28,7 +28,6 @@ TiledPlugin {
+
+ PythonProbe {
+ id: pythonDllProbe
+- pythonDir: Environment.getEnv("PYTHONHOME")
+ minVersion: "3.8"
+ }
+
diff --git a/dev-games/tiled/metadata.xml b/dev-games/tiled/metadata.xml
index 13233bbdb862..d6abd76eacce 100644
--- a/dev-games/tiled/metadata.xml
+++ b/dev-games/tiled/metadata.xml
@@ -1,8 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>mechakotik@gmail.com</email>
+ <name>Andrei Sabalenka</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
- <remote-id type="github">bjorn/tiled</remote-id>
+ <remote-id type="github">mapeditor/tiled</remote-id>
</upstream>
+ <use>
+ <flag name="minimal">Exclude optional plugins and development headers</flag>
+ </use>
</pkgmetadata>
+
diff --git a/dev-games/tiled/tiled-1.11.0.ebuild b/dev-games/tiled/tiled-1.11.0.ebuild
new file mode 100644
index 000000000000..c23e32344f0e
--- /dev/null
+++ b/dev-games/tiled/tiled-1.11.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+inherit edo flag-o-matic multiprocessing python-single-r1 toolchain-funcs xdg
+
+DESCRIPTION="A general purpose tile map editor"
+HOMEPAGE="https://www.mapeditor.org/ https://github.com/mapeditor/tiled"
+SRC_URI="https://github.com/mapeditor/tiled/archive/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="minimal python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ app-arch/zstd:=
+ dev-qt/qtbase:6[X,dbus,gui,network,opengl,widgets]
+ dev-qt/qtdeclarative:6
+ dev-qt/qtsvg:6
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/qbs
+ dev-qt/qtbase:6
+ dev-qt/qttools:6[linguist]
+"
+
+QBS_PRODUCTS="tiled,csv,json"
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+qbs_format_flags() {
+ local -a array
+ for flag in ${@}; do
+ array+=( "\"${flag}\"" )
+ done
+ echo "[$(IFS=","; echo "${array[*]}")]"
+}
+
+src_configure() {
+ if use python; then
+ eapply "${FILESDIR}"/${P}-python.patch
+ QBS_PRODUCTS="${QBS_PRODUCTS},python"
+ fi
+ if ! use minimal; then
+ QBS_PRODUCTS="${QBS_PRODUCTS},defold,defoldcollection,droidcraft,flare,gmx,json1,lua,replicaisland,rpmap,tbin,tengine,terraingenerator,tmxrasterizer,tmxviewer,tscn,yy"
+ fi
+
+ edo qbs setup-qt /usr/bin/qmake6 qt6
+ edo qbs config defaultProfile qt6
+
+ local toolchain=$(tc-get-compiler-type)
+ edo qbs setup-toolchains ${toolchain} ${toolchain}
+ edo qbs config profiles.qt6.baseProfile ${toolchain}
+
+ edo qbs resolve \
+ --force-probe-execution \
+ qbs.installPrefix:"/usr" \
+ projects.Tiled.useRPaths:false \
+ projects.Tiled.installHeaders:$(usex minimal false true) \
+ project.libDir:$(get_libdir) \
+ modules.cpp.cFlags:$(qbs_format_flags ${CFLAGS}) \
+ modules.cpp.cxxFlags:$(qbs_format_flags ${CXXFLAGS}) \
+ modules.cpp.linkerFlags:$(qbs_format_flags $(raw-ldflags ${LDFLAGS}))
+}
+
+src_compile() {
+ edo qbs build \
+ -p ${QBS_PRODUCTS} \
+ -j $(get_makeopts_jobs)
+}
+
+src_install() {
+ edo qbs install -p ${QBS_PRODUCTS} --install-root "${D}"
+
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+}