summaryrefslogtreecommitdiff
path: root/dev-games/recastnavigation/recastnavigation-1.5.1_p20210305.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/recastnavigation/recastnavigation-1.5.1_p20210305.ebuild')
-rw-r--r--dev-games/recastnavigation/recastnavigation-1.5.1_p20210305.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-games/recastnavigation/recastnavigation-1.5.1_p20210305.ebuild b/dev-games/recastnavigation/recastnavigation-1.5.1_p20210305.ebuild
deleted file mode 100644
index 7f703bf0120d..000000000000
--- a/dev-games/recastnavigation/recastnavigation-1.5.1_p20210305.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Navigation mesh construction toolset for games"
-HOMEPAGE="https://github.com/recastnavigation/recastnavigation"
-MY_COMMIT="c5cbd53024c8a9d8d097a4371215e3342d2fdc87"
-SRC_URI="https://github.com/recastnavigation/recastnavigation/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_COMMIT}"
-
-LICENSE="ZLIB"
-SLOT="0/1.5.1"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-cpp/catch )"
-
-src_prepare() {
- rm Tests/catch.hpp || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- append-cppflags "-I${ESYSROOT}/usr/include/catch2"
-
- local mycmakeargs=(
- -DRECASTNAVIGATION_DEMO=OFF
- -DRECASTNAVIGATION_EXAMPLES=OFF
- -DRECASTNAVIGATION_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}