summaryrefslogtreecommitdiff
path: root/dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-cmake.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-cmake.patch')
-rw-r--r--dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-cmake.patch53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-cmake.patch b/dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-cmake.patch
deleted file mode 100644
index e5cac15373d8..000000000000
--- a/dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-cmake.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -ruN osgQt-3.5.5/CMakeLists.txt my/CMakeLists.txt
---- osgQt-3.5.5/CMakeLists.txt 2016-09-20 07:11:32.000000000 +0200
-+++ my/CMakeLists.txt 2017-05-18 04:11:06.929237731 +0200
-@@ -543,15 +543,7 @@
- SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -D_DEBUG")
- ENDIF()
-
--IF(UNIX AND NOT WIN32 AND NOT APPLE)
-- IF(CMAKE_SIZEOF_VOID_P MATCHES "8")
-- SET(LIB_POSTFIX "64" CACHE STRING "suffix for 32/64 dir placement")
-- MARK_AS_ADVANCED(LIB_POSTFIX)
-- ENDIF()
--ENDIF()
--IF(NOT DEFINED LIB_POSTFIX)
-- SET(LIB_POSTFIX "")
--ENDIF()
-+SET(LIB_POSTFIX ${LIB_SUFFIX})
-
- # Here we apparantly do some funky stuff with making the bin/ and lib/
- # folders which is probably needed to work around a very old CMake bug?
-@@ -877,7 +869,7 @@
- ${PROJECT_BINARY_DIR}/doc/OpenSceneGraphReferenceDocs/osg32-32.png COPYONLY
- )
- #INSTALL(FILES ${PROJECT_BINARY_DIR}/doc/${PROJECT_NAME}ReferenceDocs-${OPENSCENEGRAPH_VERSION}.chm DESTINATION doc OPTIONAL COMPONENT openscenegraph-doc)
-- INSTALL(DIRECTORY ${PROJECT_BINARY_DIR}/doc/OpenSceneGraphReferenceDocs DESTINATION doc COMPONENT openscenegraph-doc)
-+ INSTALL(DIRECTORY ${PROJECT_BINARY_DIR}/doc/OpenSceneGraphReferenceDocs DESTINATION ${GENTOO_DOCDIR} COMPONENT openscenegraph-doc)
-
- # now set up openthreads documentation generation
- IF(BUILD_REF_DOCS_TAGFILE)
-@@ -893,7 +885,7 @@
- ${PROJECT_BINARY_DIR}/doc/OpenThreadsReferenceDocs/osg32-32.png COPYONLY
- )
- #INSTALL(FILES ${PROJECT_BINARY_DIR}/doc/${PROJECT_NAME}ReferenceDocs-${OPENSCENEGRAPH_VERSION}.chm DESTINATION doc OPTIONAL COMPONENT openscenegraph-doc)
-- INSTALL(DIRECTORY ${PROJECT_BINARY_DIR}/doc/OpenThreadsReferenceDocs DESTINATION doc COMPONENT openthreads-doc)
-+ INSTALL(DIRECTORY ${PROJECT_BINARY_DIR}/doc/OpenThreadsReferenceDocs DESTINATION ${GENTOO_DOCDIR} COMPONENT openthreads-doc)
-
- # Process our other doxyfiles but don't create targets for these
- CONFIGURE_FILE(${PROJECT_SOURCE_DIR}/doc/Doxyfiles/all_Doxyfile
-diff -ruN osgQt-3.5.5/CMakeModules/OsgMacroUtils.cmake my/CMakeModules/OsgMacroUtils.cmake
---- osgQt-3.5.5/CMakeModules/OsgMacroUtils.cmake 2016-09-20 07:11:32.000000000 +0200
-+++ my/CMakeModules/OsgMacroUtils.cmake 2017-05-18 04:30:26.646257926 +0200
-@@ -462,9 +462,9 @@
- IF(APPLE)
- INSTALL(TARGETS ${TARGET_TARGETNAME} RUNTIME DESTINATION share/OpenSceneGraph/bin BUNDLE DESTINATION share/OpenSceneGraph/bin )
- ELSE(APPLE)
-- INSTALL(TARGETS ${TARGET_TARGETNAME} RUNTIME DESTINATION share/OpenSceneGraph/bin COMPONENT openscenegraph-examples )
-+ INSTALL(TARGETS ${TARGET_TARGETNAME} RUNTIME DESTINATION bin COMPONENT openscenegraph-examples )
- IF(MSVC AND NOT CMAKE_BUILD_TYPE STREQUAL "Release")
-- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${TARGET_TARGETNAME}${CMAKE_BUILD_POSTFIX}.pdb DESTINATION share/OpenSceneGraph/bin COMPONENT openscenegraph-examples)
-+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${TARGET_TARGETNAME}${CMAKE_BUILD_POSTFIX}.pdb DESTINATION bin COMPONENT openscenegraph-examples)
- ENDIF(MSVC AND NOT CMAKE_BUILD_TYPE STREQUAL "Release")
- ENDIF(APPLE)
-