summaryrefslogtreecommitdiff
path: root/dev-games/mercator/mercator-0.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/mercator/mercator-0.3.3.ebuild')
-rw-r--r--dev-games/mercator/mercator-0.3.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-games/mercator/mercator-0.3.3.ebuild b/dev-games/mercator/mercator-0.3.3.ebuild
new file mode 100644
index 000000000000..92cdc48b0a23
--- /dev/null
+++ b/dev-games/mercator/mercator-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="WorldForge library primarily aimed at terrain"
+HOMEPAGE="https://www.worldforge.org/index.php/components/mercator/"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+SLOT="0"
+
+RDEPEND=">=dev-games/wfmath-1"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_compile() {
+ default
+ use doc && emake docs
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/*
+ prune_libtool_files
+}