summaryrefslogtreecommitdiff
path: root/dev-games/hawknl/hawknl-1.68-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/hawknl/hawknl-1.68-r3.ebuild')
-rw-r--r--dev-games/hawknl/hawknl-1.68-r3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-games/hawknl/hawknl-1.68-r3.ebuild b/dev-games/hawknl/hawknl-1.68-r3.ebuild
index ce4f26e97a9c..4011847e391d 100644
--- a/dev-games/hawknl/hawknl-1.68-r3.ebuild
+++ b/dev-games/hawknl/hawknl-1.68-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="A cross-platform network library designed for games"
HOMEPAGE="http://www.hawksoft.com/hawknl/"
@@ -20,6 +20,10 @@ PATCHES=( "${FILESDIR}"/${P}-build.patch )
src_configure() {
tc-export CC
+
+ # bug #855311
+ append-flags -fno-strict-aliasing
+ filter-lto
}
src_compile() {