summaryrefslogtreecommitdiff
path: root/dev-games/godot/godot-3.5.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/godot/godot-3.5.3.ebuild')
-rw-r--r--dev-games/godot/godot-3.5.3.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/dev-games/godot/godot-3.5.3.ebuild b/dev-games/godot/godot-3.5.3.ebuild
index 52470f766d26..c4e78535e32d 100644
--- a/dev-games/godot/godot-3.5.3.ebuild
+++ b/dev-games/godot/godot-3.5.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
-inherit bash-completion-r1 desktop python-any-r1 scons-utils toolchain-funcs xdg
+PYTHON_COMPAT=( python3_{10..12} )
+inherit desktop python-any-r1 scons-utils shell-completion toolchain-funcs xdg
DESCRIPTION="Multi-platform 2D and 3D game engine with a feature-rich editor"
HOMEPAGE="https://godotengine.org/"
@@ -82,10 +82,13 @@ PATCHES=(
src_prepare() {
default
+ # handle slotting
sed -i "1,5s/ godot/&${SLOT}/i" misc/dist/linux/godot.6 || die
sed -i "/id/s/Godot/&${SLOT}/" misc/dist/linux/org.godotengine.Godot.appdata.xml || die
sed -e "s/=godot/&${SLOT}/" -e "/^Name=/s/$/ ${SLOT}/" \
-i misc/dist/linux/org.godotengine.Godot.desktop || die
+ sed -e "s/godot/&${SLOT}/g" \
+ -i misc/dist/shell/{godot.bash-completion,godot.fish,_godot.zsh-completion} || die
sed -i "s|pkg-config |$(tc-getPKG_CONFIG) |" platform/{x11,server}/detect.py || die
@@ -210,13 +213,6 @@ src_install() {
fi
newbashcomp misc/dist/shell/godot.bash-completion ${s}
- bashcomp_alias ${s}{,-runner}
-
- insinto /usr/share/fish/vendor_completions.d
- newins misc/dist/shell/godot.fish ${s}.fish
- dosym ${s}.fish /usr/share/fish/vendor_completions.d/${s}-runner.fish
-
- insinto /usr/share/zsh/site-functions
- newins misc/dist/shell/_godot.zsh-completion _${s}
- dosym _${s} /usr/share/zsh/site-functions/_${s}-runner
+ newfishcomp misc/dist/shell/godot.fish ${s}.fish
+ newzshcomp misc/dist/shell/_godot.zsh-completion _${s}
}