summaryrefslogtreecommitdiff
path: root/dev-embedded/stlink/stlink-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/stlink/stlink-9999.ebuild')
-rw-r--r--dev-embedded/stlink/stlink-9999.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-embedded/stlink/stlink-9999.ebuild b/dev-embedded/stlink/stlink-9999.ebuild
deleted file mode 100644
index 479ca67cd591..000000000000
--- a/dev-embedded/stlink/stlink-9999.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit cmake-utils udev
-
-DESCRIPTION="stm32 discovery line linux programmer"
-HOMEPAGE="https://github.com/texane/stlink"
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/texane/stlink.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/texane/stlink/archive/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="virtual/libusb:1
- >=dev-libs/glib-2.32.0:2
- x11-libs/gtk+:3"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_configure() {
- local mycmakeargs=(
- -DSTLINK_UDEV_RULES_DIR="$(get_udevdir)"/rules.d
- -DSTLINK_MODPROBED_DIR="${EPREFIX}/etc/modprobe.d"
- -DLIB_INSTALL_DIR:PATH="$(get_libdir)"
- )
-
- cmake-utils_src_configure
-}