summaryrefslogtreecommitdiff
path: root/dev-embedded/sdcc/sdcc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/sdcc/sdcc-9999.ebuild')
-rw-r--r--dev-embedded/sdcc/sdcc-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-embedded/sdcc/sdcc-9999.ebuild b/dev-embedded/sdcc/sdcc-9999.ebuild
index f2689c566ba0..72705ab05c30 100644
--- a/dev-embedded/sdcc/sdcc-9999.ebuild
+++ b/dev-embedded/sdcc/sdcc-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
if [[ ${PV} == "9999" ]] ; then
ESVN_REPO_URI="https://svn.code.sf.net/p/sdcc/code/trunk/sdcc"
@@ -95,6 +95,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/924691
+ # https://sourceforge.net/p/sdcc/bugs/3725/
+ filter-lto
+
local myeconfargs=(
ac_cv_prog_STRIP=true
--without-ccache