summaryrefslogtreecommitdiff
path: root/dev-embedded/pk2-la/pk2-la-1.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/pk2-la/pk2-la-1.1-r2.ebuild')
-rw-r--r--dev-embedded/pk2-la/pk2-la-1.1-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-embedded/pk2-la/pk2-la-1.1-r2.ebuild b/dev-embedded/pk2-la/pk2-la-1.1-r2.ebuild
new file mode 100644
index 000000000000..342d462055c4
--- /dev/null
+++ b/dev-embedded/pk2-la/pk2-la-1.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Logic Analyzer and I/O Probe for the Microchip PICkit2"
+HOMEPAGE="https://sourceforge.net/projects/pk2-la"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pyusb:0[${PYTHON_USEDEP}]
+ "
+
+src_compile() { :; }
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+
+ dodoc README LA-Format IO-Format CHANGELOG
+}