summaryrefslogtreecommitdiff
path: root/dev-embedded/picotool/picotool-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/picotool/picotool-1.1.0.ebuild')
-rw-r--r--dev-embedded/picotool/picotool-1.1.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-embedded/picotool/picotool-1.1.0.ebuild b/dev-embedded/picotool/picotool-1.1.0.ebuild
deleted file mode 100644
index bd7b207bbca2..000000000000
--- a/dev-embedded/picotool/picotool-1.1.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-SDK_PV=1.4.0
-SDK_PN=pico-sdk
-SDK_P=${SDK_PN}-${SDK_PV}
-
-DESCRIPTION="tool for interacting with rp2040 devices and binaries"
-HOMEPAGE="https://github.com/raspberrypi/picotool"
-SRC_URI="
- https://github.com/raspberrypi/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/raspberrypi/${SDK_PN}/archive/refs/tags/${SDK_PV}.tar.gz -> ${SDK_P}.tar.gz
-"
-
-# picotool (BSD)
-# |- clipp (MIT)
-# |- pico-sdk (BSD)
-LICENSE="BSD MIT"
-SLOT="0"
-KEYWORDS="amd64"
-
-RDEPEND="virtual/libusb:1"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- local mycmakeargs=(
- -DPICO_SDK_PATH="${WORKDIR}"/${SDK_P}
- )
- cmake_src_configure
-}