summaryrefslogtreecommitdiff
path: root/dev-embedded/openocd/openocd-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/openocd/openocd-9999.ebuild')
-rw-r--r--dev-embedded/openocd/openocd-9999.ebuild29
1 files changed, 14 insertions, 15 deletions
diff --git a/dev-embedded/openocd/openocd-9999.ebuild b/dev-embedded/openocd/openocd-9999.ebuild
index 569c77f75c26..42d4b587893e 100644
--- a/dev-embedded/openocd/openocd-9999.ebuild
+++ b/dev-embedded/openocd/openocd-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit udev
+inherit autotools udev
if [[ ${PV} == *9999 ]] ; then
- inherit autotools git-r3
+ inherit git-r3
EGIT_REPO_URI=" https://repo.or.cz/openocd.git"
else
MY_PV="${PV/_/-}"
@@ -21,46 +21,45 @@ HOMEPAGE="http://openocd.sourceforge.net"
LICENSE="GPL-2+"
SLOT="0"
-IUSE="+cmsis-dap dummy +ftdi +jlink parport +usb verbose-io"
+IUSE="capstone +cmsis-dap dummy +ftdi +jlink parport +usb verbose-io"
RESTRICT="strip" # includes non-native binaries
RDEPEND="
acct-group/plugdev
- >=dev-lang/jimtcl-0.80:=
+ >=dev-lang/jimtcl-0.81:=
+ capstone? ( dev-libs/capstone )
cmsis-dap? ( dev-libs/hidapi )
jlink? ( >=dev-embedded/libjaylink-0.2.0 )
- usb? (
- virtual/libusb:0
- virtual/libusb:1
- )
+ usb? ( virtual/libusb:1 )
ftdi? ( dev-embedded/libftdi:= )"
DEPEND="${RDEPEND}"
-BDEPEND="
- sys-apps/texinfo
- virtual/pkgconfig"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
- if [[ ${PV} == *9999 ]] ; then
- AT_NO_RECURSIVE=yes eautoreconf
- fi
+ AT_NO_RECURSIVE=yes eautoreconf
}
src_configure() {
local myconf=(
--enable-amtjtagaccel
+ --enable-am335xgpio
--enable-arm-jtag-ew
--enable-at91rm9200
--enable-bcm2835gpio
--enable-buspirate
--enable-ep93xx
--enable-gw16012
+ --enable-jtag_dpi
--enable-sysfsgpio
+ --enable-vdebug
--disable-internal-jimtcl
--disable-internal-libjaylink
+ --disable-parport-giveio
--disable-werror
+ $(use_with capstone)
$(use_enable cmsis-dap)
$(use_enable dummy)
$(use_enable ftdi openjtag)