summaryrefslogtreecommitdiff
path: root/dev-embedded/avra/avra-1.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/avra/avra-1.3.0.ebuild')
-rw-r--r--dev-embedded/avra/avra-1.3.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-embedded/avra/avra-1.3.0.ebuild b/dev-embedded/avra/avra-1.3.0.ebuild
new file mode 100644
index 000000000000..5d7142e984e6
--- /dev/null
+++ b/dev-embedded/avra/avra-1.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="Atmel AVR Assembler"
+HOMEPAGE="http://avra.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc examples"
+
+S="${WORKDIR}/${P}/src/"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ local datadir="${WORKDIR}/${P}"
+
+ default
+
+ dodoc ${datadir}/{AUTHORS,INSTALL,README,TODO}
+
+ # install headers
+ insinto /usr/include/avr
+ doins "${datadir}/includes/"*
+
+ use doc && dohtml -r "${datadir}/doc/"*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${datadir}/examples/"*
+ fi
+}