summaryrefslogtreecommitdiff
path: root/dev-embedded/avarice/avarice-2.14-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/avarice/avarice-2.14-r1.ebuild')
-rw-r--r--dev-embedded/avarice/avarice-2.14-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-embedded/avarice/avarice-2.14-r1.ebuild b/dev-embedded/avarice/avarice-2.14-r1.ebuild
new file mode 100644
index 000000000000..43beb06d967d
--- /dev/null
+++ b/dev-embedded/avarice/avarice-2.14-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Interface for GDB to Atmel AVR JTAGICE in circuit emulator"
+HOMEPAGE="https://avarice.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-broken-__unused-macro.patch
+ "${FILESDIR}"/${P}-implicit-function-declarations.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # bug #788295
+ append-cxxflags -std=c++14
+
+ default
+}
+
+src_install() {
+ default
+ dodoc doc/*.txt
+}