summaryrefslogtreecommitdiff
path: root/dev-dotnet/libgdiplus/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/libgdiplus/files')
-rw-r--r--dev-dotnet/libgdiplus/files/libgdiplus-2.10.1-libpng15.patch164
-rw-r--r--dev-dotnet/libgdiplus/files/libgdiplus-2.10.9-freetype251.patch12
-rw-r--r--dev-dotnet/libgdiplus/files/libgdiplus-2.10.9-giflib-quantizebuffer.patch296
-rw-r--r--dev-dotnet/libgdiplus/files/libgdiplus-2.10.9-gold.patch16
4 files changed, 488 insertions, 0 deletions
diff --git a/dev-dotnet/libgdiplus/files/libgdiplus-2.10.1-libpng15.patch b/dev-dotnet/libgdiplus/files/libgdiplus-2.10.1-libpng15.patch
new file mode 100644
index 000000000000..31a1c01629d8
--- /dev/null
+++ b/dev-dotnet/libgdiplus/files/libgdiplus-2.10.1-libpng15.patch
@@ -0,0 +1,164 @@
+$NetBSD: patch-aa,v 1.8 2011/01/21 10:21:51 wiz Exp $
+
+Fix build with png-1.5.
+
+--- src/pngcodec.c.orig 2010-11-03 16:52:54.000000000 +0000
++++ src/pngcodec.c
+@@ -116,10 +116,15 @@ gdip_load_png_properties (png_structp pn
+ bitmap_data->dpi_horz = png_get_x_pixels_per_inch(png_ptr, info_ptr);
+ bitmap_data->dpi_vert = png_get_y_pixels_per_inch(png_ptr, info_ptr);
+ #elif defined(PNG_pHYs_SUPPORTED)
+- if ((info_ptr->valid & PNG_INFO_pHYs) && (info_ptr->phys_unit_type == PNG_RESOLUTION_METER)) {
+- bitmap_data->image_flags |= ImageFlagsHasRealDPI;
+- bitmap_data->dpi_horz = info_ptr->x_pixels_per_unit * 0.0254;
+- bitmap_data->dpi_vert = info_ptr->y_pixels_per_unit * 0.0254;
++ if (png_get_valid (png_ptr, info_ptr, PNG_INFO_pHYs)) {
++ png_uint_32 res_x, res_y;
++ int unit_type;
++ png_get_pHYs (png_ptr, info_ptr, &res_x, &res_y, &unit_type);
++ if (unit_type == PNG_RESOLUTION_METER) {
++ bitmap_data->image_flags |= ImageFlagsHasRealDPI;
++ bitmap_data->dpi_horz = res_x * 0.0254;
++ bitmap_data->dpi_vert = res_y * 0.0254;
++ }
+ }
+ #endif
+ /* default to screen resolution (if nothing was provided or available) */
+@@ -130,7 +135,7 @@ gdip_load_png_properties (png_structp pn
+ #if defined(PNG_iCCP_SUPPORTED)
+ {
+ png_charp name;
+- png_charp profile;
++ png_bytep profile;
+ png_uint_32 proflen;
+ int compression_type;
+
+@@ -292,6 +297,11 @@ gdip_load_png_image_from_file_or_stream
+ ImageFlags colourspace_flag;
+ int i;
+ int j;
++ png_colorp png_palette;
++ int png_num_palette;
++ png_bytep trans_alpha;
++ int num_trans;
++ png_color_16p trans_color;
+
+ width = png_get_image_width (png_ptr, info_ptr);
+ height = png_get_image_height (png_ptr, info_ptr);
+@@ -309,6 +319,8 @@ gdip_load_png_image_from_file_or_stream
+ }
+
+ /* Copy palette. */
++ png_get_PLTE (png_ptr, info_ptr, &png_palette, &png_num_palette);
++
+ num_colours = 1 << bit_depth;
+
+ if (png_get_color_type (png_ptr, info_ptr) == PNG_COLOR_TYPE_GRAY) {
+@@ -321,8 +333,8 @@ gdip_load_png_image_from_file_or_stream
+ colourspace_flag = ImageFlagsColorSpaceRGB;
+
+ palette_entries = num_colours;
+- if (palette_entries > info_ptr->num_palette) {
+- palette_entries = info_ptr->num_palette;
++ if (palette_entries > png_num_palette) {
++ palette_entries = png_num_palette;
+ }
+
+ palette = GdipAlloc (sizeof(ColorPalette) + (num_colours - 1) * sizeof(ARGB));
+@@ -331,29 +343,30 @@ gdip_load_png_image_from_file_or_stream
+
+ for (i=0; i < palette_entries; i++) {
+ set_pixel_bgra (&palette->Entries[i], 0,
+- info_ptr->palette[i].blue,
+- info_ptr->palette[i].green,
+- info_ptr->palette[i].red,
++ png_palette[i].blue,
++ png_palette[i].green,
++ png_palette[i].red,
+ 0xFF); /* alpha */
+ }
+ }
+
++ png_get_tRNS (png_ptr, info_ptr, &trans_alpha, &num_trans, &trans_color);
+ /* Make sure transparency is respected. */
+- if (info_ptr->num_trans > 0) {
++ if (num_trans > 0) {
+ palette->Flags |= PaletteFlagsHasAlpha;
+ colourspace_flag |= ImageFlagsHasAlpha;
+
+- if (info_ptr->num_trans > info_ptr->num_palette) {
+- info_ptr->num_trans = info_ptr->num_palette;
++ if (num_trans > png_num_palette) {
++ num_trans = png_num_palette;
+ }
+
+- for (i=0; i < info_ptr->num_trans; i++) {
++ for (i=0; i < num_trans; i++) {
+ set_pixel_bgra(&palette->Entries[i], 0,
+- info_ptr->palette[i].blue,
+- info_ptr->palette[i].green,
+- info_ptr->palette[i].red,
++ png_palette[i].blue,
++ png_palette[i].green,
++ png_palette[i].red,
+ #if PNG_LIBPNG_VER > 10399
+- info_ptr->trans_alpha [i]); /* alpha */
++ trans_alpha [i]); /* alpha */
+ #else
+ info_ptr->trans[i]); /* alpha */
+ #endif
+@@ -398,6 +411,8 @@ gdip_load_png_image_from_file_or_stream
+ BYTE bit_depth;
+ int stride;
+ int interlace;
++ png_colorp png_palette;
++ int png_num_palette;
+ png_bytep *row_pointers;
+ BYTE *rawptr;
+ int i, j;
+@@ -490,32 +505,33 @@ gdip_load_png_image_from_file_or_stream
+ png_byte palette = 0;
+ png_byte pix = *rowp++;
+
++ png_get_PLTE (png_ptr, info_ptr, &png_palette, &png_num_palette);
+ palette = (pix >> 6) & 0x03;
+ set_pixel_bgra (rawptr, 0,
+- info_ptr->palette[palette].blue,
+- info_ptr->palette[palette].green,
+- info_ptr->palette[palette].red,
++ png_palette[palette].blue,
++ png_palette[palette].green,
++ png_palette[palette].red,
+ 0xFF); /* alpha */
+
+ palette = (pix >> 4) & 0x03;
+ set_pixel_bgra (rawptr, 4,
+- info_ptr->palette[palette].blue,
+- info_ptr->palette[palette].green,
+- info_ptr->palette[palette].red,
++ png_palette[palette].blue,
++ png_palette[palette].green,
++ png_palette[palette].red,
+ 0xFF); /* alpha */
+
+ palette = (pix >> 2) & 0x03;
+ set_pixel_bgra (rawptr, 8,
+- info_ptr->palette[palette].blue,
+- info_ptr->palette[palette].green,
+- info_ptr->palette[palette].red,
++ png_palette[palette].blue,
++ png_palette[palette].green,
++ png_palette[palette].red,
+ 0xFF); /* alpha */
+
+ palette = pix & 0x03;
+ set_pixel_bgra (rawptr, 12,
+- info_ptr->palette[palette].blue,
+- info_ptr->palette[palette].green,
+- info_ptr->palette[palette].red,
++ png_palette[palette].blue,
++ png_palette[palette].green,
++ png_palette[palette].red,
+ 0xFF); /* alpha */
+ rawptr += 16;
+ }
diff --git a/dev-dotnet/libgdiplus/files/libgdiplus-2.10.9-freetype251.patch b/dev-dotnet/libgdiplus/files/libgdiplus-2.10.9-freetype251.patch
new file mode 100644
index 000000000000..b4faa06d6415
--- /dev/null
+++ b/dev-dotnet/libgdiplus/files/libgdiplus-2.10.9-freetype251.patch
@@ -0,0 +1,12 @@
+--- libgdiplus-2.10.9/src/gdiplus-private.h
++++ libgdiplus-2.10.9/src/gdiplus-private.h
+@@ -30,7 +30,8 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <glib.h>
+-#include <freetype/tttables.h>
++#include <ft2build.h>
++#include FT_TRUETYPE_TABLES_H
+ #include <pthread.h>
+ #include <unistd.h>
+
diff --git a/dev-dotnet/libgdiplus/files/libgdiplus-2.10.9-giflib-quantizebuffer.patch b/dev-dotnet/libgdiplus/files/libgdiplus-2.10.9-giflib-quantizebuffer.patch
new file mode 100644
index 000000000000..f65c349af772
--- /dev/null
+++ b/dev-dotnet/libgdiplus/files/libgdiplus-2.10.9-giflib-quantizebuffer.patch
@@ -0,0 +1,296 @@
+diff -uNr libgdiplus-2.10.9/src/gifcodec.c libgdiplus-2.10.9-funtoo/src/gifcodec.c
+--- libgdiplus-2.10.9/src/gifcodec.c 2011-12-02 18:23:12.000000000 +0100
++++ libgdiplus-2.10.9-funtoo/src/gifcodec.c 2013-10-08 18:06:44.643554570 +0200
+@@ -39,6 +39,293 @@
+
+ #include "gifcodec.h"
+
++#define COLOR_ARRAY_SIZE 32768
++#define BITS_PER_PRIM_COLOR 5
++#define MAX_PRIM_COLOR 0x1f
++
++static int SortRGBAxis;
++
++typedef struct QuantizedColorType {
++ GifByteType RGB[3];
++ GifByteType NewColorIndex;
++ long Count;
++ struct QuantizedColorType *Pnext;
++} QuantizedColorType;
++
++typedef struct NewColorMapType {
++ GifByteType RGBMin[3], RGBWidth[3];
++ unsigned int NumEntries; /* # of QuantizedColorType in linked list below */
++ unsigned long Count; /* Total number of pixels in all the entries */
++ QuantizedColorType *QuantizedColors;
++} NewColorMapType;
++
++
++/****************************************************************************
++ * Routine called by qsort to compare two entries.
++ ****************************************************************************/
++static int
++SortCmpRtn(const void *Entry1,
++ const void *Entry2) {
++
++ return (*((QuantizedColorType **) Entry1))->RGB[SortRGBAxis] -
++ (*((QuantizedColorType **) Entry2))->RGB[SortRGBAxis];
++}
++
++/******************************************************************************
++ * Routine to subdivide the RGB space recursively using median cut in each
++ * axes alternatingly until ColorMapSize different cubes exists.
++ * The biggest cube in one dimension is subdivide unless it has only one entry.
++ * Returns GIF_ERROR if failed, otherwise GIF_OK.
++ ******************************************************************************/
++static int
++SubdivColorMap(NewColorMapType * NewColorSubdiv,
++ unsigned int ColorMapSize,
++ unsigned int *NewColorMapSize) {
++
++ int MaxSize;
++ unsigned int i, j, Index = 0, NumEntries, MinColor, MaxColor;
++ long Sum, Count;
++ QuantizedColorType *QuantizedColor, **SortArray;
++
++ while (ColorMapSize > *NewColorMapSize) {
++ /* Find candidate for subdivision: */
++ MaxSize = -1;
++ for (i = 0; i < *NewColorMapSize; i++) {
++ for (j = 0; j < 3; j++) {
++ if ((((int)NewColorSubdiv[i].RGBWidth[j]) > MaxSize) &&
++ (NewColorSubdiv[i].NumEntries > 1)) {
++ MaxSize = NewColorSubdiv[i].RGBWidth[j];
++ Index = i;
++ SortRGBAxis = j;
++ }
++ }
++ }
++
++ if (MaxSize == -1)
++ return GIF_OK;
++
++ /* Split the entry Index into two along the axis SortRGBAxis: */
++
++ /* Sort all elements in that entry along the given axis and split at
++ * the median. */
++ SortArray = (QuantizedColorType **)malloc(
++ sizeof(QuantizedColorType *) *
++ NewColorSubdiv[Index].NumEntries);
++ if (SortArray == NULL)
++ return GIF_ERROR;
++ for (j = 0, QuantizedColor = NewColorSubdiv[Index].QuantizedColors;
++ j < NewColorSubdiv[Index].NumEntries && QuantizedColor != NULL;
++ j++, QuantizedColor = QuantizedColor->Pnext)
++ SortArray[j] = QuantizedColor;
++
++ qsort(SortArray, NewColorSubdiv[Index].NumEntries,
++ sizeof(QuantizedColorType *), SortCmpRtn);
++
++ /* Relink the sorted list into one: */
++ for (j = 0; j < NewColorSubdiv[Index].NumEntries - 1; j++)
++ SortArray[j]->Pnext = SortArray[j + 1];
++ SortArray[NewColorSubdiv[Index].NumEntries - 1]->Pnext = NULL;
++ NewColorSubdiv[Index].QuantizedColors = QuantizedColor = SortArray[0];
++ free((char *)SortArray);
++
++ /* Now simply add the Counts until we have half of the Count: */
++ Sum = NewColorSubdiv[Index].Count / 2 - QuantizedColor->Count;
++ NumEntries = 1;
++ Count = QuantizedColor->Count;
++ while (QuantizedColor->Pnext != NULL &&
++ (Sum -= QuantizedColor->Pnext->Count) >= 0 &&
++ QuantizedColor->Pnext->Pnext != NULL) {
++ QuantizedColor = QuantizedColor->Pnext;
++ NumEntries++;
++ Count += QuantizedColor->Count;
++ }
++ /* Save the values of the last color of the first half, and first
++ * of the second half so we can update the Bounding Boxes later.
++ * Also as the colors are quantized and the BBoxes are full 0..255,
++ * they need to be rescaled.
++ */
++ MaxColor = QuantizedColor->RGB[SortRGBAxis]; /* Max. of first half */
++ /* coverity[var_deref_op] */
++ MinColor = QuantizedColor->Pnext->RGB[SortRGBAxis]; /* of second */
++ MaxColor <<= (8 - BITS_PER_PRIM_COLOR);
++ MinColor <<= (8 - BITS_PER_PRIM_COLOR);
++
++ /* Partition right here: */
++ NewColorSubdiv[*NewColorMapSize].QuantizedColors =
++ QuantizedColor->Pnext;
++ QuantizedColor->Pnext = NULL;
++ NewColorSubdiv[*NewColorMapSize].Count = Count;
++ NewColorSubdiv[Index].Count -= Count;
++ NewColorSubdiv[*NewColorMapSize].NumEntries =
++ NewColorSubdiv[Index].NumEntries - NumEntries;
++ NewColorSubdiv[Index].NumEntries = NumEntries;
++ for (j = 0; j < 3; j++) {
++ NewColorSubdiv[*NewColorMapSize].RGBMin[j] =
++ NewColorSubdiv[Index].RGBMin[j];
++ NewColorSubdiv[*NewColorMapSize].RGBWidth[j] =
++ NewColorSubdiv[Index].RGBWidth[j];
++ }
++ NewColorSubdiv[*NewColorMapSize].RGBWidth[SortRGBAxis] =
++ NewColorSubdiv[*NewColorMapSize].RGBMin[SortRGBAxis] +
++ NewColorSubdiv[*NewColorMapSize].RGBWidth[SortRGBAxis] - MinColor;
++ NewColorSubdiv[*NewColorMapSize].RGBMin[SortRGBAxis] = MinColor;
++
++ NewColorSubdiv[Index].RGBWidth[SortRGBAxis] =
++ MaxColor - NewColorSubdiv[Index].RGBMin[SortRGBAxis];
++
++ (*NewColorMapSize)++;
++ }
++
++ return GIF_OK;
++}
++
++/******************************************************************************
++ * Quantize high resolution image into lower one. Input image consists of a
++ * 2D array for each of the RGB colors with size Width by Height. There is no
++ * Color map for the input. Output is a quantized image with 2D array of
++ * indexes into the output color map.
++ * Note input image can be 24 bits at the most (8 for red/green/blue) and
++ * the output has 256 colors at the most (256 entries in the color map.).
++ * ColorMapSize specifies size of color map up to 256 and will be updated to
++ * real size before returning.
++ * Also non of the parameter are allocated by this routine.
++ * This function returns GIF_OK if succesfull, GIF_ERROR otherwise.
++ ******************************************************************************/
++static int
++QuantizeBuffer(unsigned int Width,
++ unsigned int Height,
++ int *ColorMapSize,
++ GifByteType * RedInput,
++ GifByteType * GreenInput,
++ GifByteType * BlueInput,
++ GifByteType * OutputBuffer,
++ GifColorType * OutputColorMap) {
++
++ unsigned int Index, NumOfEntries;
++ int i, j, MaxRGBError[3];
++ unsigned int NewColorMapSize;
++ long Red, Green, Blue;
++ NewColorMapType NewColorSubdiv[256];
++ QuantizedColorType *ColorArrayEntries, *QuantizedColor;
++
++ ColorArrayEntries = (QuantizedColorType *)malloc(
++ sizeof(QuantizedColorType) * COLOR_ARRAY_SIZE);
++ if (ColorArrayEntries == NULL) {
++ return GIF_ERROR;
++ }
++
++ for (i = 0; i < COLOR_ARRAY_SIZE; i++) {
++ ColorArrayEntries[i].RGB[0] = i >> (2 * BITS_PER_PRIM_COLOR);
++ ColorArrayEntries[i].RGB[1] = (i >> BITS_PER_PRIM_COLOR) &
++ MAX_PRIM_COLOR;
++ ColorArrayEntries[i].RGB[2] = i & MAX_PRIM_COLOR;
++ ColorArrayEntries[i].Count = 0;
++ }
++
++ /* Sample the colors and their distribution: */
++ for (i = 0; i < (int)(Width * Height); i++) {
++ Index = ((RedInput[i] >> (8 - BITS_PER_PRIM_COLOR)) <<
++ (2 * BITS_PER_PRIM_COLOR)) +
++ ((GreenInput[i] >> (8 - BITS_PER_PRIM_COLOR)) <<
++ BITS_PER_PRIM_COLOR) +
++ (BlueInput[i] >> (8 - BITS_PER_PRIM_COLOR));
++ ColorArrayEntries[Index].Count++;
++ }
++
++ /* Put all the colors in the first entry of the color map, and call the
++ * recursive subdivision process. */
++ for (i = 0; i < 256; i++) {
++ NewColorSubdiv[i].QuantizedColors = NULL;
++ NewColorSubdiv[i].Count = NewColorSubdiv[i].NumEntries = 0;
++ for (j = 0; j < 3; j++) {
++ NewColorSubdiv[i].RGBMin[j] = 0;
++ NewColorSubdiv[i].RGBWidth[j] = 255;
++ }
++ }
++
++ /* Find the non empty entries in the color table and chain them: */
++ for (i = 0; i < COLOR_ARRAY_SIZE; i++)
++ if (ColorArrayEntries[i].Count > 0)
++ break;
++ QuantizedColor = NewColorSubdiv[0].QuantizedColors = &ColorArrayEntries[i];
++ NumOfEntries = 1;
++ while (++i < COLOR_ARRAY_SIZE)
++ if (ColorArrayEntries[i].Count > 0) {
++ QuantizedColor->Pnext = &ColorArrayEntries[i];
++ QuantizedColor = &ColorArrayEntries[i];
++ NumOfEntries++;
++ }
++ QuantizedColor->Pnext = NULL;
++
++ NewColorSubdiv[0].NumEntries = NumOfEntries; /* Different sampled colors */
++ NewColorSubdiv[0].Count = ((long)Width) * Height; /* Pixels */
++ NewColorMapSize = 1;
++ if (SubdivColorMap(NewColorSubdiv, *ColorMapSize, &NewColorMapSize) !=
++ GIF_OK) {
++ free((char *)ColorArrayEntries);
++ return GIF_ERROR;
++ }
++ if (NewColorMapSize < *ColorMapSize) {
++ /* And clear rest of color map: */
++ for (i = NewColorMapSize; i < *ColorMapSize; i++)
++ OutputColorMap[i].Red = OutputColorMap[i].Green =
++ OutputColorMap[i].Blue = 0;
++ }
++
++ /* Average the colors in each entry to be the color to be used in the
++ * output color map, and plug it into the output color map itself. */
++ for (i = 0; i < NewColorMapSize; i++) {
++ if ((j = NewColorSubdiv[i].NumEntries) > 0) {
++ QuantizedColor = NewColorSubdiv[i].QuantizedColors;
++ Red = Green = Blue = 0;
++ while (QuantizedColor) {
++ QuantizedColor->NewColorIndex = i;
++ Red += QuantizedColor->RGB[0];
++ Green += QuantizedColor->RGB[1];
++ Blue += QuantizedColor->RGB[2];
++ QuantizedColor = QuantizedColor->Pnext;
++ }
++ OutputColorMap[i].Red = (Red << (8 - BITS_PER_PRIM_COLOR)) / j;
++ OutputColorMap[i].Green = (Green << (8 - BITS_PER_PRIM_COLOR)) / j;
++ OutputColorMap[i].Blue = (Blue << (8 - BITS_PER_PRIM_COLOR)) / j;
++ } else
++ fprintf(stderr,
++ "\n%s: Null entry in quantized color map - that's weird.\n",
++ "libgdiplus");
++ }
++
++ /* Finally scan the input buffer again and put the mapped index in the
++ * output buffer. */
++ MaxRGBError[0] = MaxRGBError[1] = MaxRGBError[2] = 0;
++ for (i = 0; i < (int)(Width * Height); i++) {
++ Index = ((RedInput[i] >> (8 - BITS_PER_PRIM_COLOR)) <<
++ (2 * BITS_PER_PRIM_COLOR)) +
++ ((GreenInput[i] >> (8 - BITS_PER_PRIM_COLOR)) <<
++ BITS_PER_PRIM_COLOR) +
++ (BlueInput[i] >> (8 - BITS_PER_PRIM_COLOR));
++ Index = ColorArrayEntries[Index].NewColorIndex;
++ OutputBuffer[i] = Index;
++ if (MaxRGBError[0] < ABS(OutputColorMap[Index].Red - RedInput[i]))
++ MaxRGBError[0] = ABS(OutputColorMap[Index].Red - RedInput[i]);
++ if (MaxRGBError[1] < ABS(OutputColorMap[Index].Green - GreenInput[i]))
++ MaxRGBError[1] = ABS(OutputColorMap[Index].Green - GreenInput[i]);
++ if (MaxRGBError[2] < ABS(OutputColorMap[Index].Blue - BlueInput[i]))
++ MaxRGBError[2] = ABS(OutputColorMap[Index].Blue - BlueInput[i]);
++ }
++
++#ifdef DEBUG
++ fprintf(stderr,
++ "Quantization L(0) errors: Red = %d, Green = %d, Blue = %d.\n",
++ MaxRGBError[0], MaxRGBError[1], MaxRGBError[2]);
++#endif /* DEBUG */
++
++ free((char *)ColorArrayEntries);
++
++ *ColorMapSize = NewColorMapSize;
++
++ return GIF_OK;
++}
++
+ /* giflib declares this incorrectly as EgifOpen */
+ extern GifFileType *EGifOpen(void *userData, OutputFunc writeFunc);
diff --git a/dev-dotnet/libgdiplus/files/libgdiplus-2.10.9-gold.patch b/dev-dotnet/libgdiplus/files/libgdiplus-2.10.9-gold.patch
new file mode 100644
index 000000000000..379ae941ef40
--- /dev/null
+++ b/dev-dotnet/libgdiplus/files/libgdiplus-2.10.9-gold.patch
@@ -0,0 +1,16 @@
+ tests/Makefile.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/tests/Makefile.in b/tests/Makefile.in
+index 97f5f4e..c02ca25 100644
+--- a/tests/Makefile.in
++++ b/tests/Makefile.in
+@@ -228,7 +228,7 @@ DEPS = \
+ $(top_builddir)/src/libgdiplus.la
+
+ LDADDS = \
+- $(top_builddir)/src/libgdiplus.la
++ $(top_builddir)/src/libgdiplus.la -lX11 -lglib-2.0
+
+ testgdi_DEPENDENCIES = $(TEST_DEPS)
+ testgdi_LDADD = $(LDADDS)