summaryrefslogtreecommitdiff
path: root/dev-dotnet/cake/cake-3.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/cake/cake-3.1.0-r1.ebuild')
-rw-r--r--dev-dotnet/cake/cake-3.1.0-r1.ebuild235
1 files changed, 235 insertions, 0 deletions
diff --git a/dev-dotnet/cake/cake-3.1.0-r1.ebuild b/dev-dotnet/cake/cake-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..a37f25152cd2
--- /dev/null
+++ b/dev-dotnet/cake/cake-3.1.0-r1.ebuild
@@ -0,0 +1,235 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOTNET_PKG_COMPAT=7.0
+NUGETS="
+autofac@7.0.1
+basic.reference.assemblies.net70@1.4.2
+castle.core@5.1.1
+microsoft.build.tasks.git@1.1.1
+microsoft.codeanalysis.analyzers@3.0.0
+microsoft.codeanalysis.analyzers@3.3.4
+microsoft.codeanalysis.common@3.9.0
+microsoft.codeanalysis.common@4.6.0
+microsoft.codeanalysis.csharp.scripting@4.6.0
+microsoft.codeanalysis.csharp@4.6.0
+microsoft.codeanalysis.scripting.common@4.6.0
+microsoft.codecoverage@17.6.3
+microsoft.csharp@4.7.0
+microsoft.extensions.dependencyinjection.abstractions@7.0.0
+microsoft.extensions.dependencyinjection@7.0.0
+microsoft.net.test.sdk@17.6.3
+microsoft.netcore.platforms@1.1.0
+microsoft.netcore.platforms@2.1.2
+microsoft.netcore.platforms@5.0.0
+microsoft.netcore.platforms@7.0.3
+microsoft.netcore.targets@1.1.0
+microsoft.sourcelink.common@1.1.1
+microsoft.sourcelink.github@1.1.1
+microsoft.testplatform.objectmodel@17.6.3
+microsoft.testplatform.testhost@17.6.3
+microsoft.win32.primitives@4.3.0
+microsoft.win32.registry@5.0.0
+netstandard.library@1.6.1
+newtonsoft.json@13.0.1
+newtonsoft.json@13.0.3
+nsubstitute@5.0.0
+nuget.common@6.6.1
+nuget.configuration@6.6.1
+nuget.frameworks@6.5.0
+nuget.frameworks@6.6.1
+nuget.packaging@6.6.1
+nuget.protocol@6.6.1
+nuget.resolver@6.6.1
+nuget.versioning@6.6.1
+runtime.any.system.collections@4.3.0
+runtime.any.system.diagnostics.tools@4.3.0
+runtime.any.system.diagnostics.tracing@4.3.0
+runtime.any.system.globalization.calendars@4.3.0
+runtime.any.system.globalization@4.3.0
+runtime.any.system.io@4.3.0
+runtime.any.system.reflection.extensions@4.3.0
+runtime.any.system.reflection.primitives@4.3.0
+runtime.any.system.reflection@4.3.0
+runtime.any.system.resources.resourcemanager@4.3.0
+runtime.any.system.runtime.handles@4.3.0
+runtime.any.system.runtime.interopservices@4.3.0
+runtime.any.system.runtime@4.3.0
+runtime.any.system.text.encoding.extensions@4.3.0
+runtime.any.system.text.encoding@4.3.0
+runtime.any.system.threading.tasks@4.3.0
+runtime.any.system.threading.timer@4.3.0
+runtime.debian.8-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.fedora.23-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.fedora.24-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.native.system.io.compression@4.3.0
+runtime.native.system.net.http@4.3.0
+runtime.native.system.security.cryptography.apple@4.3.0
+runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.native.system@4.3.0
+runtime.opensuse.13.2-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.opensuse.42.1-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.osx.10.10-x64.runtime.native.system.security.cryptography.apple@4.3.0
+runtime.osx.10.10-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.rhel.7-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.ubuntu.14.04-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.ubuntu.16.04-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.ubuntu.16.10-x64.runtime.native.system.security.cryptography.openssl@4.3.0
+runtime.unix.microsoft.win32.primitives@4.3.0
+runtime.unix.system.console@4.3.0
+runtime.unix.system.diagnostics.debug@4.3.0
+runtime.unix.system.io.filesystem@4.3.0
+runtime.unix.system.net.primitives@4.3.0
+runtime.unix.system.net.sockets@4.3.0
+runtime.unix.system.private.uri@4.3.0
+runtime.unix.system.runtime.extensions@4.3.0
+spectre.console.cli@0.46.0
+spectre.console@0.46.0
+stylecop.analyzers@1.1.118
+system.appcontext@4.3.0
+system.buffers@4.3.0
+system.collections.concurrent@4.3.0
+system.collections.immutable@7.0.0
+system.collections@4.3.0
+system.console@4.3.0
+system.diagnostics.debug@4.3.0
+system.diagnostics.diagnosticsource@4.3.0
+system.diagnostics.diagnosticsource@4.7.1
+system.diagnostics.eventlog@6.0.0
+system.diagnostics.tools@4.3.0
+system.diagnostics.tracing@4.3.0
+system.formats.asn1@5.0.0
+system.globalization.calendars@4.3.0
+system.globalization.extensions@4.3.0
+system.globalization@4.3.0
+system.io.compression.zipfile@4.3.0
+system.io.compression@4.3.0
+system.io.filesystem.primitives@4.3.0
+system.io.filesystem@4.3.0
+system.io@4.3.0
+system.linq.expressions@4.3.0
+system.linq@4.3.0
+system.memory@4.5.4
+system.memory@4.5.5
+system.net.http@4.3.0
+system.net.nameresolution@4.3.0
+system.net.primitives@4.3.0
+system.net.sockets@4.3.0
+system.objectmodel@4.3.0
+system.private.uri@4.3.0
+system.reflection.emit.ilgeneration@4.3.0
+system.reflection.emit.lightweight@4.3.0
+system.reflection.emit@4.3.0
+system.reflection.extensions@4.3.0
+system.reflection.metadata@1.6.0
+system.reflection.metadata@7.0.2
+system.reflection.primitives@4.3.0
+system.reflection.typeextensions@4.3.0
+system.reflection@4.3.0
+system.resources.resourcemanager@4.3.0
+system.runtime.compilerservices.unsafe@5.0.0
+system.runtime.compilerservices.unsafe@6.0.0
+system.runtime.extensions@4.3.0
+system.runtime.handles@4.3.0
+system.runtime.interopservices.runtimeinformation@4.3.0
+system.runtime.interopservices@4.3.0
+system.runtime.numerics@4.3.0
+system.runtime@4.3.0
+system.security.accesscontrol@5.0.0
+system.security.claims@4.3.0
+system.security.cryptography.algorithms@4.3.0
+system.security.cryptography.cng@4.3.0
+system.security.cryptography.cng@5.0.0
+system.security.cryptography.csp@4.3.0
+system.security.cryptography.encoding@4.3.0
+system.security.cryptography.openssl@4.3.0
+system.security.cryptography.pkcs@5.0.0
+system.security.cryptography.primitives@4.3.0
+system.security.cryptography.protecteddata@4.4.0
+system.security.cryptography.x509certificates@4.3.0
+system.security.principal.windows@4.3.0
+system.security.principal.windows@5.0.0
+system.security.principal@4.3.0
+system.text.encoding.codepages@4.5.1
+system.text.encoding.codepages@7.0.0
+system.text.encoding.extensions@4.3.0
+system.text.encoding@4.3.0
+system.text.regularexpressions@4.3.0
+system.threading.tasks.extensions@4.3.0
+system.threading.tasks.extensions@4.5.4
+system.threading.tasks@4.3.0
+system.threading.threadpool@4.3.0
+system.threading.timer@4.3.0
+system.threading@4.3.0
+system.xml.readerwriter@4.3.0
+system.xml.xdocument@4.3.0
+xunit.abstractions@2.0.3
+xunit.analyzers@1.2.0
+xunit.assert@2.5.0
+xunit.core@2.5.0
+xunit.extensibility.core@2.5.0
+xunit.extensibility.execution@2.5.0
+xunit.runner.visualstudio@2.5.0
+xunit@2.5.0
+"
+
+inherit dotnet-pkg
+
+DESCRIPTION="Cake (C# Make) is a cross platform build automation system"
+HOMEPAGE="https://cakebuild.net/
+ https://github.com/cake-build/cake/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/cake-build/${PN}.git"
+else
+ SRC_URI="https://github.com/cake-build/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+SRC_URI+=" ${NUGET_URIS} "
+S="${WORKDIR}/${P}/src"
+
+LICENSE="MIT"
+SLOT="0"
+
+# Collision with dev-lang/coffee, file: cake, bug https://bugs.gentoo.org/914496
+RDEPEND="
+ !dev-lang/coffee-script
+"
+
+DOTNET_PKG_PROJECTS=( Cake/Cake.csproj )
+
+DOCS=( README.md ReleaseNotes.md SECURITY.md )
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n ${EGIT_REPO_URI} ]] ; then
+ git-r3_src_unpack
+ fi
+}
+
+src_prepare() {
+ dotnet-pkg_src_prepare
+ dotnet-pkg-base_remove-global-json ../
+
+ sed -e "s|net6.0;net7.0|net${DOTNET_PKG_COMPAT}|" \
+ -i Shared.msbuild || die
+}
+
+src_test() {
+ dotnet-pkg-base_test Cake.Core.Tests/Cake.Core.Tests.csproj
+}
+
+src_install() {
+ # Trick for docs. We do not install anything other form "${S}".
+ cd .. || die
+
+ dotnet-pkg_src_install
+}