summaryrefslogtreecommitdiff
path: root/dev-debug/lldb/lldb-18.1.0_rc2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-debug/lldb/lldb-18.1.0_rc2.ebuild')
-rw-r--r--dev-debug/lldb/lldb-18.1.0_rc2.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-debug/lldb/lldb-18.1.0_rc2.ebuild b/dev-debug/lldb/lldb-18.1.0_rc2.ebuild
index eb67407b87fc..6d10771e220b 100644
--- a/dev-debug/lldb/lldb-18.1.0_rc2.ebuild
+++ b/dev-debug/lldb/lldb-18.1.0_rc2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake llvm llvm.org python-single-r1
+inherit cmake llvm.org llvm-utils python-single-r1
DESCRIPTION="The LLVM debugger"
HOMEPAGE="https://llvm.org/"
@@ -51,12 +51,9 @@ LLVM_COMPONENTS=( lldb cmake llvm/utils )
LLVM_TEST_COMPONENTS=( llvm/lib/Testing/Support third-party )
llvm.org_set_globals
-pkg_setup() {
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
- python-single-r1_pkg_setup
-}
-
src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"