summaryrefslogtreecommitdiff
path: root/dev-debug/lldb/lldb-16.0.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-debug/lldb/lldb-16.0.6-r1.ebuild')
-rw-r--r--dev-debug/lldb/lldb-16.0.6-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-debug/lldb/lldb-16.0.6-r1.ebuild b/dev-debug/lldb/lldb-16.0.6-r1.ebuild
index df16f4ee368c..ba5732325fa4 100644
--- a/dev-debug/lldb/lldb-16.0.6-r1.ebuild
+++ b/dev-debug/lldb/lldb-16.0.6-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake llvm llvm.org python-single-r1
+inherit cmake flag-o-matic llvm llvm.org python-single-r1
DESCRIPTION="The LLVM debugger"
HOMEPAGE="https://llvm.org/"
@@ -54,6 +54,9 @@ pkg_setup() {
}
src_configure() {
+ # bug #858389 (https://github.com/llvm/llvm-project/issues/83636)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"