summaryrefslogtreecommitdiff
path: root/dev-debug/lldb/lldb-15.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-debug/lldb/lldb-15.0.7.ebuild')
-rw-r--r--dev-debug/lldb/lldb-15.0.7.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-debug/lldb/lldb-15.0.7.ebuild b/dev-debug/lldb/lldb-15.0.7.ebuild
index 3eff62955fde..70c8d4f38dd7 100644
--- a/dev-debug/lldb/lldb-15.0.7.ebuild
+++ b/dev-debug/lldb/lldb-15.0.7.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
-inherit cmake llvm llvm.org python-single-r1
+inherit cmake flag-o-matic llvm llvm.org python-single-r1
DESCRIPTION="The LLVM debugger"
HOMEPAGE="https://llvm.org/"
@@ -60,6 +60,9 @@ pkg_setup() {
}
src_configure() {
+ # bug #858389 (https://github.com/llvm/llvm-project/issues/83636)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"