summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/Manifest.gzbin16766 -> 16767 bytes
-rw-r--r--dev-db/hsqldb/Manifest2
-rw-r--r--dev-db/hsqldb/files/StringComparator.java53
-rw-r--r--dev-db/hsqldb/files/TestBug1191815.java129
-rw-r--r--dev-db/mysql-workbench/Manifest1
-rw-r--r--dev-db/mysql-workbench/files/mysql-workbench-8.0.36-libxml2-2.12-support.patch33
6 files changed, 0 insertions, 218 deletions
diff --git a/dev-db/Manifest.gz b/dev-db/Manifest.gz
index 02ae83ffb9b0..6e193ccd950f 100644
--- a/dev-db/Manifest.gz
+++ b/dev-db/Manifest.gz
Binary files differ
diff --git a/dev-db/hsqldb/Manifest b/dev-db/hsqldb/Manifest
index fcbba860cc53..3c5b657b8dba 100644
--- a/dev-db/hsqldb/Manifest
+++ b/dev-db/hsqldb/Manifest
@@ -1,5 +1,3 @@
-AUX StringComparator.java 1986 BLAKE2B e86079c260e0732c8828626de3c3d1611376377c228c8efb28739dff5f82cbe26ed2a06f9bf6c2214e44a291c1af51e6cb2044fc639aaafb54e356fe6b978dc8 SHA512 a0103b0b8445bfbbe325c73ab65dcf4c22c8fd4dab89cd9d60809b4323263e62da2c20a0c1f2900ee97eb9ca2549730e1d37b7f1bffdfce3d116ca802fe8beaa
-AUX TestBug1191815.java 4112 BLAKE2B f8418d564f7489e3dd256e9783624ef66994875d2509ccd66972ed5704281ae9770df7f7521ec56ab66b44af142ff4a6a846fb9d04d768b2a0b2c5f78b9c6b7f SHA512 c37491e2fcea0b4ce6bd641ffe128deaa9a8e38533ec3e607415cb1325a975dd8317c212c0fbf9f42b25de7808869df6ac63dacd53c773455f5d2ca0a58f1f62
AUX hsqldb 364 BLAKE2B 236ae5fff19eaf9c4aa184bf1228bd96c7841c8c1849d35d72be02d43b955be003c54a96fc9d792208a38c388609d3dce34a5ef1e2c36b9283dd69a545cc3e2d SHA512 6cd0a4a26739960536192a9dda36324e10a16e4ed51028515f07ca5542c68a9f13d9ee9456faf7f797071476747b2026cdf5872ebdf20c1fbfda1079c4164716
AUX hsqldb-2.7.3-hsqldb.conf.patch 1285 BLAKE2B 380066dde2adb7f336bd14edf2c52c6bdb57c1f32a419649ec7a7d02c56cdd9cf19fce2978c944cd520759c5b9255c1bc44952bf5deb8c74b41e8e6861d9af8c SHA512 19124e4835b80e2bdb9c3db57ef1f8620fd8c4716205f7ddb22b5618b8eb6e298227131cc66c97c426f39734e0f04223b0b9b71a68b806232d7447a1c90d0fa2
AUX hsqldb-2.7.3-hsqldb.init.patch 740 BLAKE2B 948afb9bb1404d34f767bebd2010fdea92d065c3fd645e0c2b9968a359e55f66af14a803fa02fbe7b417f6453ea875aa9cc67ae5eaa0700291e3765ba1979f40 SHA512 b6de0367e9f6da039976ae6ec81368fbf6982844d76377364b16a27c4d94d4f60c6b1792bcae65fa42f7febdf17b9b5c8dfd5bcc0064e345ba27b863d2d4ec74
diff --git a/dev-db/hsqldb/files/StringComparator.java b/dev-db/hsqldb/files/StringComparator.java
deleted file mode 100644
index ae0f7b0fb979..000000000000
--- a/dev-db/hsqldb/files/StringComparator.java
+++ /dev/null
@@ -1,53 +0,0 @@
-/* Copyright (c) 2001-2008, The HSQL Development Group
- * All rights reserved.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions are met:
- *
- * Redistributions of source code must retain the above copyright notice, this
- * list of conditions and the following disclaimer.
- *
- * Redistributions in binary form must reproduce the above copyright notice,
- * this list of conditions and the following disclaimer in the documentation
- * and/or other materials provided with the distribution.
- *
- * Neither the name of the HSQL Development Group nor the names of its
- * contributors may be used to endorse or promote products derived from this
- * software without specific prior written permission.
- *
- * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
- * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
- * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
- * ARE DISCLAIMED. IN NO EVENT SHALL HSQL DEVELOPMENT GROUP, HSQLDB.ORG,
- * OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
- * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
- * LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
- * ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
- * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
- * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- */
-
-
-package org.hsqldb.lib;
-
-public class StringComparator implements ObjectComparator {
-
- public int compare(Object a, Object b) {
-
- // handle nulls
- if (a == b) {
- return 0;
- }
-
- if (a == null) {
- return -1;
- }
-
- if (b == null) {
- return 1;
- }
-
- return ((String) a).compareTo((String) b);
- }
-}
diff --git a/dev-db/hsqldb/files/TestBug1191815.java b/dev-db/hsqldb/files/TestBug1191815.java
deleted file mode 100644
index 06c606401cdd..000000000000
--- a/dev-db/hsqldb/files/TestBug1191815.java
+++ /dev/null
@@ -1,129 +0,0 @@
-/* Copyright (c) 2001-2009, The HSQL Development Group
- * All rights reserved.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions are met:
- *
- * Redistributions of source code must retain the above copyright notice, this
- * list of conditions and the following disclaimer.
- *
- * Redistributions in binary form must reproduce the above copyright notice,
- * this list of conditions and the following disclaimer in the documentation
- * and/or other materials provided with the distribution.
- *
- * Neither the name of the HSQL Development Group nor the names of its
- * contributors may be used to endorse or promote products derived from this
- * software without specific prior written permission.
- *
- * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
- * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
- * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
- * ARE DISCLAIMED. IN NO EVENT SHALL HSQL DEVELOPMENT GROUP, HSQLDB.ORG,
- * OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
- * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
- * LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
- * ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
- * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
- * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- */
-
-
-package org.hsqldb.test;
-
-import java.sql.Connection;
-import java.sql.PreparedStatement;
-import java.sql.ResultSet;
-import java.sql.Statement;
-import java.sql.Timestamp;
-import java.util.Calendar;
-import java.util.GregorianCalendar;
-import java.util.TimeZone;
-
-import junit.framework.TestCase;
-import junit.framework.TestResult;
-
-/**
- * Created on Apr 28, 2005
- * @author Antranig Basman (antranig@caret.cam.ac.uk)
- */
-public class TestBug1191815 extends TestBase {
-
- public TestBug1191815(String name) {
- super(name);
- }
-
- public void test() throws Exception {
-
- try {
- Connection conn = newConnection();
- Statement stmt = conn.createStatement();
-
- stmt.executeUpdate("drop table testA if exists;");
- stmt.executeUpdate("create table testA(data timestamp);");
-
- TimeZone pst = TimeZone.getTimeZone("PST");
- Calendar cal = new GregorianCalendar(pst);
-
- cal.clear();
- cal.set(2005, 0, 1, 0, 0, 0);
-
-
- // yyyy-mm-dd hh:mm:ss.fffffffff
- Timestamp ts = new Timestamp(cal.getTimeInMillis());
- ts.setNanos(1000);
- PreparedStatement ps =
- conn.prepareStatement("insert into testA values(?)");
-
- ps.setTimestamp(1, ts, cal);
- ps.execute();
- ps.setTimestamp(1, ts, null);
- ps.execute();
-
- String sql = "select * from testA";
-
- stmt = conn.createStatement();
-
- ResultSet rs = stmt.executeQuery(sql);
-
- rs.next();
-
- Timestamp returned = rs.getTimestamp(1, cal);
-
- rs.next();
-
- Timestamp def = rs.getTimestamp(1, null);
-
- assertEquals(ts, returned);
- assertEquals(ts, def);
- } catch (Exception e) {
- e.printStackTrace();
- fail();
- }
- }
-
- public static void main(String[] args) throws Exception {
-
- TestResult result;
- TestCase test;
- java.util.Enumeration exceptions;
- java.util.Enumeration failures;
- int count;
-
- result = new TestResult();
- test = new TestBug1191815("test");
-
- test.run(result);
-
- count = result.failureCount();
-
- System.out.println("TestBug1192000 failure count: " + count);
-
- failures = result.failures();
-
- while (failures.hasMoreElements()) {
- System.out.println(failures.nextElement());
- }
- }
-}
-
diff --git a/dev-db/mysql-workbench/Manifest b/dev-db/mysql-workbench/Manifest
index 6389220e4a2d..0992223ea54a 100644
--- a/dev-db/mysql-workbench/Manifest
+++ b/dev-db/mysql-workbench/Manifest
@@ -1,7 +1,6 @@
AUX mysql-workbench-6.2.5-wbcopytables.patch 496 BLAKE2B 4666f32098ec43ad36f1c726903472e829873002521262d6781a2febfc1394dac6f9708fbb99a3fa52a032a5b8f695c9b98579b28a63e74727eac21a8ef3fbe6 SHA512 c0766315cd345893af57880eccdc2c1dd9ffa456a27d0c736af1382ca24c507de865188588753f212f35d8781305dcbd8d555f128edd6454dc2299bd0357fd5b
AUX mysql-workbench-8.0.19-mysql-connector-8.patch 624 BLAKE2B 0cb899a8b0127664471877bb9cdcda946c35ed7a159646b94891a791a618c77201cc7696d6f2893e95fd78dbc13325cef752740f76e69974e10c0f88084594fb SHA512 09c2349cb42393f6d32f24804e2c3438a5d846fc9611e0684ccf2139fd30b0abcb0f2aa7b205c60a081259e073fb345cd72837dab1a216e6a8aaaba5ec3decf7
AUX mysql-workbench-8.0.33-gcc13.patch 1516 BLAKE2B 831bde621ae092aeb75bf3e9cab6ad8eecfef27e036586fe4a3ca8a60f8d512ce4610a9ebf20e956c4a903df18eb0c3f2c5608cda462ca3c2a1cee50b0e6b1f9 SHA512 a37e9d9de5d7606528bdf80f15fda67511328bb8826005810a633eeb5b12d942b27c8a4b8287d13de8e77979f8dab90f671fb3d0334cdb9d4d7ed10bdac84ef5
-AUX mysql-workbench-8.0.36-libxml2-2.12-support.patch 1167 BLAKE2B f0f7275dd923191accaeea90bdfff2e511c20eb1d5a7e369852b1d572b8b2e5945c2f04ec95a9eb92b7c96c3622d817a1d60da18ea31f4037d4a8406957971a7 SHA512 89196eb3c61636111914eed8fbf501cfeb1bd5c605c7b0bd2bac8e56fad957c7d02d34b423b456365c5c11b367ac10e9bf04ba07e8486d53170eb11003e5990d
DIST antlr-4.11.1-complete.jar 3547867 BLAKE2B 24e9799a402302fd13ebd91028a8e3b8141af50b446bc06bb4df3f7619cad956e9b681c0908b870a1f9d6701049e89099906cdc6038dc007984b19f7a8cc756b SHA512 a445bb71e4470ffa7bbb382a873fe5c5737b96b2c68b57593c1151ed9944ec701ce0c299ea5c3b593bd33916d384d598e2538a9b0b11b41c77a399beca4aab88
DIST mysql-workbench-community-8.0.38-src.tar.gz 59069184 BLAKE2B ace0afbab46c106200da5234595065766798d97f57008261c166f97bed842f185e1bba90e0c60b9acf4843b54261b5aa49c8a3a6b096e72597443fcb1a011217 SHA512 9fa18d3a66111461dd47dec05ea8dfa214dac85017d51358e694d56cb05439d96a91f675e105cfbecc70c456127964a81ddb2a5a2951457196b20b10dcb6f502
EBUILD mysql-workbench-8.0.38.ebuild 2999 BLAKE2B e9e6452fe944e8ae846e8e60f1d9642a268074eccfcdc63637effb1cd77bc253b01d54b1225105180d01a394341cf1c87a5a49a9198546b02ec1b7e55e1f1481 SHA512 f34ec499aca287e946ff01ed51010b5e6a77a4a5a850b935448f8e3f30ff03d5c3f05daa371eb806160100de7f7ad7d61d24a5cc9f9c60c6a7982aa10c324028
diff --git a/dev-db/mysql-workbench/files/mysql-workbench-8.0.36-libxml2-2.12-support.patch b/dev-db/mysql-workbench/files/mysql-workbench-8.0.36-libxml2-2.12-support.patch
deleted file mode 100644
index e3ee9aa099f0..000000000000
--- a/dev-db/mysql-workbench/files/mysql-workbench-8.0.36-libxml2-2.12-support.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-https://bugs.gentoo.org/923020
-https://github.com/mysql/mysql-workbench/pull/43
-
-From 8f8917671ab5a06f842a340f31c6d4ec7634147a Mon Sep 17 00:00:00 2001
-From: Alfred Wingate <parona@protonmail.com>
-Date: Sat, 27 Jan 2024 22:51:15 +0200
-Subject: [PATCH] Fix support for libxml2-2.12 with its api and header changes
-
-Signed-off-by: Alfred Wingate <parona@protonmail.com>
---- a/library/grt/src/grt.h
-+++ b/library/grt/src/grt.h
-@@ -34,6 +34,7 @@
- #include <vector>
- #include <stdexcept>
- #include <boost/function.hpp>
-+#include <libxml/tree.h>
- #include <libxml/xmlmemory.h>
- #include "base/threading.h"
- #include <string>
---- a/library/grt/src/unserializer.cpp
-+++ b/library/grt/src/unserializer.cpp
-@@ -401,7 +401,11 @@ ValueRef internal::Unserializer::unserialize_xmldata(const char *data, size_t si
- xmlDocPtr doc = xmlReadMemory(data, (int)size, NULL, NULL, XML_PARSE_NOENT);
-
- if (!doc) {
-+#if LIBXML_VERSION >= 21200
-+ const xmlError* error = xmlGetLastError();
-+#else
- xmlErrorPtr error = xmlGetLastError();
-+#endif
-
- if (error)
- throw std::runtime_error(base::strfmt("Could not parse XML data. Line %d, %s", error->line, error->message));