summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/Manifest.gzbin15235 -> 15401 bytes
-rw-r--r--dev-db/influx-cli/Manifest4
-rw-r--r--dev-db/influx-cli/influx-cli-2.7.3.ebuild27
-rw-r--r--dev-db/influx-cli/metadata.xml11
-rw-r--r--dev-db/influxdb/Manifest3
-rw-r--r--dev-db/influxdb/influxdb-2.7.1-r1.ebuild10
-rw-r--r--dev-db/influxdb/influxdb-2.7.1.ebuild230
-rw-r--r--dev-db/sqlite/Manifest6
-rw-r--r--dev-db/sqlite/sqlite-3.41.2-r1.ebuild4
-rw-r--r--dev-db/sqlite/sqlite-3.42.0.ebuild4
-rw-r--r--dev-db/sqlite/sqlite-9999.ebuild4
11 files changed, 62 insertions, 241 deletions
diff --git a/dev-db/Manifest.gz b/dev-db/Manifest.gz
index 0f48204ce356..cdc1ad21260e 100644
--- a/dev-db/Manifest.gz
+++ b/dev-db/Manifest.gz
Binary files differ
diff --git a/dev-db/influx-cli/Manifest b/dev-db/influx-cli/Manifest
new file mode 100644
index 000000000000..cb7973087b5e
--- /dev/null
+++ b/dev-db/influx-cli/Manifest
@@ -0,0 +1,4 @@
+DIST influx-cli-2.7.3-deps.tar.xz 52915924 BLAKE2B 38ca630eb4445dfdd66ed47362cbad220e727c8ddab64eb262e4859577155038650e5d14fcdc6fd8f44c541db07d1b79503c7d9ec5fdd52595198293edf3850e SHA512 c2fa4b7d5d744a85de11f97e3172c9d51b2c1c7b2e31d35fbd15a6ba2b6c12cd4d265216ced0bd27d150d5d3ee619e7d972b67c63cfdbdfdfb69d84d966d881c
+DIST influx-cli-2.7.3.tar.gz 442354 BLAKE2B 3c69e6a2510a4b82830134b930ebc62446848f19cad302f35796853cebd53002963a2d9015512dbf60a4a24e86f237af1ce62c698231150a66331cd8718f2c69 SHA512 d2ffd56c7a1dee24e48afdf487e79b3f125f897fe1c642cccf64a9544134dd6692ebd40415624418597341c16c1afbd444b949c9e3d1bb825ebed5e3f8392dfa
+EBUILD influx-cli-2.7.3.ebuild 600 BLAKE2B 4219f97ec590afddc9f9204561083ea9f06b64cf3675057b0c23e3eff07141304d06dea2bc24f4e4cdce70d583a7e8d8a849efa7d4898685aa43df8d4c3d7f1c SHA512 d4ea5df49c99dc20cf7609ab17d9411bf7a2f21672de471777d6c679fe98efe86cec2119389575654eb7bcb01c724c693c442ee2b717e001a5e6555f53a390cf
+MISC metadata.xml 335 BLAKE2B ccdc9654f7819519bea209895c0a001e37c8297a7de8a55e283ab6ba9427fa4838c04f2d93f303b9d510e72538d076b7c768689be13ce9a384ab645c41cdf25f SHA512 9d5fafd31f2aa729643aa0c2535a0d2f35019706ae246fe5b1d85a388bdfb006a676853a29ea601e042fd39dcb6a4007d94176793d79eb50d9ba632e3c11aa5e
diff --git a/dev-db/influx-cli/influx-cli-2.7.3.ebuild b/dev-db/influx-cli/influx-cli-2.7.3.ebuild
new file mode 100644
index 000000000000..32cb6d38589f
--- /dev/null
+++ b/dev-db/influx-cli/influx-cli-2.7.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+MY_PV="${PV/_rc/-rc.}"
+
+DESCRIPTION="The command line for influxdb"
+HOMEPAGE="https://github.com/influxdata/influx-cli"
+
+SRC_URI="https://github.com/influxdata/influx-cli/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT=" test"
+
+src_compile() {
+ unset LDFLAGS
+ emake
+}
+
+src_install() {
+ dobin bin/$(go env GOOS)/$(go env GOARCH)/influx
+}
diff --git a/dev-db/influx-cli/metadata.xml b/dev-db/influx-cli/metadata.xml
new file mode 100644
index 000000000000..1d3caf78c06f
--- /dev/null
+++ b/dev-db/influx-cli/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">influxdata/influx-cli</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/influxdb/Manifest b/dev-db/influxdb/Manifest
index 8b9cd856e894..242aec85bb94 100644
--- a/dev-db/influxdb/Manifest
+++ b/dev-db/influxdb/Manifest
@@ -155,6 +155,5 @@ DIST winapi-i686-pc-windows-gnu-0.4.0.crate 2918815 BLAKE2B 4d357e4d30f955297217
DIST winapi-util-0.1.5.crate 10164 BLAKE2B fc800aceae5249a858c806c3e969ef2545766099872d856ebee51c883d9acf1122278db9607d50ca53eac351502b700fd2463900932d342240f97f683d517963 SHA512 7baeb661f397c4693dfa001fdc774b323c51a7c55caad40f2de5112a1cefd1d6151e3df41fa4ee193460a5905917c83d2b1de5fa10b4bd014ad96690af95c0fd
DIST winapi-x86_64-pc-windows-gnu-0.4.0.crate 2947998 BLAKE2B 2ad1ea8b5fa07d544e910ccba043ae925269b76b26c9da356305b34b86741dd8b9aff0b9ffe3d562db4fcd7d7c46a11ce9e3168b782b1d89ae6881742b7ede82 SHA512 4a654af6a5d649dc87e00497245096b35a2894ae66f155cb62389902c3b93ddcc5cf7d0d8b9dd97b291d2d80bc686af2298e80abef6ac69883f4a54e79712513
EBUILD influxdb-1.8.10.ebuild 1415 BLAKE2B c32cd9f1b5ad1696b4e612f2c99c43170e828a41653004da588e607b19de495bc8926ca1a7d60287a49394c53509d9e542ecff4b378b4486e7b69d4c3e044afb SHA512 ee1e42b70fabf4ed8676033be9a0f5e10d514a9ad98741a0e685cfb8e11f4f8f51a0ed28f91043e5b78c44f7dbfe74aea6f93fc79193ca8da425316fcd561b69
-EBUILD influxdb-2.7.1-r1.ebuild 5129 BLAKE2B 4028a527457636b2aaf192ca7291724a59f3618421b9c30ab4f70ad3d22585d2a475ced9bb9293a21e398ee59f097a44fd0bcda8d043677cbd4cc952eae1922a SHA512 49ba8abb47d4026f5abdf27b2ecce59ef126bffc19dc91467a5282350eff646e96b9886845e9f079114e764058dc4546aa8c3a23527db82ab0ed893e94f5dcc2
-EBUILD influxdb-2.7.1.ebuild 4784 BLAKE2B 5cfdea3e23c088ef059a501a6df128e3a7fd2bf4cd4ae72797620b6b6a1d7eb0a4103aaa3a5c7d1f4e54cc208fd63823a894be8e3e2f133b64fffbf9f267c731 SHA512 47d87db2196fc0db33e8cb684b6e1f613d95dd1c46372e4fba85be2ea66f73a29d83daa658f45164d60db00b4674a443ce0b6025efe4e8e916235fd8252b8f6f
+EBUILD influxdb-2.7.1-r1.ebuild 5526 BLAKE2B 77cb6bcdf76e7e2e2f75045954732c0e03d2c6f5d365f19ce561cc9b3d36966cf1b2b71aa88fd2ee6809f6741f39261fc1fd41d86aefd746af9c430eaf1a057b SHA512 28107d0998240090b4988b47b723a81bdea3880b25fb2ab6e27d16ee4ab8cd759dac3c1f4eeae9120995de628c822acb6433cde9ea20e67b778684b6889345a4
MISC metadata.xml 794 BLAKE2B b2918ee4b0c547e06957606fc84ce3fa44144f6e4510ac2bca9008645ca4a08058f02c8cd96623575214763856a97f9fa887ca70dd8a9ba884c9328b1ea54a8a SHA512 4badc736aae9a6aa97766dedc40f906b983f91c9a08fe2784df2768bcbf4e164a365276bfcef271767b9d86afa7ccccbc8dbe31857641c724eeb0e2deeda01ee
diff --git a/dev-db/influxdb/influxdb-2.7.1-r1.ebuild b/dev-db/influxdb/influxdb-2.7.1-r1.ebuild
index 4ee0d5e90982..1209ebeda900 100644
--- a/dev-db/influxdb/influxdb-2.7.1-r1.ebuild
+++ b/dev-db/influxdb/influxdb-2.7.1-r1.ebuild
@@ -236,3 +236,13 @@ src_install() {
keepdir /var/log/influxdb
fowners influxdb:influxdb /var/log/influxdb
}
+
+pkg_postinst() {
+ elog "Upgrading from InfluxDB1.x requires migration of time series data."
+ elog "See https://docs.influxdata.com/influxdb/v2.7/upgrade/v1-to-v2/"
+ elog "Keep in mind that some applications not compatible with InfluxDB 2.x"
+ elog "may stop working."
+
+ ewarn "The InfluxDB command line client has been moved to dev-db/influx-cli"
+ ewarn "You will need to install it separately"
+}
diff --git a/dev-db/influxdb/influxdb-2.7.1.ebuild b/dev-db/influxdb/influxdb-2.7.1.ebuild
deleted file mode 100644
index 47c999a22796..000000000000
--- a/dev-db/influxdb/influxdb-2.7.1.ebuild
+++ /dev/null
@@ -1,230 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CRATES="
- adler32-1.2.0
- ahash-0.7.6
- aho-corasick-0.7.18
- ansi_term-0.11.0
- ansi_term-0.12.1
- anyhow-1.0.56
- arrayvec-0.5.2
- atty-0.2.14
- autocfg-1.0.1
- bitflags-1.3.2
- bstr-0.2.17
- bumpalo-3.12.0
- cast-0.2.7
- cfg-if-1.0.0
- chrono-0.4.19
- clap-2.33.3
- codespan-reporting-0.11.1
- colored-2.0.0
- crc32fast-1.2.1
- criterion-0.3.5
- criterion-plot-0.4.4
- crossbeam-channel-0.5.1
- crossbeam-deque-0.8.1
- crossbeam-epoch-0.9.5
- crossbeam-utils-0.8.8
- csv-1.1.6
- csv-core-0.1.10
- ctor-0.1.21
- derivative-2.2.0
- derive_more-0.99.17
- diff-0.1.12
- dissimilar-1.0.3
- either-1.6.1
- ena-0.14.0
- env_logger-0.9.0
- expect-test-1.2.2
- fallible-iterator-0.2.0
- fallible-streaming-iterator-0.1.9
- fastrand-1.7.0
- flatbuffers-22.9.29
- fnv-1.0.7
- form_urlencoded-1.0.1
- getrandom-0.2.6
- half-1.8.2
- hashbrown-0.11.2
- hashlink-0.7.0
- heck-0.3.3
- hermit-abi-0.1.19
- humantime-2.1.0
- idna-0.2.3
- indexmap-1.8.1
- instant-0.1.12
- itertools-0.10.1
- itoa-0.4.8
- itoa-1.0.1
- js-sys-0.3.55
- lazy_static-1.4.0
- libc-0.2.121
- libflate-1.2.0
- libflate_lz77-1.1.0
- libsqlite3-sys-0.23.2
- lock_api-0.4.6
- log-0.4.16
- lsp-types-0.91.1
- maplit-1.0.2
- matches-0.1.9
- memchr-2.4.1
- memoffset-0.6.4
- num-integer-0.1.44
- num-traits-0.2.14
- num_cpus-1.13.0
- once_cell-1.10.0
- oorandom-11.1.3
- ordered-float-3.2.0
- output_vt100-0.1.2
- pad-0.1.6
- parking_lot-0.11.2
- parking_lot_core-0.8.5
- percent-encoding-2.1.0
- pkg-config-0.3.25
- plotters-0.3.1
- plotters-backend-0.3.2
- plotters-svg-0.3.1
- pretty-0.11.2
- pretty_assertions-1.2.1
- proc-macro-error-1.0.4
- proc-macro-error-attr-1.0.4
- proc-macro2-1.0.32
- pulldown-cmark-0.9.1
- quote-1.0.10
- rayon-1.5.2
- rayon-core-1.9.2
- redox_syscall-0.2.10
- regex-1.5.5
- regex-automata-0.1.10
- regex-syntax-0.6.25
- remove_dir_all-0.5.3
- rle-decode-fast-1.0.1
- rusqlite-0.26.3
- rustc-hash-1.1.0
- rustc_version-0.4.0
- ryu-1.0.5
- salsa-0.17.0-pre.2
- salsa-macros-0.17.0-pre.2
- same-file-1.0.6
- scopeguard-1.1.0
- semver-1.0.4
- serde-1.0.136
- serde_cbor-0.11.2
- serde_derive-1.0.136
- serde_json-1.0.79
- serde_repr-0.1.7
- smallvec-1.7.0
- strsim-0.8.0
- structopt-0.3.26
- structopt-derive-0.4.18
- syn-1.0.81
- tempfile-3.3.0
- termcolor-1.1.2
- textwrap-0.11.0
- thiserror-1.0.30
- thiserror-impl-1.0.30
- time-0.1.43
- tinytemplate-1.2.1
- tinyvec-1.5.1
- tinyvec_macros-0.1.0
- typed-arena-2.0.1
- unicase-2.6.0
- unicode-bidi-0.3.7
- unicode-normalization-0.1.19
- unicode-segmentation-1.8.0
- unicode-width-0.1.9
- unicode-xid-0.2.2
- url-2.2.2
- vcpkg-0.2.15
- vec_map-0.8.2
- version_check-0.9.3
- walkdir-2.3.2
- wasi-0.10.2+wasi-snapshot-preview1
- wasm-bindgen-0.2.78
- wasm-bindgen-backend-0.2.78
- wasm-bindgen-macro-0.2.78
- wasm-bindgen-macro-support-0.2.78
- wasm-bindgen-shared-0.2.78
- web-sys-0.3.55
- winapi-0.3.9
- winapi-i686-pc-windows-gnu-0.4.0
- winapi-util-0.1.5
- winapi-x86_64-pc-windows-gnu-0.4.0
-"
-
-inherit cargo go-module
-
-DESCRIPTION="Scalable datastore for metrics, events, and real-time analytics"
-HOMEPAGE="https://www.influxdata.com"
-
-SRC_URI="https://github.com/influxdata/influxdb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://github.com/influxdata/ui/releases/download/OSS-v${PV}/build.tar.gz -> ${P}-assets.tar.gz"
-SRC_URI+=" https://gentoo.kropotkin.rocks/go-pkgs/${P}-deps.tar.xz"
-SRC_URI+=" $(cargo_crate_uris)"
-
-LICENSE="Apache-2.0 BSD BSD-2 EPL-2.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="virtual/pkgconfig"
-
-COMMON_DEPEND="
- acct-group/influxdb
- acct-user/influxdb
-"
-
-DEPEND="${COMMON_DEPEND}"
-
-src_unpack() {
- cargo_src_unpack
-}
-
-src_prepare() {
- default
-
- local data_dir
- data_dir="${S}/static/data"
- mkdir "${data_dir}" || die
- mv "${WORKDIR}/build" "${data_dir}" || die
-}
-
-src_compile() {
- mv "${WORKDIR}/go-mod" "${WORKDIR}/go-mod-tmp" || die
- mv "${WORKDIR}/go-mod-tmp/github.com/influxdata/pkg-config@v0.2.11/go-mod" "${WORKDIR}/go-mod" || die
- cd "${WORKDIR}"/go-mod-tmp/github.com/influxdata/pkg-config* || die
- ego build .
- mv "${WORKDIR}/go-mod" "${WORKDIR}/go-mod-tmp/github.com/influxdata/pkg-config@v0.2.11" || die
- mv "${WORKDIR}/go-mod-tmp" "${WORKDIR}/go-mod" || die
-
- cd "${WORKDIR}/go-mod/github.com/influxdata/flux@v0.193.0/libflux" || die
- cargo_src_compile
-
- cd "${S}" || die
-
- export PKG_CONFIG="${WORKDIR}/go-mod/github.com/influxdata/pkg-config@v0.2.11/pkg-config"
- ego generate ./static
- GOBIN="${S}/bin" \
- ego install \
- -tags 'assets,noasm,sqlite_json,sqlite_foreign_keys' \
- -ldflags="-X main.version=${PV}" \
- ./...
-}
-
-src_test() {
- ego test ./tests
-}
-
-src_install() {
- dobin bin/influx*
- dodoc *.md
-
- newconfd "${FILESDIR}"/influxdb.confd influxdb
- newinitd "${FILESDIR}"/influxdb.initd influxdb
- keepdir /var/log/influxdb
- fowners influxdb:influxdb /var/log/influxdb
-}
diff --git a/dev-db/sqlite/Manifest b/dev-db/sqlite/Manifest
index f66144a80aae..f7edf6397dd6 100644
--- a/dev-db/sqlite/Manifest
+++ b/dev-db/sqlite/Manifest
@@ -3,7 +3,7 @@ DIST sqlite-doc-3410200.zip 10633275 BLAKE2B 1323179d04b9fa21df4ed93ad1aa89ff943
DIST sqlite-doc-3420000.zip 10665938 BLAKE2B 62aef59e6976101ecca60d1ee194e9e558009dd8bdb7cd911f9938f1256e50bc946f8ca554666b6c101f7024baac7857b83adf6e897164afb9b5c4d4917593d1 SHA512 d675ee2897323d468816bc713594c4e94cb5c15270b4f991758e2c82e2891ad724c5790f29b76bc9e5d6b3be04e95aee371c57ceb2d855c1057b4af62a5af162
DIST sqlite-src-3410200.zip 13836230 BLAKE2B 4edcd65728143b1ea27abe65db8c8353dfa309858e6f40d70f3c376ef9e5613d92c41ed5a3c3282cacef8a29a434e3881f6e47ba5642820331170ceb69321d86 SHA512 28cfa72f2b39d851c38fb757a0c6d0696c22548792ce2fa1be5e2f6084e4bf0a5fb216902b59ccba5b6ebaf140aab954ed7676d84841b58ad063404a119a0c17
DIST sqlite-src-3420000.zip 13910252 BLAKE2B defe14bf0b5588775b2a2b17b3adbbaf39f1e95eac049cbd4868e2e59fbf50fb92b11c74ecf12fe0138521e7d4d3cc2a4bf45e7c83fd774abd7aa9ed7ee0f925 SHA512 509b7aa292870c927ef137469028e5e07ca74907414c5b295360cb10b377a42de7469d3afe79f8d9947d486ef74d676679c7f2d3b1caaeb8c949f27201180def
-EBUILD sqlite-3.41.2-r1.ebuild 13003 BLAKE2B 726be151b261915a6eef651643291aaba2ce87d2347a2e7840412f6db397e62157af60e8030b103f8112fc16224abc7b74f75bfabaf80dfb69cce48bd6260aba SHA512 028211c576e45fda20f350308c0bf38ed7c83d91e96f708933014d284157470f132fd55d1283351a63a32a3ffdf5d7738eeefccec2b467b5c4b60e6104652d31
-EBUILD sqlite-3.42.0.ebuild 12923 BLAKE2B 0ba7a7f8967c1919ae717bd29f788dfa4393f81dfa1a71519595753f35f0626f3676ec72e73229114bc3beb39a0f0cfc0edaec1e4a2b4c818e6d4afabb250d4d SHA512 f40f1b643029b5814720ce664d8a08a31ac35fe815c2fd4b05aa23ca848d5f198032aa54c687315c8fd051528421f08a0ddc9e16327402c84b47fc09a7012c2c
-EBUILD sqlite-9999.ebuild 12923 BLAKE2B f374edffb203a33301d6d3aa2dcf32866c7022f71e4e2e3925f861e04ba566fd47ff4a8e3f7ccd09e7a42f9375a155a5db00fca3abd64dd9229a2dc8ce29d7ac SHA512 d412ed99acee497dc586f0a2b5e7291033c39f295661abf7968a6f9a679771762fa44ec589df1e4c94d66cc3ed276d5bdd541fdddc2ab91e01cb3861b7cb28dd
+EBUILD sqlite-3.41.2-r1.ebuild 12999 BLAKE2B aca1c41e940bafbe52de6c013ce6c9998542c438e95ee3c191b386c36a3cf13191165d7e11aee7095bfca9b87aaca9742ea2734b6e22378140019107b737791e SHA512 6df05d199014fbe26829c24c116ae17962cd667b87f2374a2c405456bdbe638d7a0a963222e9597ca2f4cde62c199dc50fc3b81ef5bd57d87cd3c93fb53f533a
+EBUILD sqlite-3.42.0.ebuild 12919 BLAKE2B e1c2637037386921bdce85d0a529bbe809177fa3c38e234a237de177bc7a5d26caed12a9ab14a1a7fea11efc1413113de62c228ea5ac1bffaeaf7b33eff02ec4 SHA512 5e18e47422e1816fb7daa51652b0f9c02c472b839a64b81716d5a50c8247542ac93ce0fbf203e3f86049b0681d438bae48e76b5abfe7f2423cc0cbeed9a90ece
+EBUILD sqlite-9999.ebuild 12919 BLAKE2B 55a0ddbcc8678367cca5ce06d69d6b5c09e1a4304dd1b06878c9031edba4846d2b5ef110e62bd7af12404644dc7ce2c19a0134451567ed6f86ad6c0d7e240dea SHA512 3235352b431d9a6ac1080da2b699dc069ba3c0d3a57d26a29d6e791e806b3262fd21de66a585d7fd5ad0042e23198fefcff518d349d98453b5268e80d3ae60a0
MISC metadata.xml 824 BLAKE2B 8ab2e8f230bf3a2b26077d90944bca7bf35ae905310205b90bf243365148488303256606c0ee7c3fb736300686466a1c2583bf103693c20063ca668fe9e52647 SHA512 ed4a89e3c2d633cb6ebf8bcbf3ca055d0d1b2ffd801ba559395f812faeaafdfedd97dae11a5a53a4c068e43026fbd4eed4cb12c8b89a7fda6dabe6f78a2e0b38
diff --git a/dev-db/sqlite/sqlite-3.41.2-r1.ebuild b/dev-db/sqlite/sqlite-3.41.2-r1.ebuild
index b123ebe2b644..c7a72617f114 100644
--- a/dev-db/sqlite/sqlite-3.41.2-r1.ebuild
+++ b/dev-db/sqlite/sqlite-3.41.2-r1.ebuild
@@ -14,9 +14,9 @@ if [[ ${PV} == 9999 ]]; then
S="${WORKDIR}"/${PN}
PROPERTIES="live"
else
- SRC_PV="$(printf "%u%02u%02u%02u" $(ver_rs 1- " "))"
+ printf -v SRC_PV "%u%02u%02u%02u" $(ver_rs 1- " ")
DOC_PV="${SRC_PV}"
- #DOC_PV="$(printf "%u%02u%02u00" $(ver_rs 1-3 " "))"
+ #printf -v DOC_PV "%u%02u%02u00" $(ver_rs 1-3 " ")
SRC_URI="
https://sqlite.org/2023/${PN}-src-${SRC_PV}.zip
diff --git a/dev-db/sqlite/sqlite-3.42.0.ebuild b/dev-db/sqlite/sqlite-3.42.0.ebuild
index 8e4f233695fa..e6a1a94de643 100644
--- a/dev-db/sqlite/sqlite-3.42.0.ebuild
+++ b/dev-db/sqlite/sqlite-3.42.0.ebuild
@@ -14,9 +14,9 @@ if [[ ${PV} == 9999 ]]; then
S="${WORKDIR}"/${PN}
PROPERTIES="live"
else
- SRC_PV="$(printf "%u%02u%02u%02u" $(ver_rs 1- " "))"
+ printf -v SRC_PV "%u%02u%02u%02u" $(ver_rs 1- " ")
DOC_PV="${SRC_PV}"
- #DOC_PV="$(printf "%u%02u%02u00" $(ver_rs 1-3 " "))"
+ #printf -v DOC_PV "%u%02u%02u00" $(ver_rs 1-3 " ")
SRC_URI="
https://sqlite.org/2023/${PN}-src-${SRC_PV}.zip
diff --git a/dev-db/sqlite/sqlite-9999.ebuild b/dev-db/sqlite/sqlite-9999.ebuild
index 2595b6ad1b89..1075e742ae8f 100644
--- a/dev-db/sqlite/sqlite-9999.ebuild
+++ b/dev-db/sqlite/sqlite-9999.ebuild
@@ -14,9 +14,9 @@ if [[ ${PV} == 9999 ]]; then
S="${WORKDIR}"/${PN}
PROPERTIES="live"
else
- SRC_PV="$(printf "%u%02u%02u%02u" $(ver_rs 1- " "))"
+ printf -v SRC_PV "%u%02u%02u%02u" $(ver_rs 1- " ")
DOC_PV="${SRC_PV}"
- #DOC_PV="$(printf "%u%02u%02u00" $(ver_rs 1-3 " "))"
+ #printf -v DOC_PV "%u%02u%02u00" $(ver_rs 1-3 " ")
SRC_URI="
https://sqlite.org/2022/${PN}-src-${SRC_PV}.zip