summaryrefslogtreecommitdiff
path: root/dev-db/spatialite/spatialite-5.0.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/spatialite/spatialite-5.0.1-r2.ebuild')
-rw-r--r--dev-db/spatialite/spatialite-5.0.1-r2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-db/spatialite/spatialite-5.0.1-r2.ebuild b/dev-db/spatialite/spatialite-5.0.1-r2.ebuild
index 3b51ff672d08..fceb9a7de979 100644
--- a/dev-db/spatialite/spatialite-5.0.1-r2.ebuild
+++ b/dev-db/spatialite/spatialite-5.0.1-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit libtool
+
MY_PN="lib${PN}"
MY_P="${MY_PN}-${PV}"
@@ -31,6 +33,11 @@ DEPEND="${RDEPEND}"
REQUIRED_USE="test? ( iconv )"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
# 1) gcp disabled for now to preserve MPL licence
econf \