summaryrefslogtreecommitdiff
path: root/dev-db/slony1
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/slony1')
-rw-r--r--dev-db/slony1/Manifest2
-rw-r--r--dev-db/slony1/slony1-2.2.10-r1.ebuild11
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-db/slony1/Manifest b/dev-db/slony1/Manifest
index 89cffcd416ba..67b642d8cd80 100644
--- a/dev-db/slony1/Manifest
+++ b/dev-db/slony1/Manifest
@@ -2,5 +2,5 @@ AUX slony1.conf 249 BLAKE2B ec214fb9a7d51bcaa58dc191d7e943c0d07be85c0f31dadbf199
AUX slony1.init 615 BLAKE2B f1b3fc27ad3c4087713cceb6c2bb9451004b70e87c0347274c75e1c3ed8d439bb99f51d5e6e904d3957150e62760272312423a47235ff4e76792e0661b683bb3 SHA512 d450bba5f65372509e542f138d297202371bcaf78332ba13de72ddf937fcffe419083dddc5032c7bafd51993fbc677b37262e1b1e938e9e3c927e130c0a7c693
DIST slony1-2.2.10-docs.tar.bz2 1445193 BLAKE2B 071f5faf2f7cae822b484f13ede6a8ede5278a065c55d2199f38e2dd195922cbc78982633316792978b968295d69e36651ae0367682ad45afab295e61e5329fa SHA512 d603abccc1ec7922fe8025ab178e6d12b28ffc763848be8d1f9fc93519b9928aa65ed6bcc1d678f2ad9f79818de06da39ec1f69d60de61c5e6fe42137c7c3112
DIST slony1-2.2.10.tar.bz2 1464652 BLAKE2B a07a830501be13f33fc189128851cee02c8d8ca51a8a54f6b97028d65eb17937817c9ab6b5ebbcaa092e96fb00f57959806e5003e016df5e7034583de601084c SHA512 1b41addb7a0be0a130c2efcab1b241e3158d10a5a6e203d83f28353e303dd524e224ab9c04a7e37a0f89cd944237b90feeb8910eb35f717926aa3ad28dbe2d0f
-EBUILD slony1-2.2.10-r1.ebuild 1936 BLAKE2B 0a2deef586e9fdaf24e8486b035bb806a7521971b6417815eb48aff47dbae62506ff90253a3cb03aac91de9580ac66a564a095019573b1fe58087b6b1b7feac0 SHA512 4ee8bf250a5c63d06c93742b3fbf3f167c1743da25aa920f318c233c69b13d784982cdb624202e0421655b4092e14c035d92860459a97f43a73d370479c4df9a
+EBUILD slony1-2.2.10-r1.ebuild 2080 BLAKE2B a86b47d3ac5d4cb213b556d7a88010291429c0f09e7ab72e38cb3449140c333cb18ed75ad46b7580f66770189bc8f4e0a9e05ea98e98bc5d79d8c811e9fd1300 SHA512 b976c360a9b1dc042284c2aa4c301baa4b846307c2eb53f3e3a2837744f1c28d0a86b6e323319a54e314e05c91cac7eb6fa1a11932974bc55b03193de85f1567
MISC metadata.xml 281 BLAKE2B 85a0d31b886497ac44662bb58420de2f6af5444882f008f902287c6a8265f6e76afa7513b0edeca5b34a26d69d9aa61832c5fb3287c577a7f047180aa3fb242e SHA512 9e9007a37a7acc9948a6eb15bd1bdfea46c95eacc88e96a878237baaf01298b1f849d6e170f04638bbfb68f2c8b8a3bf227e563b5309f859cfcd23d43bc5dd85
diff --git a/dev-db/slony1/slony1-2.2.10-r1.ebuild b/dev-db/slony1/slony1-2.2.10-r1.ebuild
index 81ec3602d9bd..1115cf1c6835 100644
--- a/dev-db/slony1/slony1-2.2.10-r1.ebuild
+++ b/dev-db/slony1/slony1-2.2.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
POSTGRES_COMPAT=( 9.6 {10..14} )
POSTGRES_USEDEP="server,threads(+)"
-inherit postgres-multi
+inherit flag-o-matic postgres-multi
IUSE="doc perl"
@@ -27,7 +27,7 @@ DEPEND="${POSTGRES_DEP}
"
RDEPEND=${DEPEND}
-REQUIRE_USE="${POSTGRES_REQ_USE}"
+REQUIRED_USE="${POSTGRES_REQ_USE}"
# Testing requires a more complex setup than we benefit from being able
# to perform.
@@ -47,6 +47,11 @@ src_unpack() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/855251
+ # https://github.com/ssinger/slony1-engine/issues/21
+ filter-lto
+
local slot_bin_dir="/usr/$(get_libdir)/postgresql-@PG_SLOT@/bin"
use perl && myconf=" --with-perltools=\"${slot_bin_dir}\""
postgres-multi_foreach econf ${myconf} \