summaryrefslogtreecommitdiff
path: root/dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171202.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171202.ebuild')
-rw-r--r--dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171202.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171202.ebuild b/dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171202.ebuild
new file mode 100644
index 000000000000..75caf3f0bb1a
--- /dev/null
+++ b/dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171202.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Qt SQL driver plugin for SQLCipher"
+HOMEPAGE="https://github.com/blizzard4591/qt5-sqlcipher"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="LGPL-2.1" # version 2.1 only
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-db/sqlcipher-3.4.1
+ >=dev-qt/qtcore-5.7.1:5=
+ >=dev-qt/qtsql-5.7.1:5=[sqlite]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+DOCS=(README.md)
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-install-path.patch
+ sed -i -e "s/@LIBDIR@/$(get_libdir)/" CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ ./qsqlcipher-test || die
+}