summaryrefslogtreecommitdiff
path: root/dev-db/pspg/pspg-5.5.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pspg/pspg-5.5.8.ebuild')
-rw-r--r--dev-db/pspg/pspg-5.5.8.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-db/pspg/pspg-5.5.8.ebuild b/dev-db/pspg/pspg-5.5.8.ebuild
new file mode 100644
index 000000000000..08af431e6bb1
--- /dev/null
+++ b/dev-db/pspg/pspg-5.5.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A better pager for CLI database clients, and can substitute psql"
+HOMEPAGE="https://github.com/okbob/pspg"
+SRC_URI="https://github.com/okbob/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="postgres"
+RESTRICT="test"
+
+RDEPEND="
+sys-libs/ncurses:=
+sys-libs/readline:=
+postgres? ( dev-db/postgresql:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_with postgres postgresql)
+}