summaryrefslogtreecommitdiff
path: root/dev-db/postgresql/postgresql-9.6.24.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql/postgresql-9.6.24.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-9.6.24.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-db/postgresql/postgresql-9.6.24.ebuild b/dev-db/postgresql/postgresql-9.6.24.ebuild
index c105a7861618..7dde31e0f3c2 100644
--- a/dev-db/postgresql/postgresql-9.6.24.ebuild
+++ b/dev-db/postgresql/postgresql-9.6.24.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -49,8 +49,8 @@ zlib? ( sys-libs/zlib )
# uuid flags -- depend on sys-apps/util-linux for Linux libcs, or if no
# supported libc in use depend on dev-libs/ossp-uuid. For BSD systems,
# the libc includes UUID functions.
-UTIL_LINUX_LIBC=( elibc_{glibc,uclibc,musl} )
-BSD_LIBC=( elibc_{Free,Net,Open}BSD )
+UTIL_LINUX_LIBC=( elibc_{glibc,musl} )
+BSD_LIBC=( elibc_{Net,Open}BSD )
nest_usedep() {
local front back
@@ -62,7 +62,6 @@ nest_usedep() {
echo "${front}${1}${back}"
}
-IUSE+=" ${UTIL_LINUX_LIBC[@]} ${BSD_LIBC[@]}"
CDEPEND+="
uuid? (
${UTIL_LINUX_LIBC[@]/%/? ( sys-apps/util-linux )}