summaryrefslogtreecommitdiff
path: root/dev-db/postgresql/postgresql-12.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql/postgresql-12.9.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-12.9.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/dev-db/postgresql/postgresql-12.9.ebuild b/dev-db/postgresql/postgresql-12.9.ebuild
index e4bba3a49ca3..f3837a3f0404 100644
--- a/dev-db/postgresql/postgresql-12.9.ebuild
+++ b/dev-db/postgresql/postgresql-12.9.ebuild
@@ -20,7 +20,7 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="https://www.postgresql.org/"
-IUSE="debug doc icu kerberos kernel_linux ldap llvm nls pam
+IUSE="debug doc icu kerberos ldap llvm nls pam
perl python +readline selinux +server systemd ssl static-libs tcl
threads uuid xml zlib"
@@ -54,7 +54,6 @@ zlib? ( sys-libs/zlib )
# supported libc in use depend on dev-libs/ossp-uuid. For BSD systems,
# the libc includes UUID functions.
UTIL_LINUX_LIBC=( elibc_{glibc,musl} )
-BSD_LIBC=( elibc_{Net,Open}BSD )
nest_usedep() {
local front back
@@ -69,7 +68,7 @@ nest_usedep() {
CDEPEND+="
uuid? (
${UTIL_LINUX_LIBC[@]/%/? ( sys-apps/util-linux )}
- $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} ${BSD_LIBC[@]/#/!} dev-libs/ossp-uuid)
+ $(nest_usedep ${UTIL_LINUX_LIBC[@]/#/!} dev-libs/ossp-uuid)
)"
DEPEND="${CDEPEND}
@@ -127,9 +126,6 @@ src_configure() {
for i in ${UTIL_LINUX_LIBC[@]}; do
use ${i} && uuid_config="--with-uuid=e2fs"
done
- for i in ${BSD_LIBC[@]}; do
- use ${i} && uuid_config="--with-uuid=bsd"
- done
[[ -z $uuid_config ]] && uuid_config="--with-uuid=ossp"
fi