summaryrefslogtreecommitdiff
path: root/dev-db/plr
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/plr')
-rw-r--r--dev-db/plr/Manifest3
-rw-r--r--dev-db/plr/metadata.xml24
-rw-r--r--dev-db/plr/plr-8.3.0.17.ebuild69
3 files changed, 96 insertions, 0 deletions
diff --git a/dev-db/plr/Manifest b/dev-db/plr/Manifest
new file mode 100644
index 000000000000..3cc708ef638c
--- /dev/null
+++ b/dev-db/plr/Manifest
@@ -0,0 +1,3 @@
+DIST plr-8.3.0.17.tar.gz 74017 BLAKE2B 314b4cfa2c3ca8ed31e80a72233a6dc8cdb9f3811dad6e9f3eb5147c17cdf5a039436598b0fc2b30c6702b02dd3cb2da33543764aee3199c6864aae22be875ce SHA512 d7080c62349d1dcdd17008a7be3643b54678e0f66bf721068df73057394496d025c4fe01e52945c3acf9cc21eb90241512667772ef3fe519a3c9081efe92dd40
+EBUILD plr-8.3.0.17.ebuild 1703 BLAKE2B 6791a8f1b9229a0eed14d05bf7298d9b768c6865e19674932a177b8d293bc4bccdeee8c1be4762a75f61e4698050af2350cb0063fdb66f9674241de09b708fd7 SHA512 705e25e42bedb0ae6b97191d66e3faafab94f73625864d94c759bcaa49f734daddce3e125166403ac1ee7e348455fc995e29c4927f34a7bde8144c7fd6b7ddcd
+MISC metadata.xml 847 BLAKE2B 0f861542afa6797366080a5bb4cd5546febb29cb583c87ea6a9ff61a60e50eb3d6a4df30ce55a69410e34f0ef91c0f3fe188a55474bca6f78e962709ffcb95bd SHA512 ed6d625612a41855b7636da7b231e4b1323f3940085d7d63b5ff048e44c66aba454172a9ff500abceb0ed1752f45de14b9c72b403441336a5ec9ecc2b2cff0cf
diff --git a/dev-db/plr/metadata.xml b/dev-db/plr/metadata.xml
new file mode 100644
index 000000000000..7eb0ae4794ba
--- /dev/null
+++ b/dev-db/plr/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>axs@gentoo.org</email>
+ <name>Ian Stakenvicius</name>
+ <description>Primary maintainer</description>
+</maintainer>
+<longdescription>
+An extension for postgresql databases to allow direct usage of <pkg>dev-lang/R</pkg>
+in SQL queries and database functions
+</longdescription>
+</pkgmetadata>
diff --git a/dev-db/plr/plr-8.3.0.17.ebuild b/dev-db/plr/plr-8.3.0.17.ebuild
new file mode 100644
index 000000000000..53ecfa0ff067
--- /dev/null
+++ b/dev-db/plr/plr-8.3.0.17.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+POSTGRES_COMPAT=( 9.{1..6} 10 )
+POSTGRES_USEDEP="server"
+
+inherit postgres-multi
+
+DESCRIPTION="R language extension for postgresql database"
+HOMEPAGE="http://www.joeconway.com/plr/"
+SRC_URI="https://github.com/postgres-plr/plr/archive/REL${PV//./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-lang/R
+ ${POSTGRES_DEP}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="${POSTGRES_REQ_USE}"
+
+S=${WORKDIR}/contrib/${PN}
+
+src_unpack() {
+ unpack ${A}
+ # the build system wants 'contrib' to be part of the path
+ mkdir -p "${WORKDIR}/contrib"
+ mv "${WORKDIR}/${PN}-REL${PV//./_}" "${S}"
+}
+
+src_prepare() {
+ local BUILD_DIR="${S}"
+ postgres-multi_src_prepare
+}
+
+src_compile() {
+ pg_src_compile() {
+ cd "${BUILD_DIR}"
+ PG_CONFIG="${SYSROOT}${EPREFIX}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
+ USE_PGXS=1 \
+ emake -j1
+ }
+ postgres-multi_foreach pg_src_compile
+}
+
+src_install() {
+ pg_src_install() {
+ cd "${BUILD_DIR}"
+ PG_CONFIG="${SYSROOT}${EPREFIX}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
+ USE_PGXS=1 \
+ emake -j1 DESTDIR="${D}" install
+ }
+ postgres-multi_foreach pg_src_install
+}
+
+pkg_postinst() {
+ elog "The plr extension needs to be explicitly added (or 'created') on each database"
+ elog "you wish to use it with. As of postgresql-9.1 the easiest way to do this is"
+ elog "with the proprietary SQL statement:"
+ elog
+ elog "\tCREATE EXTENSION plr;"
+ elog
+ elog "For more info on how to add PL/R to your postgresql database(s), please visit"
+ elog "http://www.joeconway.com/doc/plr-install.html"
+}