summaryrefslogtreecommitdiff
path: root/dev-db/plr
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/plr')
-rw-r--r--dev-db/plr/Manifest2
-rw-r--r--dev-db/plr/plr-8.4.5.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-db/plr/Manifest b/dev-db/plr/Manifest
index d695f2a4b3f7..f41b1a30fbd0 100644
--- a/dev-db/plr/Manifest
+++ b/dev-db/plr/Manifest
@@ -1,5 +1,7 @@
DIST plr-8.3.0.17.tar.gz 74017 BLAKE2B 314b4cfa2c3ca8ed31e80a72233a6dc8cdb9f3811dad6e9f3eb5147c17cdf5a039436598b0fc2b30c6702b02dd3cb2da33543764aee3199c6864aae22be875ce SHA512 d7080c62349d1dcdd17008a7be3643b54678e0f66bf721068df73057394496d025c4fe01e52945c3acf9cc21eb90241512667772ef3fe519a3c9081efe92dd40
DIST plr-8.4.1.tar.gz 265142 BLAKE2B 859913ba14d3e6876eb5a3d7593346b98ab2e1b6c70d9fd9cc7e1810fe11ecb3c552305485735cf975cc41ce2de6cbd7bcf407c9e373fc4024230be797c9899a SHA512 0db407355271009bad95c21f81e544839322f0fa0a63d2abd8edbf9eab8f61e208a3e4f7083729cc8247411885197ff3569c88264db0a29b34523dc83bbed7ec
+DIST plr-8.4.5.tar.gz 273711 BLAKE2B 666941f1cbc7e74dee532b928102afda4684b344f3c69a6ac4e3449c057e8f4dbb74b765f4222bb06e61940fa1e4ba888cc60bac193ca43989b557da9d02ceaa SHA512 bb04a8956d1cdc7acb20c89ea3b17be6ee385dac52381ab0f8af7446480fa9b8d163ff6697a05b439a75f57841b203e65bea78db8a7c3d55c1118bebbf4ac81a
EBUILD plr-8.3.0.17.ebuild 1695 BLAKE2B 08608beab85ba219a998ae4ce29fad0b69fd076cd4533cf65147f52da2eee7b73cfc8cfb3bbe84940302da826a5c6a71152728aebe54a1a1cf8bd9ca4b22939d SHA512 f46353c5f6089fae5af0de77435dd6c021534b62768f4da05a0e4baaa0ecadb6932428ce7559c1a8ee7a54092d8dbf3f22f439cd8147a90a0476f0c5d4e39cde
EBUILD plr-8.4.1.ebuild 1701 BLAKE2B cf9af2474f8a6b4a264ec730e0420ebb1c31735f87f258f2cdede5349f7acb93bdd2d5d5bd7d3d438cc23f1d0730ed89030657e06da158ca6a41c64048d24859 SHA512 fee93a9954c81eb42760db12f78ff8405ce435dafc946b347e1c0ee2f2002bf9c062a225b02042309182f799d0aa2e9a9fa3e00a923fe1010ee14cfc2bd340f1
+EBUILD plr-8.4.5.ebuild 1709 BLAKE2B 2470f0234a816812e339bdf8f66ac3cc849d6d8c6d0e727d3c3291add98d4d2ebcdc5b178e1cedae75c8b5aa04a8fbd5d7455341e08364508a76d9992d9be6b3 SHA512 a737941c229732843b686cb2a1a8d03e1f35244ef79cb6bcb0d2ad8bb5a0fa55765f42384322a6b456df2cee87cb10819725e0bf0d9132488ce8b51a97a9105a
MISC metadata.xml 399 BLAKE2B 07f2d03ca54183e589cfe1b91cc2e672ea7999cbb978c4879ca7c0327929010cdfadd530105dc7206f5739bd06dd78b28329409768f7a7013e9d6807200e1c76 SHA512 b0ce0c61aa57841cbb7a147f5540d512fef89ea7c871a24d4ecce01eb34c067a31ee344c4ecb2a10679b338da31b750a67dba1547d18fb164e9a15f393dc966f
diff --git a/dev-db/plr/plr-8.4.5.ebuild b/dev-db/plr/plr-8.4.5.ebuild
new file mode 100644
index 000000000000..a75eb62a0b0f
--- /dev/null
+++ b/dev-db/plr/plr-8.4.5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.6 {10..14} )
+POSTGRES_USEDEP="server"
+
+inherit postgres-multi
+
+DESCRIPTION="R language extension for postgresql database"
+HOMEPAGE="http://www.joeconway.com/plr/"
+SRC_URI="https://github.com/postgres-plr/plr/archive/REL${PV//./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-lang/R
+ ${POSTGRES_DEP}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+REQUIRED_USE="${POSTGRES_REQ_USE}"
+
+S="${WORKDIR}"/contrib/${PN}
+
+src_unpack() {
+ unpack ${A}
+
+ # the build system wants 'contrib' to be part of the path
+ mkdir -p "${WORKDIR}/contrib" || die
+ mv "${WORKDIR}/${PN}-REL${PV//./_}" "${S}" || die
+}
+
+src_prepare() {
+ local BUILD_DIR="${S}"
+ postgres-multi_src_prepare
+}
+
+src_compile() {
+ pg_src_compile() {
+ cd "${BUILD_DIR}"
+ PG_CONFIG="${ESYSROOT}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
+ USE_PGXS=1 \
+ emake -j1
+ }
+ postgres-multi_foreach pg_src_compile
+}
+
+src_install() {
+ pg_src_install() {
+ cd "${BUILD_DIR}"
+ PG_CONFIG="${ESYSROOT}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
+ USE_PGXS=1 \
+ emake -j1 DESTDIR="${D}" install
+ }
+ postgres-multi_foreach pg_src_install
+}
+
+pkg_postinst() {
+ elog "The plr extension needs to be explicitly added (or 'created') on each database"
+ elog "you wish to use it with. As of postgresql-9.1 the easiest way to do this is"
+ elog "with the proprietary SQL statement:"
+ elog
+ elog "\tCREATE EXTENSION plr;"
+ elog
+ elog "For more info on how to add PL/R to your postgresql database(s), please visit"
+ elog "http://www.joeconway.com/doc/plr-install.html"
+}