summaryrefslogtreecommitdiff
path: root/dev-db/pgpool2/pgpool2-4.3.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgpool2/pgpool2-4.3.8.ebuild')
-rw-r--r--dev-db/pgpool2/pgpool2-4.3.8.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-db/pgpool2/pgpool2-4.3.8.ebuild b/dev-db/pgpool2/pgpool2-4.3.8.ebuild
index d46c7c75826a..b0b928ab667f 100644
--- a/dev-db/pgpool2/pgpool2-4.3.8.ebuild
+++ b/dev-db/pgpool2/pgpool2-4.3.8.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
POSTGRES_COMPAT=( 9.6 {10..15} )
-inherit autotools postgres-multi
+inherit autotools flag-o-matic postgres-multi
MY_P="${PN/2/-II}-${PV}"
@@ -48,6 +48,12 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/855248
+ # https://github.com/pgpool/pgpool2/issues/42
+ #
+ filter-lto
+
postgres-multi_foreach econf \
--disable-rpath \
--sysconfdir="${EPREFIX}/etc/${PN}" \