summaryrefslogtreecommitdiff
path: root/dev-db/ocp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/ocp')
-rw-r--r--dev-db/ocp/Manifest4
-rw-r--r--dev-db/ocp/metadata.xml16
-rw-r--r--dev-db/ocp/ocp-0.2.ebuild41
-rw-r--r--dev-db/ocp/ocp-9999.ebuild34
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-db/ocp/Manifest b/dev-db/ocp/Manifest
new file mode 100644
index 000000000000..8016219761ab
--- /dev/null
+++ b/dev-db/ocp/Manifest
@@ -0,0 +1,4 @@
+DIST ocp-0.2.tar.gz 144968 BLAKE2B 495b2af182768a0c18b08350fb77b09964be52afd72f3ff610ed6a0a54905b116744c93c6261986ca48a0a0c56fd23fd2d15d1919f4c8a4ff8b55ebe532efa07 SHA512 0ff132a368a615c2a8e8ecb391da138ce9fd52d638de82e5a4d1c9ec3340b117c9c4d8f971ee86724664f93b4073b189407c3c19a0c22c961922145d30221c85
+EBUILD ocp-0.2.ebuild 732 BLAKE2B 4d7301cfb319b4e40650ff6c9995d7f9807bfda90e581699cea845557f56aae666a1aedfea375e2d2e24009028cb11adf59147d419bba2c1e2765b4211cb74b0 SHA512 447f0a33d07797e6dd5fbe5fc7f62ddbe853e4d038f5ba1da148c92311d38ba19289c17166c5f4a9fafacb7e22eb4ecbfafe60dfff18cfbc6ccfae29c73c287a
+EBUILD ocp-9999.ebuild 648 BLAKE2B 8484d73d462b4a676e43902796072e831834dcbbd2eb833197fdde8425d037590ec513d3cce6739451c964b22da47911a36761fa908b47a7859fd11fe98f7773 SHA512 7163ce5d60b0961e517f5cb19c344c35fb052f2a6524522bec6657d1816a8f0ea48eaf085b833e4ced42a5e2f369c0377081bebef73caae5be10d1203d1e6101
+MISC metadata.xml 614 BLAKE2B 218c867c70ad619570c2c9ce97bc8fc5ea1ba9b121db0e05e0fb3046d7b4e7fcd3e467fbeb57d72715604d1c457b4aa44649a78587d29c61b9a63d19775f3b9e SHA512 33281a9bb09cfd13ecae433df9612587d56befe35f81e50d88164b0b4caf997f404c613ae456b497fc934fae9b4837846a18a2cf714c49bbc0b0b6eb920fa77d
diff --git a/dev-db/ocp/metadata.xml b/dev-db/ocp/metadata.xml
new file mode 100644
index 000000000000..1d5044264397
--- /dev/null
+++ b/dev-db/ocp/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>maksym.satula@gmail.com</email>
+ <name>Max Satula</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/maxsatula/ocp/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">A tool for downloading and uploading files from/to Oracle Database directories using Oracle SQL Net connection only</longdescription>
+</pkgmetadata>
diff --git a/dev-db/ocp/ocp-0.2.ebuild b/dev-db/ocp/ocp-0.2.ebuild
new file mode 100644
index 000000000000..3745af1f5a87
--- /dev/null
+++ b/dev-db/ocp/ocp-0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Oracle copy tool"
+HOMEPAGE="https://github.com/maxsatula/ocp"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
+ EGIT_BRANCH="develop"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-db/oracle-instantclient-basic
+ dev-libs/popt
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == *9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ append-ldflags $(no-as-needed)
+ default
+}
diff --git a/dev-db/ocp/ocp-9999.ebuild b/dev-db/ocp/ocp-9999.ebuild
new file mode 100644
index 000000000000..baab9a6071ec
--- /dev/null
+++ b/dev-db/ocp/ocp-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Oracle copy tool"
+HOMEPAGE="https://github.com/maxsatula/ocp"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
+ EGIT_BRANCH="develop"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-db/oracle-instantclient-basic
+ dev-libs/popt
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == *9999 ]] ; then
+ eautoreconf
+ fi
+}