summaryrefslogtreecommitdiff
path: root/dev-db/ocp/ocp-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/ocp/ocp-9999.ebuild')
-rw-r--r--dev-db/ocp/ocp-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-db/ocp/ocp-9999.ebuild b/dev-db/ocp/ocp-9999.ebuild
new file mode 100644
index 000000000000..baab9a6071ec
--- /dev/null
+++ b/dev-db/ocp/ocp-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Oracle copy tool"
+HOMEPAGE="https://github.com/maxsatula/ocp"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
+ EGIT_BRANCH="develop"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-db/oracle-instantclient-basic
+ dev-libs/popt
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == *9999 ]] ; then
+ eautoreconf
+ fi
+}