summaryrefslogtreecommitdiff
path: root/dev-db/mysql/mysql-5.6.38.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mysql/mysql-5.6.38.ebuild')
-rw-r--r--dev-db/mysql/mysql-5.6.38.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-db/mysql/mysql-5.6.38.ebuild b/dev-db/mysql/mysql-5.6.38.ebuild
index 050b1e092c8f..01d0263e17be 100644
--- a/dev-db/mysql/mysql-5.6.38.ebuild
+++ b/dev-db/mysql/mysql-5.6.38.ebuild
@@ -13,12 +13,12 @@ CMAKE_MAKEFILE_GENERATOR=emake
inherit mysql-multilib-r1
# only to make repoman happy. it is really set in the eclass
-IUSE="$IUSE"
+IUSE="$IUSE numa"
# REMEMBER: also update eclass/mysql*.eclass before committing!
KEYWORDS="~alpha amd64 ~arm ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
+DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 ) numa? ( sys-process/numactl )"
RDEPEND="${RDEPEND}"
MY_PATCH_DIR="${WORKDIR}/mysql-extras-${MY_EXTRAS_VER}"
@@ -38,10 +38,6 @@ PATCHES=(
# If you want to add a single patch, copy the ebuild to an overlay
# and create your own mysql-extras tarball, looking at 000_index.txt
-# validate_password plugin uses exceptions when it shouldn't yet (until 5.7)
-# disable until we see what happens with it
-MYSQL_CMAKE_NATIVE_DEFINES=( -DWITHOUT_VALIDATE_PASSWORD=1 )
-
src_prepare() {
mysql-multilib-r1_src_prepare
if use libressl ; then
@@ -50,6 +46,13 @@ src_prepare() {
fi
}
+src_configure() {
+ # validate_password plugin uses exceptions when it shouldn't yet (until 5.7)
+ # disable until we see what happens with it
+ local MYSQL_CMAKE_NATIVE_DEFINES=( -DWITHOUT_VALIDATE_PASSWORD=1 -DWITH_NUMA=$(usex numa ON OFF) )
+ mysql-multilib-r1_src_configure
+}
+
# Official test instructions:
# USE='server embedded extraengine perl openssl static-libs' \
# FEATURES='test userpriv -usersandbox' \