summaryrefslogtreecommitdiff
path: root/dev-db/mariadb-connector-c/mariadb-connector-c-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mariadb-connector-c/mariadb-connector-c-9999.ebuild')
-rw-r--r--dev-db/mariadb-connector-c/mariadb-connector-c-9999.ebuild19
1 files changed, 16 insertions, 3 deletions
diff --git a/dev-db/mariadb-connector-c/mariadb-connector-c-9999.ebuild b/dev-db/mariadb-connector-c/mariadb-connector-c-9999.ebuild
index 62a90589ade5..c7280c550ded 100644
--- a/dev-db/mariadb-connector-c/mariadb-connector-c-9999.ebuild
+++ b/dev-db/mariadb-connector-c/mariadb-connector-c-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,7 +14,7 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86"
fi
-inherit cmake-multilib toolchain-funcs
+inherit cmake-multilib flag-o-matic toolchain-funcs
DESCRIPTION="C client library for MariaDB/MySQL"
HOMEPAGE="https://mariadb.org/"
@@ -47,9 +47,15 @@ MULTILIB_WRAPPED_HEADERS+=( /usr/include/mariadb/mariadb_version.h )
PATCHES=(
"${FILESDIR}"/${PN}-3.1.3-fix-pkconfig-file.patch
+ "${FILESDIR}"/${PN}-3.3.4-remove-zstd.patch
)
src_prepare() {
+ # Should be able to drop this once bug #926121 is fixed and
+ # https://github.com/mariadb-corporation/mariadb-connector-c/commit/395641549ac72bc31def6d8b64e09093336aef72
+ # is in a release.
+ sed -i -e '/SET(WARNING_AS_ERROR "-Werror")/d' CMakeLists.txt || die
+
# These tests the remote_io plugin which requires network access
sed -i 's/{"test_remote1", test_remote1, TEST_CONNECTION_NEW, 0, NULL, NULL},//g' "unittest/libmariadb/misc.c" || die
@@ -64,10 +70,17 @@ src_prepare() {
cmake_src_prepare
}
-multilib_src_configure() {
+src_configure() {
# mariadb cannot use ld.gold, bug #508724
tc-ld-disable-gold
+ # bug #855233 (MDEV-11914, MDEV-25633) at least
+ filter-lto
+
+ cmake-multilib_src_configure
+}
+
+multilib_src_configure() {
local mycmakeargs=(
-DWITH_EXTERNAL_ZLIB=ON
-DWITH_SSL:STRING=$(usex ssl $(usex gnutls GNUTLS OPENSSL) OFF)