summaryrefslogtreecommitdiff
path: root/dev-db/libzdb/libzdb-3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/libzdb/libzdb-3.1.ebuild')
-rw-r--r--dev-db/libzdb/libzdb-3.1.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-db/libzdb/libzdb-3.1.ebuild b/dev-db/libzdb/libzdb-3.1.ebuild
index 21ce5f4ef1c1..caa64e3ef38f 100644
--- a/dev-db/libzdb/libzdb-3.1.ebuild
+++ b/dev-db/libzdb/libzdb-3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -33,11 +33,8 @@ src_configure() {
## TODO: check what --enable-optimized actually does
## TODO: find someone with oracle db to add oci8 support
myconf=""
- if [[ $(gcc-version) < 4.1 ]];then
- myconf="${myconf} --disable-protected"
- else
- myconf="${myconf} --enable-protected"
- fi
+ # enable default hidden visibility
+ myconf="${myconf} --enable-protected"
if use sqlite; then
myconf="${myconf} --with-sqlite=${EPREFIX}/usr/ --enable-sqliteunlock"