summaryrefslogtreecommitdiff
path: root/dev-db/kyotocabinet/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/kyotocabinet/files')
-rw-r--r--dev-db/kyotocabinet/files/fix_configure-1.2.62.patch51
-rw-r--r--dev-db/kyotocabinet/files/kyotocabinet-1.2.76-configure-8-byte-atomics.patch44
-rw-r--r--dev-db/kyotocabinet/files/kyotocabinet-1.2.76-flags.patch31
-rw-r--r--dev-db/kyotocabinet/files/kyotocabinet-1.2.76-gcc6.patch11
4 files changed, 0 insertions, 137 deletions
diff --git a/dev-db/kyotocabinet/files/fix_configure-1.2.62.patch b/dev-db/kyotocabinet/files/fix_configure-1.2.62.patch
deleted file mode 100644
index 622b7fd52792..000000000000
--- a/dev-db/kyotocabinet/files/fix_configure-1.2.62.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff --git a/configure.in b/configure.in
-index 94e9d29..6999615 100644
---- a/configure.in
-+++ b/configure.in
-@@ -35,27 +35,18 @@ MYDOCUMENTFILES="COPYING FOSSEXCEPTION ChangeLog doc kyotocabinet.idl"
- MYPCFILES="kyotocabinet.pc"
-
- # Building flags
--MYCFLAGS="-Wall -ansi -pedantic -fPIC -fsigned-char -g0 -O2"
--MYCXXFLAGS="-Wall -fPIC -fsigned-char -g0 -O2"
--MYCPPFLAGS="-I. -I\$(INCLUDEDIR) -I/usr/local/include"
-+MYCFLAGS="-Wall -ansi -pedantic -fPIC -fsigned-char"
-+MYCXXFLAGS="-Wall -fPIC -fsigned-char"
-+MYCPPFLAGS="-I. -I\$(INCLUDEDIR)"
- MYCPPFLAGS="$MYCPPFLAGS -DNDEBUG -D_GNU_SOURCE=1"
- MYCPPFLAGS="$MYCPPFLAGS -D_FILE_OFFSET_BITS=64 -D_REENTRANT -D__EXTENSIONS__"
--MYLDFLAGS="-L. -L\$(LIBDIR) -L/usr/local/lib"
-+MYLDFLAGS="-L. -L\$(LIBDIR)"
- MYCMDLDFLAGS=""
- MYCMDLIBS=""
- MYLDLIBPATH=""
- MYLDLIBPATHENV="LD_LIBRARY_PATH"
- MYPOSTCMD="true"
-
--# Building paths
--PATH=".:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:$PATH"
--CPATH=".:/usr/local/include:$CPATH"
--LIBRARY_PATH=".:/usr/local/lib:$LIBRARY_PATH"
--LD_LIBRARY_PATH=".:/usr/local/lib:$LD_LIBRARY_PATH"
--PKG_CONFIG_PATH=".:/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"
--export PATH CPATH LIBRARY_PATH LD_LIBRARY_PATH PKG_CONFIG_PATH
--
--
-
- #================================================================
- # Options
-@@ -285,14 +276,6 @@ then
- MYCMDLIBS="$MYCMDLIBS $LIBS"
- fi
-
--# As-needed linking
--if uname | grep Linux >config.tmp
--then
-- MYLDFLAGS="$MYLDFLAGS -Wl,-rpath-link,.:/usr/local/lib:$MYLDLIBPATH"
-- MYLDFLAGS="$MYLDFLAGS -Wl,--as-needed"
--else
-- MYCMDLIBS="$MYCMDLIBS $LIBS"
--fi
-
- # Shared libraries
- if test "$enable_shared" != "no" && test "$enable_profile" != "yes"
diff --git a/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-configure-8-byte-atomics.patch b/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-configure-8-byte-atomics.patch
deleted file mode 100644
index 729efc083ba5..000000000000
--- a/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-configure-8-byte-atomics.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From: Shawn Landden <shawnlandden@gmail.com>
-Date: Thu, 21 Jun 2012 20:34:28 -0700
-Subject: configure: 8 byte atomics
-
-fix up configure test to handle lack of 8 byte atomics correctly
-
-as is the case with all ARM targets currently
----
- configure | 29 +++++++++++++----------------
- configure.in | 19 ++++++++++++++++---
- 2 files changed, 29 insertions(+), 19 deletions(-)
-
-index a07063d..bfc6df0 100755
---- a/configure.in
-+++ b/configure.in
-@@ -238,9 +238,22 @@ fi
- # Atomic operations
- if test "$enable_atomic" != "no"
- then
-- printf 'checking for atomic operations... '
-- AC_TRY_COMPILE([], [__sync_fetch_and_add], [MYGCCATOMIC=yes], [MYGCCATOMIC=no])
-- if test "$MYGCCATOMIC" = "yes"
-+ printf 'checking for 8 byte atomic operations... '
-+ if printf '
-+/* Some targets support 4 byte atomics, but not 8 byte atomics,
-+ * and will fail at link time if they are used.
-+ *
-+ * http://gcc.gnu.org/onlinedocs/gcc-4.6.3/gcc/Atomic-Builtins.html
-+ * http://gcc.gnu.org/wiki/Atomic
-+ */
-+#include <stdint.h>
-+int
-+main ()
-+{
-+uint64_t n = 0xdeadbeaf;
-+__sync_bool_compare_and_swap(&n, 0xdeadbeaf, 0);
-+return n;
-+}' | $CC -xc -o config.tmp - >/dev/null 2>&1
- then
- MYCPPFLAGS="$MYCPPFLAGS -D_MYGCCATOMIC"
- printf 'yes\n'
---
-1.7.9.5
-
diff --git a/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-flags.patch b/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-flags.patch
deleted file mode 100644
index 931e8c3f7bbe..000000000000
--- a/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-flags.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/configure.in
-+++ b/configure.in
-@@ -193,28 +193,6 @@
- # Byte order
- AC_C_BIGENDIAN(MYCPPFLAGS="$MYCPPFLAGS -D_MYBIGEND")
-
--# System-depending optimization
--printf 'checking for 64-bit availability... '
--if printf 'main() {}' | $CC -xc -m64 -o config.tmp - >config.tmp 2>&1
--then
-- MYCFLAGS="-m64 $MYCFLAGS"
-- MYCXXFLAGS="-m64 $MYCXXFLAGS"
-- printf 'yes\n'
--else
-- printf 'no\n'
--fi
--if test "$enable_opt" != "no"
--then
-- printf 'checking for CPU optimization availability... '
-- if printf 'main() {}' | $CC -xc -march=native -o config.tmp - >config.tmp 2>&1
-- then
-- MYCFLAGS="-march=native $MYCFLAGS"
-- MYCXXFLAGS="-march=native $MYCXXFLAGS"
-- printf 'yes\n'
-- else
-- printf 'no\n'
-- fi
--fi
- printf 'checking for useless warnings... '
- if printf 'main() {}' | $CC -xc \
- -Wno-unused-but-set-variable -Wno-unused-but-set-parameter -o config.tmp - >config.tmp 2>&1
diff --git a/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-gcc6.patch b/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-gcc6.patch
deleted file mode 100644
index 3bcc6a28e795..000000000000
--- a/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-gcc6.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/kcdbext.h
-+++ b/kcdbext.h
-@@ -1278,7 +1278,7 @@
- if (omode_ == 0) {
- set_error(_KCCODELINE_, BasicDB::Error::INVALID, "not opened");
- *sp = 0;
-- return false;
-+ return NULL;
- }
- if (!cache_) return db_.get(kbuf, ksiz, sp);
- size_t dvsiz = 0;