summaryrefslogtreecommitdiff
path: root/dev-cpp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/Manifest.gzbin9200 -> 9362 bytes
-rw-r--r--dev-cpp/cpp-taskflow/Manifest5
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0-r1.ebuild33
-rw-r--r--dev-cpp/cpp-taskflow/files/cpp-taskflow-2.4.0-do_not_compile_examples.patch82
-rw-r--r--dev-cpp/cpp-taskflow/files/cpp-taskflow-2.4.0-fix_installation_path.patch22
-rw-r--r--dev-cpp/cpp-taskflow/metadata.xml20
-rw-r--r--dev-cpp/nlohmann_json/Manifest3
-rw-r--r--dev-cpp/nlohmann_json/files/nlohmann_json-3.7.3-gcc-10.patch131
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.7.3.ebuild4
-rw-r--r--dev-cpp/tbb/Manifest2
-rw-r--r--dev-cpp/tbb/files/tbb-2017.20161128-build.patch187
-rw-r--r--dev-cpp/tbb/files/tbb-4.4.20160803-underlinking.patch15
-rw-r--r--dev-cpp/websocketpp/Manifest2
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild2
-rw-r--r--dev-cpp/yaml-cpp/Manifest2
-rw-r--r--dev-cpp/yaml-cpp/yaml-cpp-0.6.3-r2.ebuild2
16 files changed, 303 insertions, 209 deletions
diff --git a/dev-cpp/Manifest.gz b/dev-cpp/Manifest.gz
index 303c0745ba9d..31344fa6bee4 100644
--- a/dev-cpp/Manifest.gz
+++ b/dev-cpp/Manifest.gz
Binary files differ
diff --git a/dev-cpp/cpp-taskflow/Manifest b/dev-cpp/cpp-taskflow/Manifest
new file mode 100644
index 000000000000..ccbb8c11d2ef
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/Manifest
@@ -0,0 +1,5 @@
+AUX cpp-taskflow-2.4.0-do_not_compile_examples.patch 2634 BLAKE2B 6b326b97e721061892abe0e01bcfb49dffea91b641684b1c860c8f8384153103107d9ab26dfaa4b577897e49f45fa2a6cfaaf5cf49409afa429b5dd0c7aefda9 SHA512 21b61ba80536cf8baa24c67e35902b66fb98408f86be8a4611b15304525c2e14a20af80507ccdd4d6a365303abdc38d1d199f1888baa0a35a04483a837ddadd5
+AUX cpp-taskflow-2.4.0-fix_installation_path.patch 739 BLAKE2B 6cf25c76b91d3e60c7a9f35bcf0d5a89f28dd42efb32c3fa57eefd9b716e9905d20cd8becc0a47cf74f992bf2e77b6051034f62533dbfdab4b57a70a4b24eecf SHA512 36e2284da55eba9ca24a34e8baa105a28e411d54927378f6978c96c19af08a760fc4f3caff6ec4f325d63ca8974e7b66e27e3c69ba39e22f6b8e67d3ae303b24
+DIST cpp-taskflow-2.4.0.tar.gz 76993334 BLAKE2B 8f257165ab72dbe6c1cf6a86886669008e9f16f1dfd4871defc452bdb9dfa3e45ab9bfbbdc874b4ba566a2a7d8984a666ce2933b2c6d2215467f7fbfa03ac520 SHA512 dd6c7500e39d7058871280d12e120bd28d9609e5289f1d7851b3b59e2c1bfe74d3040d902bd5b26895e558b563c8abad878e7bc343e199e7356940c02a64217f
+EBUILD cpp-taskflow-2.4.0-r1.ebuild 603 BLAKE2B 0620b659d11e94d1fde1e6f53767a98aded76fc8f7b2af238e0ff4a900484dbae00a288e12bce48a4c3adde8ced548dcef577528473328408e93219b1e49ebb3 SHA512 fd5822c2ff54904142ebf6fc5c36f263ce16178d6b161aa412dad4cb378f9e9449943e2a836cc815c9e3d6ef4f4f32bed6ef86ae0f712689cc81bb2cc4b9887f
+MISC metadata.xml 662 BLAKE2B 9a3c9f4208ed92f0957323e281cedd321b9e15c15af231eeca1b88b8e0d87df81a546afd8877f496151c0815cb566d9e205fe1eb8b8fce33114435e2c66f75ab SHA512 9b0b6de9d422df44507429af356aa0d31411a564efe4a58065cdff38845f1e1e53fef6aef8a8537ccfff8ee36e3e77beff65aca3bda4efb2a5f3166c41ea68d2
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0-r1.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..b3df053c1da1
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Modern C++ Parallel Task Programming"
+HOMEPAGE="https://cpp-taskflow.github.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-do_not_compile_examples.patch
+ "${FILESDIR}"/${P}-fix_installation_path.patch
+)
+
+HTML_DOCS=( docs/. )
+
+src_install() {
+ cmake-utils_src_install
+
+ if $(use doc); then
+ einstalldocs
+ fi
+}
diff --git a/dev-cpp/cpp-taskflow/files/cpp-taskflow-2.4.0-do_not_compile_examples.patch b/dev-cpp/cpp-taskflow/files/cpp-taskflow-2.4.0-do_not_compile_examples.patch
new file mode 100644
index 000000000000..99f4658adfe4
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/files/cpp-taskflow-2.4.0-do_not_compile_examples.patch
@@ -0,0 +1,82 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1bf8ed3..190dabe 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -223,76 +223,10 @@ target_include_directories(${PROJECT_NAME} INTERFACE
+ $<INSTALL_INTERFACE:include/>
+ )
+
+-# -----------------------------------------------------------------------------
+-# Example program
+-# -----------------------------------------------------------------------------
+-
+-message(STATUS "Building examples ...")
+-set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${TF_EXAMPLE_DIR})
+-
+-add_executable(simple ${TF_EXAMPLE_DIR}/simple.cpp)
+-target_link_libraries(
+- simple ${PROJECT_NAME} Threads::Threads tf::default_settings
+-)
+-
+-add_executable(observer ${TF_EXAMPLE_DIR}/observer.cpp)
+-target_link_libraries(
+- observer ${PROJECT_NAME} Threads::Threads tf::default_settings
+-)
+-
+-add_executable(subflow ${TF_EXAMPLE_DIR}/subflow.cpp)
+-target_link_libraries(
+- subflow ${PROJECT_NAME} Threads::Threads tf::default_settings
+-)
+-
+-add_executable(condition ${TF_EXAMPLE_DIR}/condition.cpp)
+-target_link_libraries(
+- condition ${PROJECT_NAME} Threads::Threads tf::default_settings
+-)
+-
+-add_executable(visualization ${TF_EXAMPLE_DIR}/visualization.cpp)
+-target_link_libraries(
+- visualization ${PROJECT_NAME} Threads::Threads tf::default_settings
+-)
+-
+-add_executable(reduce ${TF_EXAMPLE_DIR}/reduce.cpp)
+-target_link_libraries(
+- reduce ${PROJECT_NAME} Threads::Threads tf::default_settings
+-)
+-
+-add_executable(parallel_for ${TF_EXAMPLE_DIR}/parallel_for.cpp)
+-target_link_libraries(
+- parallel_for ${PROJECT_NAME} Threads::Threads tf::default_settings
+-)
+-
+-add_executable(run ${TF_EXAMPLE_DIR}/run.cpp)
+-target_link_libraries(
+- run ${PROJECT_NAME} Threads::Threads tf::default_settings
+-)
+-
+-add_executable(composition ${TF_EXAMPLE_DIR}/composition.cpp)
+-target_link_libraries(
+- composition ${PROJECT_NAME} Threads::Threads tf::default_settings
+-)
+-
+-#### CUDA examples
+-if(${TF_ENABLE_CUDA})
+-set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${TF_EXAMPLE_DIR}/cuda)
+-
+-add_executable(saxpy ${TF_EXAMPLE_DIR}/cuda/saxpy.cu)
+-target_link_libraries(
+- saxpy ${PROJECT_NAME} Threads::Threads tf::default_settings
+-)
+-
+-add_executable(device_property ${TF_EXAMPLE_DIR}/cuda/device_property.cu)
+-target_link_libraries(
+- device_property ${PROJECT_NAME} Threads::Threads tf::default_settings
+-)
+-endif(${TF_ENABLE_CUDA})
+-
+ # -----------------------------------------------------------------------------
+ # Unittest
+ # -----------------------------------------------------------------------------
++
+ enable_testing()
+ message(STATUS "Building unit tests ...")
+ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${TF_UTEST_DIR})
diff --git a/dev-cpp/cpp-taskflow/files/cpp-taskflow-2.4.0-fix_installation_path.patch b/dev-cpp/cpp-taskflow/files/cpp-taskflow-2.4.0-fix_installation_path.patch
new file mode 100644
index 000000000000..f68e572f5ab2
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/files/cpp-taskflow-2.4.0-fix_installation_path.patch
@@ -0,0 +1,22 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 190dabe..6d613d6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,7 +6,7 @@ MESSAGE(STATUS "CMAKE_ROOT: " ${CMAKE_ROOT})
+ #_cmake_modify_IGNORE set(CMAKE_VERBOSE_MAKEFILE ON)
+
+ # Project name
+-project(Cpp-Taskflow VERSION 2.3.1 LANGUAGES CXX)
++project(Cpp-Taskflow VERSION 2.4.0 LANGUAGES CXX)
+
+ # build options
+ option(TF_ENABLE_CUDA "Enables build of cuda code" OFF)
+@@ -748,7 +748,7 @@ write_basic_package_version_file(
+ install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}Config.cmake
+ ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}ConfigVersion.cmake
+- DESTINATION ${TF_LIB_INSTALL_DIR}/cmake
++ DESTINATION ${TF_LIB_INSTALL_DIR}/cmake/${PROJECT_NAME}
+ )
+
+
diff --git a/dev-cpp/cpp-taskflow/metadata.xml b/dev-cpp/cpp-taskflow/metadata.xml
new file mode 100644
index 000000000000..8406ef2081f1
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ Cpp-Taskflow is faster, more expressive, and easier for drop-in
+ integration than many of existing task programming frameworks in
+ handling complex parallel workloads.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">cpp-taskflow/cpp-taskflow</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
index 852e42f03c14..b1229213899e 100644
--- a/dev-cpp/nlohmann_json/Manifest
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -1,7 +1,8 @@
+AUX nlohmann_json-3.7.3-gcc-10.patch 4668 BLAKE2B 6c70c34ce5df904ed641d021c8584cf69115f7b9434d5c43c283425e7eabbe40a21f06130b36ac1681302c9498ee0570ce396f82cb9258d5bef36ed7362f526f SHA512 ece8cea0e2aa217df1915df1de138db03320b15220d725bce4cf77282b5aa71952472594066c921efd6aa8a51ad0e2b1b22e83cfa89563f211d1225190a267af
DIST nlohmann_json-3.6.1.tar.gz 118862808 BLAKE2B 257508b33480741bd4438fe928869c0744a5e84806fa4e068b048bfc0e665802a45f31bc740c14f74e7a0384df18b9bba58a0e001750b1a800ea00cd1712b280 SHA512 e0565ccdee34e89a6836a97f039c04a0bac445b44f6f323918ea424b34e4577688a4f4f72d5ef1ec0b53d159bfe87e8e9c97b70ef98231ea463f59f05e16eb2a
DIST nlohmann_json-3.7.0.tar.gz 118868542 BLAKE2B 25191628b737ea5614de85d0fcb4425fcb2d37e6890626e6ba22949430a1c5f827ff17d1cd8245c8e98d0deda617d8268c55caff3017a6b4a2f730e524599311 SHA512 35510a0ee59d847ff9fcd4f4026ef936abb89675884fdd2db808f8349a55073206f764cd4f797deb1b6493ea0e04889505f49483e5b88798011dd5db87e7c87d
DIST nlohmann_json-3.7.3.tar.gz 119013476 BLAKE2B c10648cacdaf6f82aa2b1db49a412165eb9f3d00fd2b2232531077209c2add27dfebfb9dcd62e6923769411a471778a18a347b524e2ed3cf6f008883333ab8cd SHA512 c416b1e14f1fd695fc30a56127ca6440de4b334858ced54a6424d9d093e4665e74b7048f9ab7253ac02ac870e64a2868c78e6c2d6de80d1bd49e50a850cec865
EBUILD nlohmann_json-3.6.1-r1.ebuild 798 BLAKE2B 65d37e21588513c043122349c2e89450565b16c534d58849c8af36a9f14695296c624664db03585f0dfa5e8ec935dabf765290155a38714a28fc749bf66c02ea SHA512 b693e518ec9a21edbba894628d31db72463f0c54a4ae7aee190c680abec3b5197937367f44d6aaf5673a31e7a86114760ae3016a9acbec4463038dd8abbbf4c7
EBUILD nlohmann_json-3.7.0.ebuild 802 BLAKE2B a224e06c3ef1199734674a2f693c448a1c621a2426887912510d5a09fdca0e9a108adf982bf074306098b428e5eef0d4b2ac02697038bdf41ab4c0dc38e39e82 SHA512 8499faa38a4de2f8733bfaeb2484cf7a125819db48836df2a72cefc7c107d88db5574f8096243d91f4c3e4b97a5f56e53c4fe98bb471636ff3f50d6bb107215b
-EBUILD nlohmann_json-3.7.3.ebuild 802 BLAKE2B 65b708379f74507c31d064f1763d9e9f8a9c4d9d8cd0918b34659218da78803882bb83cafc005dec0654af3213a5e97ad12aefab29bf946d495616d5c98c05d5 SHA512 632c2e8a74ce19bfd7836f2e942a24b91fb44942eac3cdf2fba8a49cf816e3b5e07a2e25bc02679faa0f6d2d7679256264b3b50dc5cffa4087d30a3a0735817b
+EBUILD nlohmann_json-3.7.3.ebuild 855 BLAKE2B 6342aa0db8f63ed9dde230ef134abc88a1259a4aba2ed1ee666d81cc394b832f79bb5877f1233feddbccafeb121bda27643cda58fbb65f6ed9bbdf5fdc805695 SHA512 ecef01faf88748f0b8629a2d2f9e3580c18eb0ce9ef9ce11632f7852435e0c313596d014d9e91dae090956a07bca0a996cfeaf8533051a2a5eb89acdf767d2ae
MISC metadata.xml 337 BLAKE2B a929f6f116c9b0bdf3415325cc710b4b2afa1bb2b6a74c8df9531ad0358d8141054cee8be2be7b380574a8c59359f1c9e9bd8b7fcb607b8da251b787d75dcf43 SHA512 d6ae8564e57c1062487634fb7d4e2c0fa4c79a38d89c06c3514d3459cfd08500634a5fc8add1e126f3181b711dae74931c906b67f6aac51d6400cd2800f293df
diff --git a/dev-cpp/nlohmann_json/files/nlohmann_json-3.7.3-gcc-10.patch b/dev-cpp/nlohmann_json/files/nlohmann_json-3.7.3-gcc-10.patch
new file mode 100644
index 000000000000..1cdb6d594eca
--- /dev/null
+++ b/dev-cpp/nlohmann_json/files/nlohmann_json-3.7.3-gcc-10.patch
@@ -0,0 +1,131 @@
+From ec955f08b47ab7cb81f6e4a4c3e7b331ddf50f71 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Art=C3=B6m=20Bakri=20Al-Sarmini?= <3sz3tt+git@gmail.com>
+Date: Sun, 12 Apr 2020 22:32:39 +0300
+Subject: [PATCH 1/2] Templatize basic_json ctor from json_ref
+
+---
+ include/nlohmann/detail/meta/type_traits.hpp | 13 ++++++++++++
+ include/nlohmann/json.hpp | 8 ++++----
+ single_include/nlohmann/json.hpp | 21 ++++++++++++++++----
+ 3 files changed, 34 insertions(+), 8 deletions(-)
+
+diff --git a/include/nlohmann/detail/meta/type_traits.hpp b/include/nlohmann/detail/meta/type_traits.hpp
+index 280f69534..dd0b3084f 100644
+--- a/include/nlohmann/detail/meta/type_traits.hpp
++++ b/include/nlohmann/detail/meta/type_traits.hpp
+@@ -41,6 +41,19 @@ template<typename> struct is_basic_json : std::false_type {};
+ NLOHMANN_BASIC_JSON_TPL_DECLARATION
+ struct is_basic_json<NLOHMANN_BASIC_JSON_TPL> : std::true_type {};
+
++//////////////////////
++// jspn_ref helpers //
++//////////////////////
++
++template <typename>
++class json_ref;
++
++template<typename>
++struct is_json_ref : std::false_type {};
++
++template <typename T>
++struct is_json_ref<json_ref<T>> : std::true_type {};
++
+ //////////////////////////
+ // aliases for detected //
+ //////////////////////////
+diff --git a/include/nlohmann/json.hpp b/include/nlohmann/json.hpp
+index 336d69fe7..0598efc8c 100644
+--- a/include/nlohmann/json.hpp
++++ b/include/nlohmann/json.hpp
+@@ -1773,10 +1773,10 @@ class basic_json
+ // other constructors and destructor //
+ ///////////////////////////////////////
+
+- /// @private
+- basic_json(const detail::json_ref<basic_json>& ref)
+- : basic_json(ref.moved_or_copied())
+- {}
++ template <typename JsonRef,
++ detail::enable_if_t<detail::conjunction<detail::is_json_ref<JsonRef>,
++ std::is_same<typename JsonRef::value_type, basic_json>>::value, int> = 0 >
++ basic_json(const JsonRef& ref) : basic_json(ref.moved_or_copied()) {}
+
+ /*!
+ @brief copy constructor
+diff --git a/single_include/nlohmann/json.hpp b/single_include/nlohmann/json.hpp
+index 09464f3b2..8927180e6 100644
+--- a/single_include/nlohmann/json.hpp
++++ b/single_include/nlohmann/json.hpp
+@@ -2794,6 +2794,19 @@ template<typename> struct is_basic_json : std::false_type {};
+ NLOHMANN_BASIC_JSON_TPL_DECLARATION
+ struct is_basic_json<NLOHMANN_BASIC_JSON_TPL> : std::true_type {};
+
++//////////////////////
++// jspn_ref helpers //
++//////////////////////
++
++template <typename>
++class json_ref;
++
++template<typename>
++struct is_json_ref : std::false_type {};
++
++template <typename T>
++struct is_json_ref<json_ref<T>> : std::true_type {};
++
+ //////////////////////////
+ // aliases for detected //
+ //////////////////////////
+@@ -16632,10 +16645,10 @@ class basic_json
+ // other constructors and destructor //
+ ///////////////////////////////////////
+
+- /// @private
+- basic_json(const detail::json_ref<basic_json>& ref)
+- : basic_json(ref.moved_or_copied())
+- {}
++ template <typename JsonRef,
++ detail::enable_if_t<detail::conjunction<detail::is_json_ref<JsonRef>,
++ std::is_same<typename JsonRef::value_type, basic_json>>::value, int> = 0 >
++ basic_json(const JsonRef& ref) : basic_json(ref.moved_or_copied()) {}
+
+ /*!
+ @brief copy constructor
+
+From 70be9751cd60e622ce6463f41d47c02fc2d83cbc Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Art=C3=B6m=20Bakri=20Al-Sarmini?= <3sz3tt+git@gmail.com>
+Date: Sun, 12 Apr 2020 23:42:26 +0300
+Subject: [PATCH 2/2] typo fix
+
+---
+ include/nlohmann/detail/meta/type_traits.hpp | 2 +-
+ single_include/nlohmann/json.hpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/include/nlohmann/detail/meta/type_traits.hpp b/include/nlohmann/detail/meta/type_traits.hpp
+index dd0b3084f..13e92cb48 100644
+--- a/include/nlohmann/detail/meta/type_traits.hpp
++++ b/include/nlohmann/detail/meta/type_traits.hpp
+@@ -42,7 +42,7 @@ NLOHMANN_BASIC_JSON_TPL_DECLARATION
+ struct is_basic_json<NLOHMANN_BASIC_JSON_TPL> : std::true_type {};
+
+ //////////////////////
+-// jspn_ref helpers //
++// json_ref helpers //
+ //////////////////////
+
+ template <typename>
+diff --git a/single_include/nlohmann/json.hpp b/single_include/nlohmann/json.hpp
+index 8927180e6..294e7509b 100644
+--- a/single_include/nlohmann/json.hpp
++++ b/single_include/nlohmann/json.hpp
+@@ -2795,7 +2795,7 @@ NLOHMANN_BASIC_JSON_TPL_DECLARATION
+ struct is_basic_json<NLOHMANN_BASIC_JSON_TPL> : std::true_type {};
+
+ //////////////////////
+-// jspn_ref helpers //
++// json_ref helpers //
+ //////////////////////
+
+ template <typename>
+
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.7.3.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.7.3.ebuild
index 7a43019627da..c99fd51237eb 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.7.3.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.7.3.ebuild
@@ -21,6 +21,10 @@ DOCS=( ChangeLog.md README.md )
S=${WORKDIR}/json-${PV}
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.7.3-gcc-10.patch
+)
+
src_configure() {
local mycmakeargs=(
-DJSON_BuildTests=$(usex test)
diff --git a/dev-cpp/tbb/Manifest b/dev-cpp/tbb/Manifest
index 4949f9ce165d..8241c7660742 100644
--- a/dev-cpp/tbb/Manifest
+++ b/dev-cpp/tbb/Manifest
@@ -1,6 +1,4 @@
-AUX tbb-2017.20161128-build.patch 4840 BLAKE2B eec4a437f0a609c8f39b76950aae76c9e357cd0705ad521a3304aceb8361c10cdf0d28078370c840ad315cbe06f3b134ca5d58036b2718a136f3958c3942e9c1 SHA512 40ca5bdfe05eecbc47a9af062e6ede3e14200048cdebd796af71cd5f27b350c65e5aa569cc8a6e2f3cfbd90fec167d4f053abc36310b07113910ba25061c56a4
AUX tbb-2020.1-makefile-debug.patch 2640 BLAKE2B 98e1d88f279452898be78fb53235427a5c45a0056429e07acd5bc273a48c7214dc8df29c72cba344688f650fce25bba06f6f9e4dfbf1091260544e95159cf33d SHA512 9a29ff67321b75efe10621bfe924e89a5c51d4e7327e20aa69018aaea590189ed297b9ab94bd3b48172d0b093e3d2aaebfc7088b480364f6f6c7802a27d3c1e4
-AUX tbb-4.4.20160803-underlinking.patch 389 BLAKE2B 88b85cf0a2c8706dff908d4c4e73e1399aa8ac85f7c2df1bd5daebc564e4007c4bf0df27647e53764c6dd437422ed48885e798a6e4fc6b5900810c7855c9ceeb SHA512 bfd3b9d5221a89a120e115447a9aa653e93a208422c68c8cc74a672f42037fd1af3dc755480d746570f2c5dbeb173650d9b4acfb38aaec5d3c3feea6c2232af1
DIST tbb-2019.8.tar.gz 2580540 BLAKE2B 1cddb0c8ade6f6363811b7f9b323a2bb7739a18114acd56e1b4a13f33904ddff8cb6aec9b4b0add995cd307ff7815f0b55ce33fa64b7dd92c0062fbaa13d0833 SHA512 924a8dde011452a2c46c5152942a9835e76fe5610e08b69eb0e985de3fb46bdb49f0f628d10fa7704428f6e61ec63f7002da5399d47da6ee6004fa236d346dc8
DIST tbb-2020.2.tar.gz 2637172 BLAKE2B 6b6e65732d3971f7374058513004ca3cfc3855b83c0a2dde59d50e08c26ff220470e31db86f4ab9f009c7e02e454a00a348730e63c829aa8d217320f7879cfc9 SHA512 6d7412fa6ce12d27736af3c8942c5ab5ea6945dd3ca93f309535c0dba3ff757d6507a5ffc3bcd73e6fdcda043cdedfa657631b25ae86fbf221d0f1d66a85b48f
EBUILD tbb-2019.8.ebuild 3219 BLAKE2B da178b7f1be91e0cea538891f93d40842fa7fb72ee81b60fccc46d46c8f0ce8c36aa0a46910013bb78311ce05452d5d8594067f4526a74126341bae446ccd76a SHA512 00281dde79efa4e06a6b98eeb206d823e06a8b846808a58d43f324bb2053e2ac4f20a7b8a0b9d85416877a58efb03410855e10af073675ee85d0313bf87b42fb
diff --git a/dev-cpp/tbb/files/tbb-2017.20161128-build.patch b/dev-cpp/tbb/files/tbb-2017.20161128-build.patch
deleted file mode 100644
index e952bfbc434e..000000000000
--- a/dev-cpp/tbb/files/tbb-2017.20161128-build.patch
+++ /dev/null
@@ -1,187 +0,0 @@
---- a/build/FreeBSD.gcc.inc
-+++ b/build/FreeBSD.gcc.inc
-@@ -28,8 +28,8 @@ WARNING_KEY = -Wall
- DYLIB_KEY = -shared
- WARNING_SUPPRESS = -Wno-parentheses
-
--CPLUS = g++
--CONLY = gcc
-+CPLUS = $(CXX)
-+CONLY = $(CC)
- LIB_LINK_FLAGS = -shared
- LIBS = -lpthread
- C_FLAGS = $(CPLUS_FLAGS)
-@@ -42,7 +42,7 @@ ifneq (,$(shell gcc -dumpversion | egrep "^([6-9])"))
- endif
-
- ifeq ($(cfg), release)
-- CPLUS_FLAGS = -g -O2 -DUSE_PTHREAD
-+ CPLUS_FLAGS = -g -DUSE_PTHREAD
- endif
- ifeq ($(cfg), debug)
- CPLUS_FLAGS = -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD
-@@ -59,22 +59,12 @@ ifeq (ia64,$(arch))
- CPLUS_FLAGS += $(PIC_KEY)
- endif
-
--ifeq (intel64,$(arch))
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
--endif
--
--ifeq (ia32,$(arch))
-- CPLUS_FLAGS += -m32
-- LIB_LINK_FLAGS += -m32
--endif
--
- #------------------------------------------------------------------------------
- # Setting assembler data.
- #------------------------------------------------------------------------------
- ASSEMBLY_SOURCE=$(arch)-gas
- ifeq (ia64,$(arch))
-- ASM=as
-+ ASM=$(AS)
- TBB_ASM.OBJ = atomic_support.o lock_byte.o log2.o pause.o
- MALLOC_ASM.OBJ = atomic_support.o lock_byte.o pause.o
- endif
---- a/build/linux.clang.inc
-+++ b/build/linux.clang.inc
-@@ -31,15 +31,15 @@ DYLIB_KEY = -shared
- EXPORT_KEY = -Wl,--version-script,
- LIBDL = -ldl
-
--CPLUS = clang++
--CONLY = clang
-+CPLUS := $(CXX)
-+CONLY := $(CC)
- LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY)
- LIBS += -lpthread -lrt
- LINK_FLAGS = -Wl,-rpath-link=. -rdynamic
- C_FLAGS = $(CPLUS_FLAGS)
-
- ifeq ($(cfg), release)
-- CPLUS_FLAGS = $(ITT_NOTIFY) -g -O2 -DUSE_PTHREAD
-+ CPLUS_FLAGS = $(ITT_NOTIFY) -g -DUSE_PTHREAD
- endif
- ifeq ($(cfg), debug)
- CPLUS_FLAGS = -DTBB_USE_DEBUG $(ITT_NOTIFY) -g -O0 -DUSE_PTHREAD
-@@ -60,24 +60,10 @@ MALLOC_ASM.OBJ=
-
- ifeq (intel64,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
- endif
-
- ifeq (ia32,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m32 -march=pentium4
-- LIB_LINK_FLAGS += -m32
--endif
--
--ifeq (ppc64,$(arch))
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
--endif
--
--ifeq (ppc32,$(arch))
-- CPLUS_FLAGS += -m32
-- LIB_LINK_FLAGS += -m32
- endif
-
- ifeq (bg,$(arch))
-@@ -89,12 +75,6 @@ endif
- # Setting assembler data.
- #------------------------------------------------------------------------------
- ASM = as
--ifeq (intel64,$(arch))
-- ASM_FLAGS += --64
--endif
--ifeq (ia32,$(arch))
-- ASM_FLAGS += --32
--endif
- ifeq ($(cfg),debug)
- ASM_FLAGS += -g
- endif
---- a/build/linux.gcc.inc
-+++ b/build/linux.gcc.inc
-@@ -32,12 +32,12 @@ DYLIB_KEY = -shared
- EXPORT_KEY = -Wl,--version-script,
- LIBDL = -ldl
-
--CPLUS = g++
--CONLY = gcc
-+CPLUS := $(CXX)
-+CONLY := $(CC)
- LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY)
- LIBS += -lpthread -lrt
- LINK_FLAGS = -Wl,-rpath-link=. -rdynamic
--C_FLAGS = $(CPLUS_FLAGS)
-+C_FLAGS := $(CPLUS_FLAGS)
-
- # gcc 4.2 and higher support OpenMP
- ifneq (,$(shell gcc -dumpversion | egrep "^(4\.[2-9]|[5-9])"))
-@@ -68,7 +68,7 @@ ifneq (,$(shell gcc -dumpversion | egrep "^([6-9])"))
- endif
-
- ifeq ($(cfg), release)
-- CPLUS_FLAGS = $(ITT_NOTIFY) -g -O2 -DUSE_PTHREAD
-+ CPLUS_FLAGS = $(ITT_NOTIFY) -g -DUSE_PTHREAD
- endif
- ifeq ($(cfg), debug)
- CPLUS_FLAGS = -DTBB_USE_DEBUG $(ITT_NOTIFY) -g -O0 -DUSE_PTHREAD
-@@ -84,24 +84,12 @@ endif
-
- ifeq (intel64,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m64 $(RTM_KEY)
-- LIB_LINK_FLAGS += -m64
-+ CPLUS_FLAGS += $(RTM_KEY)
- endif
-
- ifeq (ia32,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m32 -march=pentium4 $(RTM_KEY)
-- LIB_LINK_FLAGS += -m32
--endif
--
--ifeq (ppc64,$(arch))
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
--endif
--
--ifeq (ppc32,$(arch))
-- CPLUS_FLAGS += -m32
-- LIB_LINK_FLAGS += -m32
-+ CPLUS_FLAGS += $(RTM_KEY)
- endif
-
- ifeq (bg,$(arch))
-@@ -109,12 +97,6 @@ ifeq (bg,$(arch))
- CONLY = $(firstword $(notdir $(shell which powerpc{64,32,}-bg{z..a}-linux-gcc 2>/dev/null)))
- endif
-
--# for some gcc versions on Solaris, -m64 may imply V9, but perhaps not everywhere (TODO: verify)
--ifeq (sparc,$(arch))
-- CPLUS_FLAGS += -mcpu=v9 -m64
-- LIB_LINK_FLAGS += -mcpu=v9 -m64
--endif
--
- # automatically generate "IT" instructions when compiling for Thumb ISA
- ifeq (armv7,$(arch))
- CPLUS_FLAGS += -Wa,-mimplicit-it=thumb
-@@ -123,13 +105,7 @@ endif
- #------------------------------------------------------------------------------
- # Setting assembler data.
- #------------------------------------------------------------------------------
--ASM = as
--ifeq (intel64,$(arch))
-- ASM_FLAGS += --64
--endif
--ifeq (ia32,$(arch))
-- ASM_FLAGS += --32
--endif
-+ASM := $(AS)
- ifeq ($(cfg),debug)
- ASM_FLAGS += -g
- endif
diff --git a/dev-cpp/tbb/files/tbb-4.4.20160803-underlinking.patch b/dev-cpp/tbb/files/tbb-4.4.20160803-underlinking.patch
deleted file mode 100644
index 5935017a325e..000000000000
--- a/dev-cpp/tbb/files/tbb-4.4.20160803-underlinking.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=418447
-
---- a/build/Makefile.test
-+++ b/build/Makefile.test
-@@ -44,8 +44,8 @@
- USE_PROXY_FLAG = $(DEFINE_KEY)HARNESS_USE_PROXY
- CPLUS_FLAGS += $(USE_PROXY_FLAG)
- LINK_TBB.LIB = $(PROXY.LIB)
-- LIBS += $(LIBDL)
--endif
-+endif
-+LIBS += $(LIBDL)
-
- TEST_SUFFIXES=secondary compiler_builtins pic
- include $(tbb_root)/build/common_rules.inc
diff --git a/dev-cpp/websocketpp/Manifest b/dev-cpp/websocketpp/Manifest
index 95c68a15d3ad..2aad5b407296 100644
--- a/dev-cpp/websocketpp/Manifest
+++ b/dev-cpp/websocketpp/Manifest
@@ -2,5 +2,5 @@ AUX websocketpp-0.7.0-cmake-install.patch 970 BLAKE2B 2099c37b65d3f685f8b9745d92
AUX websocketpp-0.8.1-boost-1.70.patch 5976 BLAKE2B f3bccde47637c8938b1a0acf95d855692256434be130fafc34311bbbb337c655022b77a301f4524029dc2841e2a47d9975f7fbed3ed004b9bd1ba65d87c6bf30 SHA512 34df3fc78415e0fac8d73a2afb2faa2e1e2bfd6e2ae6458e48a89354dfaeb7f3a8d95c5e5e0ffa2f8d096508e5a9636184b403def95501d027f2c68f5e096052
AUX websocketpp-0.8.1-disable-test_transport-test_transport_asio_timers.patch 1227 BLAKE2B 26ac496842e4e23d254ba908679399ff8907253434430c887290cbd3b3beb14aaf69834cfc0b8f326f13c0f63ec7da535f0c8b438d20d7c1d2d4b5d5d2afb5cc SHA512 1ef7f2b71dcbeb386cd27bbf97f599f0c056b014423090ceb28e336c0f1527c6f8d6b04931144823c1d1deb14781508a0a6e869f69a9a232978851634f35fa0c
DIST websocketpp-0.8.1.tar.gz 699468 BLAKE2B e5769229b400d2f42e69541b07cfba17dcc82cdad20685a52ac1130c2fc4e94764a38d2e4f7c36101b11705e10c67eb149ba2c30750e7a6f63696d52c272fed2 SHA512 35e0261ed0285acf77d300768819bd380197de8acdf68223e2d7598481b9bfd69cb1653b435139771b1db6c16530c8d8cf9a887a8a6bba3fea126d0da4dbc13c
-EBUILD websocketpp-0.8.1-r1.ebuild 1041 BLAKE2B 2e3751948dea06b7892df0dba1c3a1222674a2ad1e3dcc525617c873451c8b371246c386ea41aa87f3a7a814fab8cfc90146188606a3e061a7d59197f82215f0 SHA512 fa6b55b79846c5d17422743e3398487bcaf95a42e835f10367c008b427058eb086a0819ab8b4b1fa566b59b386ce4aefae4a2f725bdba416485a459d6abaace0
+EBUILD websocketpp-0.8.1-r1.ebuild 1048 BLAKE2B bab31dca0ca2553b82e8065de7058cded1f4a218c11f839dab3f63a0ea7e97e16796c35382658bc4423234b8a0064c05b98d92bcd882d9e1fc319d2a67c7aa25 SHA512 86802c3b45293d8618e879346153328dac604f7c253d080f1188d1242f2180275fadb4c8781101c8440215f9c4cfb08265c51ba04ced011c8ee31c795213cca3
MISC metadata.xml 329 BLAKE2B bec1c49134f4f6cfd9c8487c0e607d609ed376853bd4022c3dbbee3f3932fb1925af6ec89c9ced2bafba9e3c2db67d3659e12e072e831ea0d3c95c5ae4ae621d SHA512 1cf8076fec3d5f414bc22c1eb74a1ebdb1f5c1711fd0b103c9da5cc8fc8f8fa30367c737d4b97bf22419cda1e327858817ef4b7109d703264ff6df3dd30a843c
diff --git a/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild b/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild
index 16030b37783e..051e22e7eeb3 100644
--- a/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild
+++ b/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="examples test"
RESTRICT="!test? ( test )"
diff --git a/dev-cpp/yaml-cpp/Manifest b/dev-cpp/yaml-cpp/Manifest
index d84f0699d03b..f6cfb1d9c5b3 100644
--- a/dev-cpp/yaml-cpp/Manifest
+++ b/dev-cpp/yaml-cpp/Manifest
@@ -6,5 +6,5 @@ DIST yaml-cpp-0.6.2.tar.gz 1396250 BLAKE2B be342c212c980cdb03349dbafbe1db0bb5811
DIST yaml-cpp-0.6.3.tar.gz 1398768 BLAKE2B 07abe1c56740105a0af2335bb1cd48086cb614d9d04c61342e53788bfb043fd7eb2629e441a0a5be50898b288f3526f1707c5fdf1d734395b6450c3103773b14 SHA512 68b9ce987cabc1dec79382f922de20cc2c222cb9c090ecb93dc686b048da5c917facf4fce6d8f72feea44b61e5a6770ed3b0c199c4cd4e6bde5b6245c09f8e49
EBUILD yaml-cpp-0.6.2.ebuild 923 BLAKE2B 56c096aaa6f7be157e5d83594968e2e65bfee0ea152a95f6a8d0d3b7aeff202a97ef8b70739b8430120978ecb416ddd94c15b9c20e25580fb12c4f011bf8251b SHA512 41a527eec285e4ce2122cedbcc6aed7ae38eb6b5ab21ae5d691205d7990a7fb6bebb9d8b93d4253939b96cd3b232e7b3ec596d5d3fc8ddaa2df35b13f0396af1
EBUILD yaml-cpp-0.6.3-r1.ebuild 972 BLAKE2B ce630cbf1b1f58728cda0a79f8d922f8fa57eb1dbd11e64efe3983bf1fbe52412c59d651ca9bd7d53006670238953e67ecea4e9b224590020635d6431cf3fd29 SHA512 8796a6ce430f75762a7b3689a2c5a85922ee6329aefe1d998d9b4b99f0b1dbbad6ca5dc492a8104dd99c392606073cc02ef14d656db766647b5177227efcead7
-EBUILD yaml-cpp-0.6.3-r2.ebuild 1014 BLAKE2B fbfad3a7dc92675e548f3c2ebe356a356b118d52bd153bb95b16f5fdd0f1be6e5c19f399b6d601749ee9fdaad9d15792c381736681e60fc2a4b56dac4ef243ce SHA512 09a659ac3b5d0735b6240b6b977692fbad235d347024e2f4a075886a91d33348fa69a4190febeef6cbe05fe3a40f7dd6d5aceb8e14c17031452380244110c3fb
+EBUILD yaml-cpp-0.6.3-r2.ebuild 1012 BLAKE2B 22566cbbfea39f50fc2addfb9695cb6ef8809511a51e2fdc7bd69b31149b1629ffb58bab0e763b4d9da76ba243cce169520fe5c838bd1f6c4a2a22c4db795e2c SHA512 a1fba028cc85e435e2e2616f334f1af0c2152043ea52dabeff0c27f71fdf616e6860e33cd67a993921fd65eaeb412b6b164f7f0919c46cc8289b465f8ed05c97
MISC metadata.xml 325 BLAKE2B 8e094a75d87d80e86efaf6ee191225ad0772dac343ae12ec84e73faffc17464c8431ee78018602127fd52441a6b18d09b58127b7d7ea1ee02163f58d327f0f3f SHA512 a4a5de1911c7bfeb37a3ca5aca8b3c044d51230164ac7d14566a9a4064e5202fac0e613089191ea959d0bb3df157049932d394d167e32fc8a432ab35e4cf24ae
diff --git a/dev-cpp/yaml-cpp/yaml-cpp-0.6.3-r2.ebuild b/dev-cpp/yaml-cpp/yaml-cpp-0.6.3-r2.ebuild
index db3c4f6dd2db..966f37d2c32c 100644
--- a/dev-cpp/yaml-cpp/yaml-cpp-0.6.3-r2.ebuild
+++ b/dev-cpp/yaml-cpp/yaml-cpp-0.6.3-r2.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/jbeder/${PN}/archive/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/0.6"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ppc ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
# test breaks build