summaryrefslogtreecommitdiff
path: root/dev-cpp/tree
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/tree')
-rw-r--r--dev-cpp/tree/Manifest4
-rw-r--r--dev-cpp/tree/files/tree-2.62-test.patch17
-rw-r--r--dev-cpp/tree/files/tree-2.81-test.patch36
-rw-r--r--dev-cpp/tree/tree-2.81.ebuild35
4 files changed, 54 insertions, 38 deletions
diff --git a/dev-cpp/tree/Manifest b/dev-cpp/tree/Manifest
index f62b8c1be1ae..8bbe9f1c7e3b 100644
--- a/dev-cpp/tree/Manifest
+++ b/dev-cpp/tree/Manifest
@@ -1,4 +1,4 @@
-AUX tree-2.62-test.patch 289 BLAKE2B 9074ea69e8c141b813e1854c5956eb016846196c9722ed3740a942caae7a0b086f37a4ab54e2faa81c73d310e1a2effdf8302f5703aa23a3052cc88e67638037 SHA512 7b63e0e60db5c636a13fe4cf8f8043fa4029a04b21eeb4cac08fcce4f433e0e6096927fffb7f345c319b46ea6043a9388a7419e8fa6c783f58b449f9ab1061db
+AUX tree-2.81-test.patch 550 BLAKE2B fe73799591f7f0c65d2f031792bc87b2d85bc143bf4adb35e04db712ef95a5ba0e15d8256aec28a0ac95d2306fa45de41d1a8dc5d53629d38ede35fe87cef256 SHA512 a859891662a1093f517f43a6ea14a4e1f7d81988d0fe83253554bea83bfdecde0b51ed05795d0d6f0b3494a7cde6db56a8304397ea5ad9fb2d446647f4301514
DIST tree-2.81.tar.gz 1167128 BLAKE2B ea92724b16fc7ea8a5f0036f5a7a57d000d66b332b4ba46139463f707f95922f38b1d4d56a6d2fca0a3c4ece8f11e28bbf4aa6bec5c5a7bc59ccaa36a01413d6 SHA512 85e910fdb19ffd03ae79302a95ebffdb44725fd9f291a61d6912f743b54fe9b3d1c863e00c7e75d238f428946809e42c7ae6379b1051688fb06ee6c6d761d294
-EBUILD tree-2.81.ebuild 930 BLAKE2B e936c307f73b44080c3174f5fd659e7c23a488807cf6e1b88cc2e67264e5478939a03f798e736ed453343303225c287734da844c6039450876385d29f55595a9 SHA512 5c04375499ecbf2fbf635536949163824cae501a53618fd07855bb5cd257b32d3728a36c72516f0259d407a8d88966750025a8b59633fbc79a7fe318f99b520f
+EBUILD tree-2.81.ebuild 790 BLAKE2B b4bec87a24051da0d7139d28588cc97b1cc72b80321658df594d7fde2afba5e3b87148c60ba321363e4e51bd85ba0c409d175faf96ca747c60a1645bdba6e84e SHA512 42eb10e31ecb206b0470805fc66da44a4504e016d2aaf9315661997596373d4aad1b87762861e360a5df5b23a28410009ab1991c7253026da5f48c9c9788e501
MISC metadata.xml 619 BLAKE2B ac5307e69727d5da71a21955619b8e322df63ebd877617c70b494ad541c470ef6df41a90ddf92b132452c293e2fbcbb85f2b72ee372f95491124ab50f7299ce2 SHA512 b2486910e891482643fc8464b11269ca6f83e87a8403edb78b2163e7fa37586b503597f0ea61332439322d257ad239d0c0a210707788043d555a96f3b712cc84
diff --git a/dev-cpp/tree/files/tree-2.62-test.patch b/dev-cpp/tree/files/tree-2.62-test.patch
deleted file mode 100644
index f7022426698b..000000000000
--- a/dev-cpp/tree/files/tree-2.62-test.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- test_tree.output 2008-08-28 11:16:11.000000000 +0100
-+++ test_tree.output.new 2009-04-15 19:06:53.174832287 +0100
-@@ -1,3 +1,8 @@
-+-----
-+hi
-+ 1
-+ 0
-+-----
- empty tree to begin with:
- 0
- 'more text' is sibling 2 in its sibling range
-@@ -309,3 +314,5 @@
- D
- I
- -----
-+G
-+H
diff --git a/dev-cpp/tree/files/tree-2.81-test.patch b/dev-cpp/tree/files/tree-2.81-test.patch
new file mode 100644
index 000000000000..c9e675dc7953
--- /dev/null
+++ b/dev-cpp/tree/files/tree-2.81-test.patch
@@ -0,0 +1,36 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,13 +1,6 @@
+-
+-%.o: %.cc
+- g++ -c -I. $^
+-
+-test1: test1.o
+- g++ -o test1 test1.o
+-
+-run_tests: test1 test1.req
+- ./test1 > test1.res
+- @diff test1.res test1.req
++check: test_tree
++ ./test_tree > mytest.output && \
++ diff -Nu test_tree.output mytest.output
+ @echo "*** All tests OK ***"
+
+ clean:
+--- a/test_tree.output
++++ b/test_tree.output
+@@ -1,3 +1,8 @@
++-----
++hi
++ 1
++ 0
++-----
+ empty tree to begin with:
+ 0
+ 'more text' is sibling 2 in its sibling range
+@@ -309,3 +314,5 @@
+ D
+ I
+ -----
++G
++H
diff --git a/dev-cpp/tree/tree-2.81.ebuild b/dev-cpp/tree/tree-2.81.ebuild
index db3b12d49646..cce24586ed8f 100644
--- a/dev-cpp/tree/tree-2.81.ebuild
+++ b/dev-cpp/tree/tree-2.81.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="An STL-like tree class"
HOMEPAGE="http://www.aei.mpg.de/~peekas/tree/"
@@ -14,28 +14,25 @@ SLOT="0"
KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="doc"
-S="${S}"/src
+S="${WORKDIR}/${P}/src"
-src_prepare() {
- rm Makefile || die
- epatch "${FILESDIR}"/${PN}-2.62-test.patch
-}
-
-src_test() {
- local test
- test="$(tc-getCXX) ${CXXFLAGS} ${LDAFLAGS} test_tree.cc -o test_tree"
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
- echo ${test}
- eval ${test} || die "compile test failed"
- ./test_tree > mytest.output || die "running test failed"
- diff -Nu test_tree.output mytest.output || die "test dist failed"
+src_configure() {
+ tc-export CXX
}
src_install() {
- insinto /usr/include
- doins tree.hh tree_util.hh
+ doheader tree.hh tree_util.hh
dodoc tree_example.cc
+
if use doc; then
- dohtml "${S}"/../doc/*
+ dodoc ../doc/treefig.*
+ rm ../doc/treefig.* || die
+
+ docinto html
+ rm ../doc/{doxygen_tree.config,favicon.ico,tree.tex} || die
+ dodoc -r ../doc/.
fi
+ docompress -x /usr/share/doc/${PF}
}