summaryrefslogtreecommitdiff
path: root/dev-cpp/tree/tree-2.81.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/tree/tree-2.81.ebuild')
-rw-r--r--dev-cpp/tree/tree-2.81.ebuild35
1 files changed, 16 insertions, 19 deletions
diff --git a/dev-cpp/tree/tree-2.81.ebuild b/dev-cpp/tree/tree-2.81.ebuild
index db3b12d49646..cce24586ed8f 100644
--- a/dev-cpp/tree/tree-2.81.ebuild
+++ b/dev-cpp/tree/tree-2.81.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="An STL-like tree class"
HOMEPAGE="http://www.aei.mpg.de/~peekas/tree/"
@@ -14,28 +14,25 @@ SLOT="0"
KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="doc"
-S="${S}"/src
+S="${WORKDIR}/${P}/src"
-src_prepare() {
- rm Makefile || die
- epatch "${FILESDIR}"/${PN}-2.62-test.patch
-}
-
-src_test() {
- local test
- test="$(tc-getCXX) ${CXXFLAGS} ${LDAFLAGS} test_tree.cc -o test_tree"
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
- echo ${test}
- eval ${test} || die "compile test failed"
- ./test_tree > mytest.output || die "running test failed"
- diff -Nu test_tree.output mytest.output || die "test dist failed"
+src_configure() {
+ tc-export CXX
}
src_install() {
- insinto /usr/include
- doins tree.hh tree_util.hh
+ doheader tree.hh tree_util.hh
dodoc tree_example.cc
+
if use doc; then
- dohtml "${S}"/../doc/*
+ dodoc ../doc/treefig.*
+ rm ../doc/treefig.* || die
+
+ docinto html
+ rm ../doc/{doxygen_tree.config,favicon.ico,tree.tex} || die
+ dodoc -r ../doc/.
fi
+ docompress -x /usr/share/doc/${PF}
}