summaryrefslogtreecommitdiff
path: root/dev-cpp/toml11/toml11-4.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/toml11/toml11-4.2.0.ebuild')
-rw-r--r--dev-cpp/toml11/toml11-4.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-cpp/toml11/toml11-4.2.0.ebuild b/dev-cpp/toml11/toml11-4.2.0.ebuild
new file mode 100644
index 000000000000..da9ac1e07435
--- /dev/null
+++ b/dev-cpp/toml11/toml11-4.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="TOML for Modern C++"
+HOMEPAGE="https://toruniina.github.io/toml11/
+ https://github.com/ToruNiina/toml11/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/ToruNiina/${PN}.git"
+else
+ SRC_URI="https://github.com/ToruNiina/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DOCS=( README.md README_ja.md )