summaryrefslogtreecommitdiff
path: root/dev-cpp/tclap/tclap-1.2.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/tclap/tclap-1.2.5.ebuild')
-rw-r--r--dev-cpp/tclap/tclap-1.2.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-cpp/tclap/tclap-1.2.5.ebuild b/dev-cpp/tclap/tclap-1.2.5.ebuild
new file mode 100644
index 000000000000..635d82ad2d8e
--- /dev/null
+++ b/dev-cpp/tclap/tclap-1.2.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2007-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple templatized C++ library for parsing command line arguments"
+HOMEPAGE="http://tclap.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf $(use_enable doc doxygen)
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}"/usr/share/doc/${PF}/html install
+}