summaryrefslogtreecommitdiff
path: root/dev-cpp/simpleini/simpleini-4.22.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/simpleini/simpleini-4.22.ebuild')
-rw-r--r--dev-cpp/simpleini/simpleini-4.22.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/simpleini/simpleini-4.22.ebuild b/dev-cpp/simpleini/simpleini-4.22.ebuild
new file mode 100644
index 000000000000..ccc5bfadc70d
--- /dev/null
+++ b/dev-cpp/simpleini/simpleini-4.22.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="C++ library providing a simple API to read and write INI-style files"
+HOMEPAGE="https://github.com/brofield/simpleini/"
+SRC_URI="https://github.com/brofield/simpleini/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest )"
+BDEPEND="test? ( virtual/pkgconfig )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.20-pkgconfig-var.patch
+)
+
+src_compile() {
+ if use test; then
+ tc-export CXX PKG_CONFIG
+ emake -C tests "${emakeargs[@]}"
+ fi
+}
+
+src_install() {
+ # note: this skips ConvertUTF, can use -DSI_CONVERT_ICU instead if needed
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ einstalldocs
+}